Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Deleted

[Q] Haier W910 problem - Help please!

OP mbuhboot

Prev Previous Post   Next Post Next
22nd March 2014, 06:19 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jan 2009

I've a two month old Haier W910 with stock ROM. The other day, when switching on the phone, the device displayed white snow. The device function normally - touch screen, audio, wireless and cellular (accept calls) but the screen continue to show white snow (like old analog TV).

I found a youtube video showing the same symptom and one of the comments suggested that the phone need to re-flash ROM and it will solve the problem. The youtube video posted confirmed that it did. Since then and for the past 3-4 days I've been trying to flash my phone but it doesn't work. I'm able to put the phone in "Download mode" and use fastboot to flash a recovery boot, oem unlock works but I can't seems to reflash full ROM: I can't use the "update.zip" method as a I can't see the screen and when I try to flash different ROMs under www.needrom.dom using 'fastboot update' it keep saying:

archive does not contain 'android-info.txt'
archive does not contain 'android-product.txt'
error: update package has no android-info.txt or android-product.txt

I can't flash the rom in "recovery mode" as I can't see the menu and select the proper option.

I guess I also need to replace the bootloader as the screen is white snow from the very beginning..

So the question is: how can I do a device full reflash WITHOUT using the screen (preferably in fastboot)

btw: fastboot recognizes the devices. but adb.exe does not. funny.
Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes