Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,098 Members 46,612 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Soft-bricked Galaxy 2 SGH-I777. Odin of no use--drivers won't intall

Tip us?
 
keltaurn
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Feb 2014
Cool [Q] Soft-bricked Galaxy 2 SGH-I777. Odin of no use--drivers won't intall

I literally tried everything with this phone. Was able to root, went to install siyah kernel from zip and now I get the samsung logo. I can boot into CWM recovery, but none of the functions work--just hangs on the hat. Any ideas are greatly appreciated. Thanks. I just want to flash it to stock and sell it on ebay. Loved this damn phone. I just upgraded to the S3.
 
SteveMurphy
Old
#2  
SteveMurphy's Avatar
Recognized Contributor
Thanks Meter 2105
Posts: 1,213
Join Date: Apr 2012
Location: Atlanta
Quote:
Originally Posted by keltaurn View Post
I just want to flash it to stock...
Use creepyncrawly's guide:

http://forum.xda-developers.com/show....php?t=1313659
The Following 3 Users Say Thank You to SteveMurphy For This Useful Post: [ Click to Expand ]
 
creepyncrawly
Old
#3  
Recognized Contributor
Thanks Meter 2959
Posts: 2,453
Join Date: Sep 2010

 
DONATE TO ME
Quote:
Originally Posted by keltaurn View Post
I literally tried everything with this phone. Was able to root, went to install siyah kernel from zip and now I get the samsung logo. I can boot into CWM recovery, but none of the functions work--just hangs on the hat. Any ideas are greatly appreciated. Thanks. I just want to flash it to stock and sell it on ebay. Loved this damn phone. I just upgraded to the S3.
Okay. I've read all your posts. You have not provided any information that would be useful to troubleshoot your issue. However, I can make a few guesses that could possibly help, and then you need to give us some details so we can help further.

1) You don't say if the phone is stock and what version of stock was on it, or whether you have custom firmware. I'm assuming you have stock, then rooted and installed the wrong version of Siyah, or perhaps a version for Siyah not made for the I777. As far as not being able to use the functions when you boot into CWM, it is probably because the select key is the home button, and not the power button.

2) You can't flash back to stock using CWM. I'm not aware of any zip with straight stock. You must use Odin to flash stock. Since you are having connection problems using Odin, I am guessing that you either did not follow the correct sequence, or that you did not install the correct USB driver on your Windows pc. Another possibility is that you have a bad usb cable or connection.

3) If you spent a month searching on the xda forum for this phone, you would have found any number of posts by myself that detail all the answers to all the questions you have posed so far. I've posted these things several dozens of times.

Please let us know if any of the above helps you. Please search these forums for issues connecting to Odin. If you are unable to find any answers that way, please post back here with more detailed information.
The Following 4 Users Say Thank You to creepyncrawly For This Useful Post: [ Click to Expand ]
 
jball
Old
#4  
jball's Avatar
Senior Member
Thanks Meter 147
Posts: 690
Join Date: Jan 2012
Location: Amber
I have an issue with my S2 I777.
When it last booted it was on cyanogenmod 9 with siyah v4.3.3 and is a good setup. My problem is i let it die/dead battery and didn't bother to plug it in for about 4 days or so.now when i try turning it on with any button combo i get nothing.when i plug it in the battery icon just flashes and not even my jig will get it into download mode to use odin

Sent from my Nexus 5 using Tapatalk
 
cyril279
Old
#5  
cyril279's Avatar
Senior Member
Thanks Meter 1032
Posts: 510
Join Date: Jun 2013
Default enter download mode WITHOUT a battery in the phone

follow these steps:

-remove the battery from the phone
-hold down vol+ & vol- & power, then plug in the usb cable
-continue holding the buttons until the phone shows the download mode prompt
-put the battery into the phone (while the phone is at the download prompt)

happy flashing
-Cyril

Quote:
Originally Posted by jball View Post
I have an issue with my S2 I777.
When it last booted it was on cyanogenmod 9 with siyah v4.3.3 and is a good setup. My problem is i let it die/dead battery and didn't bother to plug it in for about 4 days or so.now when i try turning it on with any button combo i get nothing.when i plug it in the battery icon just flashes and not even my jig will get it into download mode to use odin

Sent from my Nexus 5 using Tapatalk
The Following 2 Users Say Thank You to cyril279 For This Useful Post: [ Click to Expand ]
 
jball
Old
#6  
jball's Avatar
Senior Member
Thanks Meter 147
Posts: 690
Join Date: Jan 2012
Location: Amber
Quote:
Originally Posted by cyril279 View Post
follow these steps:

-remove the battery from the phone
-hold down vol+ & vol- & power, then plug in the usb cable
-continue holding the buttons until the phone shows the download mode prompt
-put the battery into the phone (while the phone is at the download prompt)

happy flashing
-Cyril
K that part worked as far as getting into download mode so the phone is salvageable. However as soon as i put the battery in wile plugged in and in download mode it just shuts down.wile still plugged in i repeat the button combo and it does flash in red that the battery is to low .before posting in here it had been plugged in for one day and all last night. I was getting excellent battery life before this issue started .have tried multiple charger cords

?

Sent from my Nexus 5 using Tapatalk
 
cyril279
Old
#7  
cyril279's Avatar
Senior Member
Thanks Meter 1032
Posts: 510
Join Date: Jun 2013
I have heard with these devices that they behave poorly when the battery is allowed to die completely, citing that the phone needs power to start/maintain the charging circuit (it sounds silly, I agree). One common suggestion is to purchase an external charger, or go to a local mobile store and ask them to put the battery on a charger for a few minutes, or to simply purchase another battery.

Hopefully one of our peers can chime-in to verify this, or provide other options.

Quote:
Originally Posted by jball View Post
K that part worked as far as getting into download mode so the phone is salvageable. However as soon as i put the battery in wile plugged in and in download mode it just shuts down.wile still plugged in i repeat the button combo and it does flash in red that the battery is to low .before posting in here it had been plugged in for one day and all last night. I was getting excellent battery life before this issue started .have tried multiple charger cords

?

Sent from my Nexus 5 using Tapatalk
The Following 4 Users Say Thank You to cyril279 For This Useful Post: [ Click to Expand ]
 
jball
Old
#8  
jball's Avatar
Senior Member
Thanks Meter 147
Posts: 690
Join Date: Jan 2012
Location: Amber
I have a dock/external charger and extra battery being shipped.
I will let you know how it goes

Sent from my Nexus 5 using Tapatalk
 
jball
Old
#9  
jball's Avatar
Senior Member
Thanks Meter 147
Posts: 690
Join Date: Jan 2012
Location: Amber
Update
This is the external charger i received today
http://www.amazon.com/gp/aw/d/B0080XSEYI
Wile charging it indicates red and when finished charging it turns blue.
100% battery life just like it did before i let it drain.

Sent from my Nexus 5 using Tapatalk

The Following 2 Users Say Thank You to jball For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes