5,594,653 Members 33,198 Now Online
XDA Developers Android and Mobile Development Forum

ML2 Update| GPS stopped working

Tip us?
 
TransformixS4
Old
#1  
TransformixS4's Avatar
Senior Member - OP
Thanks Meter 130
Posts: 261
Join Date: Mar 2013
Location: NY
Default ML2 Update| GPS stopped working

After the ML2 4.3 update my GPs decided to not work. I tried so many fixes but none worked.
It searches for GPS forever.
I need to root to fix this but if anyone have the same issue or a fix without root i would appreciate it!
-TransformixS4
Galaxy Note 3 and 4.4 KitKat Thread
 
ChristopherXDA
Old
(Last edited by ChristopherXDA; 2nd February 2014 at 04:25 PM.)
#2  
Member
Thanks Meter 5
Posts: 71
Join Date: Apr 2013
Location: CT
Quote:
Originally Posted by TransformixS4 View Post
After the ML2 4.3 update my GPs decided to not work. I tried so many fixes but none worked.
It searches for GPS forever.
I need to root to fix this but if anyone have the same issue or a fix without root i would appreciate it!
-TransformixS4
I am having the same issue!

So far I've:

1. Toggled GPS Off -> rebooted --> toggled back on
2. Cleared all data on Google Maps App -> uninstalled updates --> Downloaded the latest version in play store.
3. "Turned Off" apps and widgets that obviously use GPS, including some that don't, e.g. bloatware like blurb etc. and cleared their data.
4. Unchecked in the default Internet browser app the 'use location' option
5. Pulled sim and battery
6. Booted into safemode
7. Went to Samsung Desk at best buy to maybe reflash firmware but the device is not detected, probably because they don't have the ML2 (rep claimed it was because phone was discontinued).
Device: Iphone 4S --> AT&T HTC One -> Samsung Galaxy S4 Active
Case: Cima S Line.
Rom: Trickdroid or ARHD on HTC.
The Following User Says Thank You to ChristopherXDA For This Useful Post: [ Click to Expand ]
 
TransformixS4
Old
#3  
TransformixS4's Avatar
Senior Member - OP
Thanks Meter 130
Posts: 261
Join Date: Mar 2013
Location: NY
Default Yea...

Quote:
Originally Posted by ChristopherXDA View Post
I am having the same issue!

So far I've:

1. Toggled GPS Off -> rebooted --> toggled back on
2. Cleared all data on Google Maps App -> uninstalled updates --> Downloaded the latest version in play store.
3. "Turned Off" apps and widgets that obviously use GPS, including some that don't, e.g. bloatware like blurb etc. and cleared their data.
4. Unchecked in the default Internet browser app the 'use location' option
5. Pulled sim and battery
6. Booted into safemode
7. Went to Samsung Desk to maybe reflash firmware but the device is not detected, probably because they don't have the ML2 (rep claimed it was because phone was discontinued).
1. DISCOUNTED?! NOOOOOO.
2. I factory reseted. Cleared cache. Flashed ML2. No hope...
3. Chatted with Samsung, they said to bring my phone in so they can check if the hardware has any problems.
Galaxy Note 3 and 4.4 KitKat Thread
 
ChristopherXDA
Old
(Last edited by ChristopherXDA; 22nd February 2014 at 01:43 AM.)
#4  
Member
Thanks Meter 5
Posts: 71
Join Date: Apr 2013
Location: CT
Just thought I'd post a follow up. This evening I did a full factory reset via Odin- replacing everything- and GPS still didn't work. The phone just won't grab a satellite even though everything else is fine/no physical damage. Pretty much blows. Hopefully AT&T will replace this because the Samsung guy at best buy was like mail it Samsung...but what do i do in the freakin mean time? I wish Samsung would send me a new phone and wait for me to return this one, even if it meant a temp billing on my credit card.

Also, a sidenote- I used Ad-Away on 4.2 and when I updated to 4.3 ML2, my Hosts file with all the ad blocking entries remained. But now that I Odin-ed 4.3ML2 full reset, I obviously lost that, and am now realizing how many goddamn ads there are. In everything! #EndRant.
Device: Iphone 4S --> AT&T HTC One -> Samsung Galaxy S4 Active
Case: Cima S Line.
Rom: Trickdroid or ARHD on HTC.
 
jholber2
Old
#5  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Apr 2008
I'm having the same issue. Worked fine on 4.2 and 4.3 mi2. It has to be software... I took it to Best Buy this weekend 3/22/14 and they re-flashed 4.3 without any problems. Still no gps lock... My wifi works but drops repeatedly every few minutes~seconds on my home router (Cisco e1200). Works fine on my work router (Linksys WRT150N).
 
najay
Old
(Last edited by najay; 1st March 2014 at 12:33 AM.)
#6  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Aug 2010
I am seeing the same issue with GPS. It was working fine when I first got the phone, and now, after the 4.3 ml2 update, it drops out every few minutes. I went back to using my nexus 7 tablet for nav.duty. I am also pretty frustrated about no having root.
 
ChristopherXDA
Old
#7  
Member
Thanks Meter 5
Posts: 71
Join Date: Apr 2013
Location: CT
So some folks are saying their GPS was fixed by flashing the MF1 modem with Odin. I tried it and it did flash MF1 but my GPS is still not getting a fix. THe thread is over here: http://forum.xda-developers.com/show....php?t=2691264
Device: Iphone 4S --> AT&T HTC One -> Samsung Galaxy S4 Active
Case: Cima S Line.
Rom: Trickdroid or ARHD on HTC.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Motorola Droid RAZR HD and M to Receive KitKat in a “Few More Weeks”

Verizon and Motorola shocked us all back in November when … more

[APK] YouTube Update to 5.6 Now Lets You Cast Live Video to Your Chromecast

Earlier today, we talked about how Google brought two new apps to … more

[OTA Captured] Android 4.4.2 Now Rolling Out to the AT&T Galaxy S 4 Active

A little under two months ago, AT&T started rolling out … more