Backup+ Lets You Backup Your App Data on Android Lollipop

Even though Android 5.0 Lollipop hasn’t yet seen its official release, quite … more

TechTalk Compiles All the Android News You Need in One App

If you’re as obsessed with mobile devices as the vast majority of our forum … more

Android App Review: Google Inbox to Improve Your Life – XDA TV

Recently, Google+ exploded with the announcement of Google Inbox, as … more

Damp the LG G3 Thermal Throttling

As our mobile devices grow thinner and more powerfulwith each passing generation, it’s inevitable … more
Post Reply

ML2 Update| GPS stopped working

OP TransformixS4

29th January 2014, 06:07 PM   |  #1  
TransformixS4's Avatar
OP Senior Member
Flag NY
Thanks Meter: 183
 
465 posts
Join Date:Joined: Mar 2013
More
After the ML2 4.3 update my GPs decided to not work. I tried so many fixes but none worked.
It searches for GPS forever.
I need to root to fix this but if anyone have the same issue or a fix without root i would appreciate it!
-TransformixS4
30th January 2014, 08:00 PM   |  #2  
Member
Flag CT
Thanks Meter: 6
 
78 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by TransformixS4

After the ML2 4.3 update my GPs decided to not work. I tried so many fixes but none worked.
It searches for GPS forever.
I need to root to fix this but if anyone have the same issue or a fix without root i would appreciate it!
-TransformixS4

I am having the same issue!

So far I've:

1. Toggled GPS Off -> rebooted --> toggled back on
2. Cleared all data on Google Maps App -> uninstalled updates --> Downloaded the latest version in play store.
3. "Turned Off" apps and widgets that obviously use GPS, including some that don't, e.g. bloatware like blurb etc. and cleared their data.
4. Unchecked in the default Internet browser app the 'use location' option
5. Pulled sim and battery
6. Booted into safemode
7. Went to Samsung Desk at best buy to maybe reflash firmware but the device is not detected, probably because they don't have the ML2 (rep claimed it was because phone was discontinued).
Last edited by ChristopherXDA; 2nd February 2014 at 04:25 PM.
The Following User Says Thank You to ChristopherXDA For This Useful Post: [ View ]
1st February 2014, 07:17 PM   |  #3  
TransformixS4's Avatar
OP Senior Member
Flag NY
Thanks Meter: 183
 
465 posts
Join Date:Joined: Mar 2013
More
Yea...
Quote:
Originally Posted by ChristopherXDA

I am having the same issue!

So far I've:

1. Toggled GPS Off -> rebooted --> toggled back on
2. Cleared all data on Google Maps App -> uninstalled updates --> Downloaded the latest version in play store.
3. "Turned Off" apps and widgets that obviously use GPS, including some that don't, e.g. bloatware like blurb etc. and cleared their data.
4. Unchecked in the default Internet browser app the 'use location' option
5. Pulled sim and battery
6. Booted into safemode
7. Went to Samsung Desk to maybe reflash firmware but the device is not detected, probably because they don't have the ML2 (rep claimed it was because phone was discontinued).

1. DISCOUNTED?! NOOOOOO.
2. I factory reseted. Cleared cache. Flashed ML2. No hope...
3. Chatted with Samsung, they said to bring my phone in so they can check if the hardware has any problems.
22nd February 2014, 01:41 AM   |  #4  
Member
Flag CT
Thanks Meter: 6
 
78 posts
Join Date:Joined: Apr 2013
More
Just thought I'd post a follow up. This evening I did a full factory reset via Odin- replacing everything- and GPS still didn't work. The phone just won't grab a satellite even though everything else is fine/no physical damage. Pretty much blows. Hopefully AT&T will replace this because the Samsung guy at best buy was like mail it Samsung...but what do i do in the freakin mean time? I wish Samsung would send me a new phone and wait for me to return this one, even if it meant a temp billing on my credit card.

Also, a sidenote- I used Ad-Away on 4.2 and when I updated to 4.3 ML2, my Hosts file with all the ad blocking entries remained. But now that I Odin-ed 4.3ML2 full reset, I obviously lost that, and am now realizing how many goddamn ads there are. In everything! #EndRant.
Last edited by ChristopherXDA; 22nd February 2014 at 01:43 AM.
25th February 2014, 12:23 AM   |  #5  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Apr 2008
I'm having the same issue. Worked fine on 4.2 and 4.3 mi2. It has to be software... I took it to Best Buy this weekend 3/22/14 and they re-flashed 4.3 without any problems. Still no gps lock... My wifi works but drops repeatedly every few minutes~seconds on my home router (Cisco e1200). Works fine on my work router (Linksys WRT150N).
1st March 2014, 12:27 AM   |  #6  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Aug 2010
I am seeing the same issue with GPS. It was working fine when I first got the phone, and now, after the 4.3 ml2 update, it drops out every few minutes. I went back to using my nexus 7 tablet for nav.duty. I am also pretty frustrated about no having root.
Last edited by najay; 1st March 2014 at 12:33 AM.
24th March 2014, 01:27 AM   |  #7  
Member
Flag CT
Thanks Meter: 6
 
78 posts
Join Date:Joined: Apr 2013
More
So some folks are saying their GPS was fixed by flashing the MF1 modem with Odin. I tried it and it did flash MF1 but my GPS is still not getting a fix. THe thread is over here: http://forum.xda-developers.com/show....php?t=2691264

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes