Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,615 Members 46,213 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Error 0017 flashing stock firmware

Tip us?
 
dunc4n88
Old
#21  
dunc4n88's Avatar
Senior Member
Thanks Meter 218
Posts: 592
Join Date: Nov 2011
another suggestion boot into cwm and try to mount everything the data the cache everything and see if it mounts them if it does then that would indicate that the vital partitions are ok if they all mount try installing rom

report back

Sent from my C1905 using XDA Premium 4 mobile app

---------- Post added at 09:19 PM ---------- Previous post was at 09:19 PM ----------

but first flash the cm11 kernel before hand

Sent from my C1905 using XDA Premium 4 mobile app
 
goocreations
Old
#22  
Junior Member - OP
Thanks Meter 4
Posts: 19
Join Date: Feb 2014
Quote:
Originally Posted by dunc4n88 View Post
another suggestion boot into cwm and try to mount everything the data the cache everything and see if it mounts them if it does then that would indicate that the vital partitions are ok if they all mount try installing rom

report back

Sent from my C1905 using XDA Premium 4 mobile app

---------- Post added at 09:19 PM ---------- Previous post was at 09:19 PM ----------

but first flash the cm11 kernel before hand

Sent from my C1905 using XDA Premium 4 mobile app
All partitions can be formatted and mounted - so my partition table might not be the problem.
I think I've now tried every possible combination in CWM. These are the options I've tried:

1. Wipe data and cache, format all partitions (data, system, boot, cahce), unmounted all partitions (), installed zip = symlink error
2. Wipe data and cache, format all partitions, mounted all partitions, installed zip = symlink error
3. Wipe data and cache, mounted all partitions, installed zip = symlink error
4. Wipe data and cache, unmounted all partitions, installed zip = symlink error
5. No wiping or formatting, unmounted all partitions, installed zip = symlink error
6. No wiping or formatting, mounted all partitions, installed zip = symlink error

But now after all this, I viewed the log (under advanced):

Code:
Select Code
minzip: Extracted file "/system/app/WAPPushManager.apk"
minzip: Extracted file "/system/app/WhisperPush.apk"
minzip: Can't create target file "/system/bin/adb": Read-only file system
symlink: failed to remove /system/bin/su: Read-only file system
symlink: failed to symlink /system/bin/su to ../xbin/su: File exists
script aborted: symlink: some symlink failed
symlink: some symlink failed
E:Error in /storage/sdcard1/cm-11-20140204-UNOFFICIAL-c1905.zip
(Status 7)
Installation aborted.
I:using /data/media for /sdcard/0/clockworkmod/.
last_install_path.
I:Can't partition non mmcblk device: /devices/platform/msm_sdcc.3/mmc_host/mmc1
Can you do anything with this?
 
dunc4n88
Old
#23  
dunc4n88's Avatar
Senior Member
Thanks Meter 218
Posts: 592
Join Date: Nov 2011
looking at the top lines looks like the device is locked un a read only state and also the mmcblk is the partition tables so looks like they are corrupted aswell could be wrong tho just looked through mine and the bottom address doesnt exist on my phone in them directories there somewhere else think its gonna be a case of using adb to fix this but im no good with adb we need another person here to give guidence aswell ill pm another member who might be able to help

Sent from my C1905 using XDA Premium 4 mobile app
The Following User Says Thank You to dunc4n88 For This Useful Post: [ Click to Expand ]
 
goocreations
Old
#24  
Junior Member - OP
Thanks Meter 4
Posts: 19
Join Date: Feb 2014
Thanks, I appriciate it.
 
jckelsall
Old
#25  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Jan 2014
Hey, I am having a similar problem - I accidentally unplugged my Xperia M (Single SIM, C1905) while flashing a new boot.img. Now, the only sign of anything happening is the LED flashing red when plugged in. To fix this problem, I tried to boot into fastboot to reflash the boot.img, but my phone will not boot into fastboot at all.
I have tried to reflash the stock firmware using flashtool, and repeatedly get a similar error to yours:
 
23/058/2014 12:58:08 - INFO - <- This level is successfully initialized
23/058/2014 13:03:45 - INFO - Flashtool Version 0.9.15.0 built on 15-03-2014 23:00:00
23/003/2014 13:03:46 - INFO - Device disconnected
23/003/2014 13:03:54 - INFO - Selected Bundle for Sony Xperia M (C1905). FW release : 15.1.C.2.8. Customization : CE
23/003/2014 13:03:54 - INFO - Preparing files for flashing
23/004/2014 13:04:28 - INFO - Device connected in flash mode
23/004/2014 13:04:40 - INFO - Please connect your device into flashmode.
23/004/2014 13:04:41 - INFO - Device disconnected
23/004/2014 13:04:57 - INFO - Device connected in flash mode
23/004/2014 13:04:57 - INFO - Opening device for R/W
23/004/2014 13:04:57 - INFO - Reading device information
23/004/2014 13:04:57 - INFO - Phone ready for flashmode operations.
23/004/2014 13:04:57 - INFO - Start Flashing
23/004/2014 13:04:57 - INFO - Processing loader.sin
23/004/2014 13:04:57 - INFO - Checking header
23/004/2014 13:04:57 - ERROR - Processing of loader.sin finished with errors.
23/004/2014 13:04:57 - INFO - Ending flash session
23/004/2014 13:04:57 - ERROR - ERR_SEVERITY="MINOR";ERR_CODE="0017";ERR_DYNAMIC=" 0x80080021 ";

The boot partition on an Xperia M is located in dev/block/mmcblk0p17, so I think that the 'ERR_CODE="0017"' could be to do with the boot partition number.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes