Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

dirty sandisk 64gb Sd card volume on galaxy note 2

OP sifat004

6th January 2014, 10:07 AM   |  #1  
OP Senior Member
Thanks Meter: 8
 
154 posts
Join Date:Joined: Apr 2011
Hello all..I am facing a weird problem of my sandisk 64gb class 10 card. Suddenly I cant copy anything on it. Its in exfat format. I have tried to format it using card reader but couldnt. Even I tried to format it by phone. But not working.

I can access it but cant delete anything or format.

Plz someone help as I have no warranty as purchased from other country.

Thanks in advance.
25th March 2014, 01:37 AM   |  #2  
Member
Thanks Meter: 0
 
45 posts
Join Date:Joined: Jan 2013
hi! try sending an email to sandisk. i faced the same issue before and when i sent them an email, they had me mail them the sd card and they sent me a new one. the only thing you need to pay for is the shipping in sending them your faulty card. they're going to shoulder the shipping in sending you a new one. haven't really found a way to resolve the issue, though, but i hope this helps.
26th March 2014, 06:03 AM   |  #3  
cyberboob's Avatar
Senior Member
Thanks Meter: 386
 
656 posts
Join Date:Joined: Apr 2012
More
as amPOGlko said... try returning it. There's a lot of sites saying the same thing... sandisk and samsung phones not working well together. Who knows?
If they don't send you a new one, then maybe you can try Samsung or Toshiba SDcard instead. Good luck!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes