Android 5.0 Leaked for the Samsung Galaxy Note 3

Android Lollipop is still making its way to many new devices. Firmware updates have been … more

Learn to Sync Files Between Android And PC with Unison

Dropbox and similar cloud services are great if youre planning to keep your files … more

OnePlus Indian Ban Lifted, Android One Expanding – XDA TV

Android 5.0.1 Lollipop is available for the Nvidia SHIELD Tablet! That and … more

Nvidia and Robotics w/ Barrett Williams – XDA:DevCon 2014

Robotics continues to dominate our videos from this years XDA:DevCon 2014 in … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Cant Flash Anything with Flashtool

OP bbmaster123

25th March 2014, 01:10 AM   |  #1  
OP Member
Thanks Meter: 1
 
34 posts
Join Date:Joined: Sep 2011
Hi all. I've got an xperia x10a that doesnt turn on. I've read a lot of the other similar threads on this forum, and the go to answer to fix a bricked x10 is "flash stock rom with flashtool". the problem for me is that nothing will flash. it comes up as a different error, depending on the version of flashtool I use, but its generally either
"Error. aborted"

or

"error processing loader.sin"

i've tried multiple kernels and roms. anything I can do?
25th March 2014, 10:24 AM   |  #2  
TangVLD's Avatar
Member
Flag VLDV
Thanks Meter: 11
 
42 posts
Join Date:Joined: Jan 2011
More
Did you install the drivers?
25th March 2014, 07:37 PM   |  #3  
OP Member
Thanks Meter: 1
 
34 posts
Join Date:Joined: Sep 2011
yes, I did install the drivers.
26th March 2014, 01:28 AM   |  #4  
TangVLD's Avatar
Member
Flag VLDV
Thanks Meter: 11
 
42 posts
Join Date:Joined: Jan 2011
More
both X10 ADB drivers and flashmode drivers?
26th March 2014, 06:46 PM   |  #5  
OP Member
Thanks Meter: 1
 
34 posts
Join Date:Joined: Sep 2011
yes dude, all the drivers are installed correctly haha. it detects the phone, it just refuses to flash it. This is my output:

26/043/2014 12:43:29 - INFO - <- This level is successfully initialized
26/043/2014 12:43:32 - INFO - Device connected in flash mode
26/043/2014 12:43:47 - INFO - Selected x10_2.3_Gingerbread_aro.ftf
26/043/2014 12:43:47 - INFO - Preparing files for flashing
26/043/2014 12:43:49 - INFO - Searching Xperia....
26/043/2014 12:43:49 - INFO - Found at USB\VID_0FCE&PID_ADDE\6&79BEE0&0&2
26/043/2014 12:43:49 - INFO - Start Flashing
26/044/2014 12:44:54 - INFO -
26/046/2014 12:46:09 - ERROR - Error flashing. Aborted
26/046/2014 12:46:09 - INFO - Now unplug the device and power it on
26/046/2014 12:46:09 - INFO - Then go to application settings
26/046/2014 12:46:09 - INFO - turn on Unknown Sources and Debugging

The other Version of flashtool gives me this:

26/022/2014 13:22:06 - INFO - Device connected in flash mode
26/022/2014 13:22:17 - INFO - Selected Bundle for x10. FW release : 2.3.3. Customization : stock-with-xrecovery-v3
26/022/2014 13:22:17 - INFO - Preparing files for flashing
26/022/2014 13:22:17 - INFO - Please connect your device into flashmode.
26/022/2014 13:22:18 - INFO - Opening device for R/W
26/022/2014 13:22:18 - INFO - Start Flashing
26/022/2014 13:22:18 - INFO - Processing loader.sin
26/022/2014 13:22:18 - INFO - Checking header
26/022/2014 13:22:18 - ERROR - Processing of loader.sin finished with errors.
26/022/2014 13:22:18 - INFO - Ending flash session
26/022/2014 13:22:18 - ERROR -
26/022/2014 13:22:18 - ERROR - Error flashing. Aborted
26/022/2014 13:22:18 - INFO - Device connected in flash mode


For the record, I've also tried PC companion and SEUS and they don't restore the phone either
Last edited by bbmaster123; 26th March 2014 at 07:23 PM. Reason: adding info
26th March 2014, 09:47 PM   |  #6  
dekefake's Avatar
Senior Member
Flag /system/usr
Thanks Meter: 311
 
268 posts
Join Date:Joined: Oct 2013
Donate to Me
More
Quote:
Originally Posted by bbmaster123

It just refuses to flash it...

Did you unlocked the Bootloader ? If not, try unlock it. If it doesn't wants to flash, try to pull out the battery, connect the USB with battery out, run flash process, and when your computer is waiting for phone connect, hold back button and pull the battery. The flash will launch, and if it fails, retry pulling out the battery and re-run the flash

This issue can be due to a bad USB connection ( the connector may be damaged and do intempestive disconnects )

EDIT: Download the latest version of Flashtool and disable the final verification before launch flash
Last edited by dekefake; 26th March 2014 at 09:49 PM.
The Following 2 Users Say Thank You to dekefake For This Useful Post: [ View ]
26th March 2014, 10:27 PM   |  #7  
OP Member
Thanks Meter: 1
 
34 posts
Join Date:Joined: Sep 2011
Quote:
Originally Posted by dekefake

Did you unlocked the Bootloader ? If not, try unlock it. If it doesn't wants to flash, try to pull out the battery, connect the USB with battery out, run flash process, and when your computer is waiting for phone connect, hold back button and pull the battery. The flash will launch, and if it fails, retry pulling out the battery and re-run the flash

This issue can be due to a bad USB connection ( the connector may be damaged and do intempestive disconnects )

EDIT: Download the latest version of Flashtool and disable the final verification before launch flash


I can't lock/unlock the bootloader in flash mode AFAIK, and I can't load the phone into any other mode. it won't even show the Ericsson logo, just black screen. But I will follow your instructions with the battery and the verification, and see how that goes. I just finished uninstalling everything for a fresh slate. I'll let ya know in a few minutes.

EDIT: okay, followed your instructions. it still doesn't flash, unfortunately. Heres my new output:

26/049/2014 16:49:10 - INFO - <- This level is successfully initialized
26/049/2014 16:49:10 - INFO - Flashtool Version 0.9.15.0 built on 15-03-2014 23:00:00
26/049/2014 16:49:14 - INFO - Device connected in flash mode
26/049/2014 16:49:18 - INFO - Device disconnected
26/049/2014 16:49:24 - INFO - Selected Bundle for x10. FW release : 2.3.3. Customization : stock-with-xrecovery-v3
26/049/2014 16:49:24 - INFO - Preparing files for flashing
26/049/2014 16:49:24 - INFO - Please connect your device into flashmode.
26/049/2014 16:49:32 - INFO - Device connected in flash mode
26/049/2014 16:49:32 - INFO - Opening device for R/W
26/049/2014 16:49:33 - INFO - Reading device information
26/049/2014 16:49:33 - INFO - Phone ready for flashmode operations.
26/049/2014 16:49:33 - INFO - Current device : X10i - CB511K0TVL - 1241-1846_R1C - 1227-4612_2.1.A.0.435 - WORLD-1-4-8_3.0.1.G.0.75
26/049/2014 16:49:33 - INFO - Start Flashing
26/049/2014 16:49:33 - INFO - Using an unofficial loader
26/049/2014 16:49:33 - INFO - Processing loader_unlocked.sin
26/049/2014 16:49:33 - INFO - Checking header
26/049/2014 16:49:33 - ERROR - Processing of loader_unlocked.sin finished with errors.
26/049/2014 16:49:33 - INFO - Ending flash session
26/049/2014 16:49:33 - ERROR - ERR_SEVERITY="MAJOR";ERR_CLASS="SECURITY_CLASS";ER R_DYNAMIC="SIN header verification failed"
26/049/2014 16:49:33 - ERROR - Error flashing. Aborted
26/049/2014 16:49:33 - INFO - Device connected in flash mode
26/049/2014 16:49:34 - INFO - Device disconnected
26/049/2014 16:49:35 - INFO - Device connected in flash mode
26/049/2014 16:49:41 - INFO - Selected Bundle for x10. FW release : 2.3.3. Customization : stock-with-xrecovery-v3
26/049/2014 16:49:41 - INFO - Preparing files for flashing
26/049/2014 16:49:41 - INFO - Please connect your device into flashmode.
26/049/2014 16:49:41 - INFO - Opening device for R/W
26/049/2014 16:49:41 - INFO - Reading device information

--Here it hangs indefinitely. if I try to force it to flash again, I get this:

26/053/2014 16:53:20 - ERROR - Processing of loader.sin finished with errors.
26/053/2014 16:53:20 - INFO - Ending flash session
26/053/2014 16:53:20 - ERROR - Error in processHeader : 6 : The handle is invalid.
26/053/2014 16:53:20 - ERROR - Error flashing. Aborted
26/053/2014 16:53:20 - INFO - Device connected in flash mode
Last edited by bbmaster123; 26th March 2014 at 10:54 PM. Reason: New info
26th March 2014, 10:43 PM   |  #8  
dekefake's Avatar
Senior Member
Flag /system/usr
Thanks Meter: 311
 
268 posts
Join Date:Joined: Oct 2013
Donate to Me
More
Quote:
Originally Posted by bbmaster123

I can't lock/unlock the bootloader in flash mode

Ok good

Try flash it if you can access flash mode : http://www.mediafire.com/download/g2....3_Generic.rar
26th March 2014, 10:57 PM   |  #9  
OP Member
Thanks Meter: 1
 
34 posts
Join Date:Joined: Sep 2011
Quote:
Originally Posted by dekefake

Ok good

Try flash it if you can access flash mode : http://www.mediafire.com/download/g2....3_Generic.rar

Yes sir!

EDIT: same error...tried usb 2.0 and 3.0 ports on front and back of my PC, with 2 different cables. Also, the bootloader was attempted to unlock with the tool with the weird name, like qecmd5825.cmd. I checked with s1 tool, its listed as unlocked, but also as dead, and it still wont restore the bootloader.

AGHHH this is crazy! These older phones are so much more troublesome! my htc desire z and One were a breeze compared to this ahaha
Last edited by bbmaster123; 27th March 2014 at 12:53 AM. Reason: results

The Following User Says Thank You to bbmaster123 For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
bricked, x10, xperia
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes