Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Google Invites Selected Devs to Buy Project Tango Development Kit

Just about a month ago, the curious Project Tango development kit was … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Deleted

[Q] "Kernel/Recovery is not seandroid enforcing" Removal Question

OP perezmarka

Prev Previous Post   Next Post Next
26th March 2014, 11:16 PM   |  #1  
OP Member
Thanks Meter: 7
 
39 posts
Join Date:Joined: Nov 2013
More
I have a Sprint Samsung Galaxy S4 that was running JB 4.3. When I decided to root and ROM it, I read a lot. I'll tell you what I did and where I got my files so you know exactly what happened:

In Download Mode:
First I Odined UnknownForce's NAE Modem Only Firmware with No Bootloader
Then I Odined Philz Touch Recovery 6.15.6

I booted to Recovery.
I cleared Cache and Davlic Cache twice.
I did Wipe/Factory Reset twice.
Then I flashed using Rawintellect's Stock(ish) Rom.

I install Ktoonsez Kernel for Sprint Touchwiz

At this point I am running a custom rom with a custom recovery and a custom kernel. It runs great.

I have no SEAndroid messages about the kernel or recovery at this point.

I decided to upgrade to Kit Kat 4.4. I did a nandroid backup. Then I took the official Sprint MD5 update and Odin it right over my rom. It worked. When the system boots up, it is running the Touchwiz version of Kit Kat. But I don't have root.

So I go to recovery to flash CF-Auto-Root-jfltespr-jfltespr-sphl720.zip but I'm back to stock recovery. So I go to download mode and re-Odin Philz Touch Recovery 6.15.6. Then I reboot to recovery.

There is an SEAndroid Recovery Message! But it lets me into recovery and I flash the zip. Reboot.

Since I was back to stock recovery, I check the kernel in settings. It's back to stock to. So I boot back to recovery and reinstall the custom kernel. Reboot to system.

There is an SEAndroid Kernel Message now! But it lets me into the system and I have root. I run Titanium Backup and remove Knox Files according to these instructions. I used method two for rooted phones. I also use method three.

Rebooted. Still showing the SEAndroid messages.

So I booted to download mode and re-Odined the NAE Modem Only Firmware with No Bootloader. Shut down phone and rebooted.

Still have the messages! Now I'm frustrated. So I do a Nandroid Backup of the KitKat Version and restore my nandroid backup of the Stock(ish) rom.

Phone works but I still have the SEAndroid messages! So I restore my nandroid backup of Kit Kat and started researching this.

What I know:

Though the messages may cause issues and boot loops for some, it is not doing it for me.
The messages do not hurt the functioning of the system.
I know the Knox counter was tripped from 0x0 to 0x1. (I never saw the Knox counter till I did this In fact!)
I know going back to stock recovery and kernel will remove the messages.

What I want:

I know the "Kernel/Recovery is not seandroid enforcing" doesn't hurt the phone but I want the message gone. I was on a rooted phone with custom rom, recovery and kernel without these messages showing up. Something is different from the way the phone was setup before and now. I don't want to go back to stock anything.

The SEAndroid is software. Software can be removed.

How do you remove it?

I know Knox was tripped somewhere in this process. Will that cause the message to appear even if your running without a boot loader?

How can I remove the SEAndroid software so it doesn't even run? Any ideas?
Last edited by perezmarka; 26th March 2014 at 11:21 PM. Reason: More Info Added
Subscribe to Thread

Tags
seandroid, seandroid enforcing
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes