Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,512 Members 42,357 Now Online
XDA Developers Android and Mobile Development Forum

[Q] KitKat update Device overheating closing apps

Tip us?
 
Roussel90
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Mar 2014
Default [Q] KitKat update Device overheating closing apps

Hi! I'm newly registered to these forums and i'm posting my problem here because I hope you guys can help me out i've tried everything!

I'm on Bell Canada provider LTE on a Samsung I337 Galaxy S4 and updated to KitKat 4.4.2. Since the update my apps are getting closed saying my phone overheats and I can only use Phone and Contacts. I figured this happens only when going on LTE. I stay on the internet for about 10-15 seconds then it happens and im locked for a good 30 seconds and its stays like that until I get back to Wifi. Being on wifi doesn't trigger the alert.
I've tried wiping my data , doing a system recovery. I even tried rolling back to 4.3 but that didn't work too well. I need to desactivate this security feature or remove it. You guys are my last hope!

Here's a screenshot:

Click image for larger version

Name:	Screenshot_2014-03-27-18-49-12.jpg
Views:	3032
Size:	154.4 KB
ID:	2654340
 
SelfElevated2
Old
(Last edited by SelfElevated2; 28th March 2014 at 12:46 AM.)
#2  
SelfElevated2's Avatar
Senior Member
Thanks Meter 256
Posts: 788
Join Date: Oct 2012
Quote:
Originally Posted by Roussel90 View Post
Hi! I'm newly registered to these forums and i'm posting my problem here because I hope you guys can help me out i've tried everything!

I'm on Bell Canada provider LTE on a Samsung I337 Galaxy S4 and updated to KitKat 4.4.2. Since the update my apps are getting closed saying my phone overheats and I can only use Phone and Contacts. I figured this happens only when going on LTE. I stay on the internet for about 10-15 seconds then it happens and im locked for a good 30 seconds and its stays like that until I get back to Wifi. Being on wifi doesn't trigger the alert.
I've tried wiping my data , doing a system recovery. I even tried rolling back to 4.3 but that didn't work too well. I need to desactivate this security feature or remove it. You guys are my last hope!

Here's a screenshot:

Attachment 2654340

I've been using the s4 since it came out and ive never seen it heard of anything like that. I'm on an att version and have been on 4.4.2 for awhile. Did you do the official ota or is it a custom rom?
Sounds like a kernel issue to me. Are you using any apps that are hard on the CPU at the time like heavy gaming? Which shouldn't even cause that but it does warm up a bit.

I would look into rooting and flashing a custom rom if it was the official update. But that will trigger the new knoxed boot loader and void your warranty. So there is that option which will most likely fix the issue. Or if your still under warranty and don't want to void it contact Samsung or your contract carrier and see if they will fix or replace your phone which could take some time.
The Following 2 Users Say Thank You to SelfElevated2 For This Useful Post: [ Click to Expand ]
 
Gage_Hero
Old
#3  
Senior Member
Thanks Meter 191
Posts: 1,144
Join Date: Jul 2010
Quote:
Originally Posted by Roussel90 View Post
Hi! I'm newly registered to these forums and i'm posting my problem here because I hope you guys can help me out i've tried everything!

I'm on Bell Canada provider LTE on a Samsung I337 Galaxy S4 and updated to KitKat 4.4.2. Since the update my apps are getting closed saying my phone overheats and I can only use Phone and Contacts. I figured this happens only when going on LTE. I stay on the internet for about 10-15 seconds then it happens and im locked for a good 30 seconds and its stays like that until I get back to Wifi. Being on wifi doesn't trigger the alert.
I've tried wiping my data , doing a system recovery. I even tried rolling back to 4.3 but that didn't work too well. I need to desactivate this security feature or remove it. You guys are my last hope!

Here's a screenshot:

Attachment 2654340
If you haven't rooted the phone and it's either less than a year old or you have extended warrenty, I would take it back to Bell. If the phone is rooted then I would say you have a bad flash of the rom (only guessing because you don't say if you did the OTA stock update or you flashed it) I flashed one rom that made my phone hot but I quickly did recovery back to the older rom.
Telus Galaxy S4 - Stock 4.3 to
[ROM] Maple leaf iBASTiD if ya aint tried it.... you should... Go Canada... Go iBASTiD......
The Following User Says Thank You to Gage_Hero For This Useful Post: [ Click to Expand ]
 
Roussel90
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Mar 2014
Quote:
Originally Posted by SelfElevated2 View Post
I've been using the s4 since it came out and ive never seen it heard of anything like that. I'm on an att version and have been on 4.4.2 for awhile. Did you do the official ota or is it a custom rom?
Sounds like a kernel issue to me. Are you using any apps that are hard on the CPU at the time like heavy gaming? Which shouldn't even cause that but it does warm up a bit.

I would look into rooting and flashing a custom rom if it was the official update.
Quote:
Originally Posted by Gage_Hero View Post
If you haven't rooted the phone and it's either less than a year old or you have extended warrenty, I would take it back to Bell. If the phone is rooted then I would say you have a bad flash of the rom (only guessing because you don't say if you did the OTA stock update or you flashed it) I flashed one rom that made my phone hot but I quickly did recovery back to the older rom.


Hi thanks for the answer, I did put the original official OTA 4.4.2 provided by my carrier and my cell warranty/knox warranty is gone. I'm only using chrome to navigate on the web when its happening so my only option is to try custom kernels not too sure which to pick I wanna have a stable like official one. I've never used any custom kernels before. Any idea what causes that force close?
 
Gage_Hero
Old
#5  
Senior Member
Thanks Meter 191
Posts: 1,144
Join Date: Jul 2010
Quote:
Originally Posted by Roussel90 View Post
Hi thanks for the answer, I did put the original official OTA 4.4.2 provided by my carrier and my cell warranty/knox warranty is gone. I'm only using chrome to navigate on the web when its happening so my only option is to try custom kernels not too sure which to pick I wanna have a stable like official one. I've never used any custom kernels before. Any idea what causes that force close?
There is definitely an issue with your install... see my post here http://forum.xda-developers.com/show...7#post51448767 it is number 3, suggest you read up a bit before diving head first into this... unless you have installed a custom recovery, rooted and installed a rom before. Mapleleaf is as close to stock as you can get.... if you choose twrp, don't use 2.7 see if you can get 2.6 I have seen a few people have problems with that version.... twrp is device specific so make sure you install the right one..... read up on the too.....
Telus Galaxy S4 - Stock 4.3 to
[ROM] Maple leaf iBASTiD if ya aint tried it.... you should... Go Canada... Go iBASTiD......
The Following User Says Thank You to Gage_Hero For This Useful Post: [ Click to Expand ]
 
Roussel90
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Mar 2014
Quote:
Originally Posted by Gage_Hero View Post
There is definitely an issue with your install... see my post here http://forum.xda-developers.com/show...7#post51448767 it is number 3, suggest you read up a bit before diving head first into this... unless you have installed a custom recovery, rooted and installed a rom before. Mapleleaf is as close to stock as you can get.... if you choose twrp, don't use 2.7 see if you can get 2.6 I have seen a few people have problems with that version.... twrp is device specific so make sure you install the right one..... read up on the too.....
I've tried different roms and kernels and its still doing it. I need to basicly desactivate or remove the security feature of the phone but I can't find whats controlling it, If anyone has an idea let me know. Until then no mobile data for me. My phone is rooted so i'm open to any ideas but customizing my phone still triggers the alert. 4.3 was not doing it at all. So something is new since the update.
 
jd1639
Old
#7  
jd1639's Avatar
Recognized Contributor
Thanks Meter 3,228
Posts: 9,573
Join Date: Sep 2012
Location: Minnetonka, MN
Quote:
Originally Posted by Roussel90 View Post
I've tried different roms and kernels and its still doing it. I need to basicly desactivate or remove the security feature of the phone but I can't find whats controlling it, If anyone has an idea let me know. Until then no mobile data for me. My phone is rooted so i'm open to any ideas but customizing my phone still triggers the alert. 4.3 was not doing it at all. So something is new since the update.
Thanks for providing the link to here. We should take your issue out of the other thread which deals with nb1 down grade. Your issue is that a lot is not working when you flash the stock firmware? What exactly is the problem?

Sent from my Nexus 5
The Following User Says Thank You to jd1639 For This Useful Post: [ Click to Expand ]
 
Roussel90
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Mar 2014
Quote:
Originally Posted by jd1639 View Post
Thanks for providing the link to here. We should take your issue out of the other thread which deals with nb1 down grade. Your issue is that a lot is not working when you flash the stock firmware? What exactly is the problem?

Sent from my Nexus 5
As seen on the screenshot, whenever i'm on an app. Android system just closes every apps im using and locks the phone for a good 30 seconds saying it overheats. I can only use Phone and apps whil this occurs. That all started when upgrading to Android 4.4. Before that phone was very stable. Its all on stock firmware too. I've tried different roms too, still the force closing occurs. Back to 4.3 i had never seen this thing happen.
 
jd1639
Old
#9  
jd1639's Avatar
Recognized Contributor
Thanks Meter 3,228
Posts: 9,573
Join Date: Sep 2012
Location: Minnetonka, MN
Quote:
Originally Posted by Roussel90 View Post
As seen on the screenshot, whenever i'm on an app. Android system just closes every apps im using and locks the phone for a good 30 seconds saying it overheats. I can only use Phone and apps whil this occurs. That all started when upgrading to Android 4.4. Before that phone was very stable. Its all on stock firmware too. I've tried different roms too, still the force closing occurs. Back to 4.3 i had never seen this thing happen.
Boy, this is a tough one. Using Odin to go back to 4.3 should have fixed the problem unless its a coincidence that the overheating started when you upgraded to 4.4. Even when you Odin back to 4.3 or earlier you still have the overheating problem? Just want to confirm that

Sent from my Nexus 5
 
Roussel90
Old
#10  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Mar 2014
Quote:
Originally Posted by jd1639 View Post
Boy, this is a tough one. Using Odin to go back to 4.3 should have fixed the problem unless its a coincidence that the overheating started when you upgraded to 4.4. Even when you Odin back to 4.3 or earlier you still have the overheating problem? Just want to confirm that

Sent from my Nexus 5
No I don't, But LTE is gone. so I cannot verify that 100%. i've used the phone for several months before the update and was working like a charm. The second the OTA 4.4 was installed it showed and my problems started.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes