Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[HELP] bricked mt6577

OP louis xv

26th March 2014, 12:43 AM   |  #1  
OP Junior Member
Thanks Meter: 3
 
15 posts
Join Date:Joined: Mar 2009
Hello every one
i have this phone (alps e1901 v77 fwvga) aka xtouch x507 (mt6577)
i flashed the original firmware from the supplier but since then the phone didn't boot
it wont charge also, but it's being recognized by pc and i still can flash on it.
and i tested the battery its charged, and also there is current drain (~50 mA)
when power button is pressed
so any ideas!!!???
26th March 2014, 07:38 AM   |  #2  
arnabbiswasalsodeep's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 149
 
343 posts
Join Date:Joined: Jan 2013
More
Reflash the rom
And don't flash the preloader if you flash one more time after flash

Press thanks I'd helped
26th March 2014, 02:23 PM   |  #3  
OP Junior Member
Thanks Meter: 3
 
15 posts
Join Date:Joined: Mar 2009
didn't work
Quote:
Originally Posted by arnabbiswasalsodeep

Reflash the rom
And don't flash the preloader if you flash one more time after flash

Press thanks I'd helped

do you mean flash every thing except preloader, i did that but it didn't help either
26th March 2014, 10:26 PM   |  #4  
PradeepMurugan's Avatar
Senior Member
Flag Karur
Thanks Meter: 258
 
222 posts
Join Date:Joined: Oct 2013
Donate to Me
More
Quote:
Originally Posted by louis xv

Hello every one
i have this phone (alps e1901 v77 fwvga) aka xtouch x507 (mt6577)
i flashed the original firmware from the supplier but since then the phone didn't boot
it wont charge also, but it's being recognized by pc and i still can flash on it.
and i tested the battery its charged, and also there is current drain (~50 mA)
when power button is pressed
so any ideas!!!???

Remove battery and then flash ROM in sp tools.
The Following User Says Thank You to PradeepMurugan For This Useful Post: [ View ]
28th March 2014, 11:32 PM   |  #5  
OP Junior Member
Thanks Meter: 3
 
15 posts
Join Date:Joined: Mar 2009
Quote:
Originally Posted by PradeepMurugan

Remove battery and then flash ROM in sp tools.

i've tried flashing the room with/ without the battery but nothing worked
Post Reply Subscribe to Thread

Tags
bricked mt6577
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes