Question [Q] mk2 hotspot installed, still wifi hotpot not working on sprint s4 sph-l720

Hi, can anyone help

i am using spring galaxy s4, with mk2 update. Have flashed mk2 hotpot mod dexodexed, which installs normally.
But i am still getting the same error - hotspot not supported
software version- l720vpuemk2
hardware - l720.08
android - 4.3
baseband version- l720vpuemk2
kernel version- 3.4.78-kt-sgs4-jb4.3-tw-spr-02.05.2014-gd8c5a17
build number- stock(ish)v06
selinux status- permissive

Wifi hotspot works normally when using AOSP based ROM