Post Reply

Mic doesnt work at all witch back cover on, when back cover is off it works perfectly

28th March 2014, 06:22 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: Mar 2011
Hello!

My problem is that my mic doesnt work at all witch back cover on, when I tack the back cover is off it works perfectly. I havent dropped it this happend randomly.

But what is the issue? Why does the mic work when I got my back cover off?

Speaker mic works both when cover is on and off.

Please help!

Thank you
29th March 2014, 01:46 AM   |  #2  
Senior Member
Flag Dallas, Tx
Thanks Meter: 465
 
1,927 posts
Join Date:Joined: Jan 2011
More
I dropped mine one time and had to replace the mic. these are very sensitive. Make sure the cover is not pushing it or messing with it
29th March 2014, 11:45 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
9 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by gypsy214

I dropped mine one time and had to replace the mic. these are very sensitive. Make sure the cover is not pushing it or messing with it

I thought it was due to a drop too, but I cannot remember if I ever dropped it. However I returned it to the store and it was sent for repair. Do you think they can say it was my fault somehow? I bought it last november and it looks brand new, no scratches.

Thank you for your respeonse
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in G2 Q&A, Help & Troubleshooting by ThreadRank