Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,883 Members 41,964 Now Online
XDA Developers Android and Mobile Development Forum

[Q] E: Can't mount /sdcard/ and no files found

Tip us?
 
Huhmeister
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Mar 2014
Default [Q] E: Can't mount /sdcard/ and no files found

Ive been having trouble and flashing roms for the past week trying to get my captivate to boot, but i constanly either get into a boot loop or i load into a black screen.

In CWM 5.1.0.7, when i choose "Install zip from sdcard > Choose zip from sdcard" i get a "E: Can't mount /sdcard/" error.

If i go to "Reformatting, tweaks and more > System Information > Browse directories and files", ill get "No files found." on a few of the directories and my /bin folder only has "init.goldfish.sh" in it. most of them have only bare minimal things in them. (im not sure if this is normal or not)

How should i go about fixing this?
 
Nihar
Old
#2  
Senior Member
Thanks Meter 557
Posts: 493
Join Date: Sep 2012
Location: Pune

 
DONATE TO ME
Quote:
Originally Posted by Huhmeister View Post
Ive been having trouble and flashing roms for the past week trying to get my captivate to boot, but i constanly either get into a boot loop or i load into a black screen.

In CWM 5.1.0.7, when i choose "Install zip from sdcard > Choose zip from sdcard" i get a "E: Can't mount /sdcard/" error.

If i go to "Reformatting, tweaks and more > System Information > Browse directories and files", ill get "No files found." on a few of the directories and my /bin folder only has "init.goldfish.sh" in it. most of them have only bare minimal things in them. (im not sure if this is normal or not)

How should i go about fixing this?
i think your internal storage has been corrupted..
 
Huhmeister
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Mar 2014
Quote:
Originally Posted by n205des View Post
i think your internal storage has been corrupted..
Could there be a fix?
 
Nihar
Old
#4  
Senior Member
Thanks Meter 557
Posts: 493
Join Date: Sep 2012
Location: Pune

 
DONATE TO ME
Quote:
Originally Posted by Huhmeister View Post
Could there be a fix?
check out this thread!
http://forum.xda-developers.com/show....php?t=2648547
 
Huhmeister
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Mar 2014
Quote:
Originally Posted by n205des View Post
Thanks a million! I atleast got my phone to start up now lol. Is there really no hope for the internal SD? No way to flash it back to normal? It is a software error afterall.
 
Nihar
Old
#6  
Senior Member
Thanks Meter 557
Posts: 493
Join Date: Sep 2012
Location: Pune

 
DONATE TO ME
Quote:
Originally Posted by Huhmeister View Post
Thanks a million! I atleast got my phone to start up now lol. Is there really no hope for the internal SD? No way to flash it back to normal? It is a software error afterall.
according to me , no there is no hope...
bt according to some users, their sd card came back to life after some time and then got bricked again...
and also no to the stock, it boots up bt cannot really do anything..
you can now use cm10,10.1,10.2, 11 roms using neat kernel..
The Following User Says Thank You to Nihar For This Useful Post: [ Click to Expand ]
 
Huhmeister
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Mar 2014
Quote:
Originally Posted by n205des View Post
according to me , no there is no hope...
bt according to some users, their sd card came back to life after some time and then got bricked again...
and also no to the stock, it boots up bt cannot really do anything..
you can now use cm10,10.1,10.2, 11 roms using neat kernel..
4 days later, I finally have the time to have one last follow up problem. I've flashed a CM11 nightly and my external sd shows up as my main storage in settings. I can download apps but i still can't access my camera or save pictures from the internet(it tells me "no SD card , and sd card is required to download). Also tested this with the voice recorder, it wouldnt start and told me the same thing.

Is this normal with the method you gave or have i done something wrong?
 
Nihar
Old
#8  
Senior Member
Thanks Meter 557
Posts: 493
Join Date: Sep 2012
Location: Pune

 
DONATE TO ME
Quote:
Originally Posted by Huhmeister View Post
4 days later, I finally have the time to have one last follow up problem. I've flashed a CM11 nightly and my external sd shows up as my main storage in settings. I can download apps but i still can't access my camera or save pictures from the internet(it tells me "no SD card , and sd card is required to download). Also tested this with the voice recorder, it wouldnt start and told me the same thing.

Is this normal with the method you gave or have i done something wrong?
you have done everything right, but you have forgotten to flash the neat kernel..
just flash it and everything wil be back to normal...
 
Huhmeister
Old
#9  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Mar 2014
Quote:
Originally Posted by n205des View Post
you have done everything right, but you have forgotten to flash the neat kernel..
just flash it and everything wil be back to normal...
I got it completely working with your advice but when i took the phone out of my pocket it was stuck on the neat kernal loading screen and rebooting it wouldnt help. I decided to flash back to stock and redo the process. I wiped all data etc. in recovery but when i went to partition the sd card again in cwm it finished instantly.

My pc wouldnt read it and even my another phone didnt detect it was there.

I'm assuming the SD card just died, its verbatim 8gig(Not sure if thats a reliable brand or not).

Could this be because i did something wrong is it just a coincidence with the sd card dying? Im buying a sandisk soon anyhow.
 
Nihar
Old
#10  
Senior Member
Thanks Meter 557
Posts: 493
Join Date: Sep 2012
Location: Pune

 
DONATE TO ME
Quote:
Originally Posted by Huhmeister View Post
I got it completely working with your advice but when i took the phone out of my pocket it was stuck on the neat kernal loading screen and rebooting it wouldnt help. I decided to flash back to stock and redo the process. I wiped all data etc. in recovery but when i went to partition the sd card again in cwm it finished instantly.

My pc wouldnt read it and even my another phone didnt detect it was there.

I'm assuming the SD card just died, its verbatim 8gig(Not sure if thats a reliable brand or not).

Could this be because i did something wrong is it just a coincidence with the sd card dying? Im buying a sandisk soon anyhow.
i think it died..
just to ensure longer life, buy a sandisk class 10 sd card..
i bought it!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Twik Keeps Your Accounts Secure with Randomly Generated Passwords

If youre one of thosewho find it just an impossible task to keep trackof … more

Moto G 4G Receives Official CyanogenMod 11 Love

When theMoto Gwas initially released to the world in November of last year,very few actually … more

Get Your Tasks Organized on Android Wear with Agenda Wear

Having a checklist of things you need to do is something we all can find useful at … more

Top 5 LG G3 MODs – XDA Developer TV

The LG G3 has been LG’s breakout hit of the summer. Using their knowledge frombuilding some … more