Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Q&A for twrp unofficial

OP simonsickle

30th March 2014, 10:49 PM   |  #1  
simonsickle's Avatar
OP Recognized Developer
Flag Sevierville
Thanks Meter: 928
 
703 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Please post all comments concerns and questions in this thread. Thank you for your support

Sent from my 831C using Tapatalk
Last edited by ΠΣΘ; 19th May 2014 at 10:22 PM.
30th March 2014, 10:59 PM   |  #2  
Captain_Throwback's Avatar
Retired Moderator / Recognized Contributor
Flag Bensalem, PA
Thanks Meter: 11,257
 
10
12,389 posts
Join Date:Joined: Aug 2008
Donate to Me
More
Great work on this.

Any way to get exFAT working on this? It seems to be working fine on the version from Dees_Troy (my card is formatted exFAT).

The tree Dees_Troy put up is here: https://github.com/TeamWin/android_device_htc_m8_whl (I'm sure you already know this)

I also caught him on IRC yesterday and he said he'd look at any errors in the source tomorrow, as I was having issues building with it as-is. With all the additional updates you had to make, it's no wonder!
Last edited by ΠΣΘ; 19th May 2014 at 10:18 PM.
The Following 2 Users Say Thank You to Captain_Throwback For This Useful Post: [ View ]
30th March 2014, 11:01 PM   |  #3  
simonsickle's Avatar
OP Recognized Developer
Flag Sevierville
Thanks Meter: 928
 
703 posts
Join Date:Joined: Nov 2012
Donate to Me
More
I'm not sure can you give mine a try and tell me if your card mounts? I have nothing formatted to test it. As for the code I got it all cleaned up and working. I also fixed the segfaults

Sent from my HTC M8WHL
The Following 4 Users Say Thank You to simonsickle For This Useful Post: [ View ]
30th March 2014, 11:14 PM   |  #4  
Captain_Throwback's Avatar
Retired Moderator / Recognized Contributor
Flag Bensalem, PA
Thanks Meter: 11,257
 
10
12,389 posts
Join Date:Joined: Aug 2008
Donate to Me
More
Quote:
Originally Posted by simonsickle

I'm not sure can you give mine a try and tell me if your card mounts? I have nothing formatted to test it. As for the code I got it all cleaned up and working. I also fixed the segfaults

Sent from my HTC M8WHL

Looks like exFAT is working fine (though external SD isn't mounted by default). And great job on fixing the seg faults.

The one thing missing is offmode charging support, which I believe Dees_Troy did include on his tree. Besides that, it looks great.
The Following 2 Users Say Thank You to Captain_Throwback For This Useful Post: [ View ]
30th March 2014, 11:22 PM   |  #5  
simonsickle's Avatar
OP Recognized Developer
Flag Sevierville
Thanks Meter: 928
 
703 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Offmode charging just needs a bit of tweaking. Im working with the init files to get them fully working. I like to do things as clean as possible

Thanks for testing exfat btw
The Following 3 Users Say Thank You to simonsickle For This Useful Post: [ View ]
30th March 2014, 11:25 PM   |  #6  
Captain_Throwback's Avatar
Retired Moderator / Recognized Contributor
Flag Bensalem, PA
Thanks Meter: 11,257
 
10
12,389 posts
Join Date:Joined: Aug 2008
Donate to Me
More
Quote:
Originally Posted by simonsickle

Offmode charging just needs a bit of tweaking. Im working with the init files to get them fully working. I like to do things as clean as possible

Thanks for testing exfat btw

No problem. I took your version and updated the init.rc real quick and added the offmode_charging binary to /sbin to fix the offmode charging for myself in the meantime .
The Following User Says Thank You to Captain_Throwback For This Useful Post: [ View ]
1st April 2014, 03:54 PM   |  #7  
hasoon2000's Avatar
Senior Member
Flag Orland Park, Illinois
Thanks Meter: 9,287
 
3,514 posts
Join Date:Joined: Feb 2008
Donate to Me
More
Quote:
Originally Posted by Captain_Throwback

No problem. I took your version and updated the init.rc real quick and added the offmode_charging binary to /sbin to fix the offmode charging for myself in the meantime .

Would you mind sending me your version so I can update my toolkit to support Sprint?

Thanks!

Sent From My HTC One via Someone's Room
1st April 2014, 05:46 PM   |  #8  
simonsickle's Avatar
OP Recognized Developer
Flag Sevierville
Thanks Meter: 928
 
703 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Hasoon just build the one in my github.... It's not stable enough for a actual release (exfat and such) either. So I'd prefer my work stays out of a toolkit for now. Until I fix kernel bugs please don't place it in the tool

Sent from my HTC M8WHL
1st April 2014, 05:56 PM   |  #9  
Senior Member
Thanks Meter: 86
 
532 posts
Join Date:Joined: Sep 2007
Donate to Me
More
Quote:
Originally Posted by Captain_Throwback

No problem. I took your version and updated the init.rc real quick and added the offmode_charging binary to /sbin to fix the offmode charging for myself in the meantime .

Can I take your version for a spin also...

Sent from my 831C using Tapatalk
1st April 2014, 06:02 PM   |  #10  
Captain_Throwback's Avatar
Retired Moderator / Recognized Contributor
Flag Bensalem, PA
Thanks Meter: 11,257
 
10
12,389 posts
Join Date:Joined: Aug 2008
Donate to Me
More
Quote:
Originally Posted by hasoon2000

Would you mind sending me your version so I can update my toolkit to support Sprint?

Thanks!

Sent From My HTC One via Someone's Room

Quote:
Originally Posted by JT man

Can I take your version for a spin also...

Sent from my 831C using Tapatalk

Have you considered using the version directly from TeamWin?

Or just building it from source from the github listed in the OP?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes