Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,372 Members 39,864 Now Online
XDA Developers Android and Mobile Development Forum

Disable capacitive button light ?

Tip us?
 
Blackus17
Old
#1  
Blackus17's Avatar
Member - OP
Thanks Meter 13
Posts: 75
Join Date: Nov 2013
Location: Thalassery, Kannur
Default Disable capacitive button light ?

It's been 4 years of Galaxy S I9000 and no developer has yet developed a method to turn off the capacitive button light. This is very necessary as it could help with the very low battery capacity. I strongly request developers to concentrate their skills on this, to disable the light and thereby prevent the irritation to eye during the night & save a lot of juice.
Please Help
Thanks
Sent from Blackus17's Samsung Galaxy S GT-I9000
 
CayetanoVelocity
Old
#2  
Junior Member
Thanks Meter 1
Posts: 8
Join Date: Oct 2011
Quote:
Originally Posted by Blackus17 View Post
It's been 4 years of Galaxy S I9000 and no developer has yet developed a method to turn off the capacitive button light. This is very necessary as it could help with the very low battery capacity. I strongly request developers to concentrate their skills on this, to disable the light and thereby prevent the irritation to eye during the night & save a lot of juice.
Please Help
Thanks
Pardon me if I misunderstood your question.
If you just want the buttons not to turn on when receiving an sms (i.e. acting as notification led) then CyanogenMod has that option, just go into Settings->CyanogenMod->Audio->Quiet hours (or something to that effect), set from, say, 2:00 to 1:59 (all day minus 1') and check last option (Dim LED or something).
If you want them not to light up under any circumstance, well, I don't think I'd use that setting but I guess it'd be nice to have!
 
Blackus17
Old
#3  
Blackus17's Avatar
Member - OP
Thanks Meter 13
Posts: 75
Join Date: Nov 2013
Location: Thalassery, Kannur
I want the lights permanently disabled.
Sent from Blackus17's Samsung Galaxy S GT-I9000
 
Gokulbalram
Old
#4  
Gokulbalram's Avatar
Senior Member
Thanks Meter 65
Posts: 381
Join Date: Apr 2013
Location: Pune
Try adding qemu.hw.mainkeys =0 to the build.prop file of your phone. Just let me know if that helped. PS: If you're using Nightlies, the build.prop file keeps resetting.
 
Blackus17
Old
#5  
Blackus17's Avatar
Member - OP
Thanks Meter 13
Posts: 75
Join Date: Nov 2013
Location: Thalassery, Kannur
Quote:
Originally Posted by Gokulbalram View Post
Try adding qemu.hw.mainkeys =0 to the build.prop file of your phone. Just let me know if that helped. PS: If you're using Nightlies, the build.prop file keeps resetting.
No.. it doesn't work . I already tried it many times before starting this thread.
Sent from Blackus17's Samsung Galaxy S GT-I9000
 
Gokulbalram
Old
#6  
Gokulbalram's Avatar
Senior Member
Thanks Meter 65
Posts: 381
Join Date: Apr 2013
Location: Pune
Quote:
Originally Posted by Blackus17 View Post
No.. it doesn't work . I already tried it many times before starting this thread.
Say, are you on a Custom ROM?
 
pryerlee
Old
(Last edited by pryerlee; 3rd April 2014 at 11:07 AM.)
#7  
pryerlee's Avatar
Senior Member
Thanks Meter 113
Posts: 464
Join Date: Nov 2008
Location: Bristol
I think "qemu.hw.mainkeys" is to disable the virtual button bar on JB roms and not to turn off the soft key backlights (although i could be wrong?). You can add an init.d script that shortens how long they stay on for (i don't think you can turn them off completely) i set mine to 000 sec and they stayed on permanently so i set it to 001 sec and that works for me. Do a search for the init.d script, it's on xda somewhere.
 
Gokulbalram
Old
#8  
Gokulbalram's Avatar
Senior Member
Thanks Meter 65
Posts: 381
Join Date: Apr 2013
Location: Pune
On certain custom ROMs, they do act as a notification LED. So, that stays on until you turn in the phone. So all you have to is go to Settings>Display>Notification Lights (it will be called something similar) and then turn it off. Some ROMs could have a different way to turn it off. Also, I don't think that you lose battery when they turn on as you click on the buttons.

Cheers! The thanks button is right there... Just saying..

Sent from my GT-I9000 using XDA Premium 4 mobile app
Phone: Samsung Galaxy S i9000 || Samsung Galaxy S3 i9300
ROM: Paranoid Android 4.5 A1 || Omni 4.4.4
Kernel: Stock PA || Boeffla 2.2
Processor: 100-1200 MHZ || 100-1400 MHZ
Governor: OnDemand || SmartAssV2

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

LG G Watch Tool is a Toolkit all Owners Need

The LG G Watch is one of the first two devices hitting the market rocking the highly anticipated … more

Benchmark Your CPU Performance with Mini CPU Integer Script

When it comes to device testing, there are two types of people on XDA. The first … more

Rid Yourself of Charging Annoyances with No Wake on Charge Xposed Module

Almost every OEM has skinned and otherwise modifiedAndroid to suit … more