Unhappy Stuck at Boot - After years of use (HELP!)

Hey guys..

My phone is stuck at the "Samsung Galaxy S4" screen" where it shows just the letters.

The last thing I remember doing was using taskiller and phone's memory killer to kill memory because it was slow... and when I tried to open up text messages, it wouldn't open.
So I restarted the phone and now it's stuck at the "Samsung Galaxy S4" Screen.
( I also removed some apps days before.. but I had rebooted and phone it was working just fine).

- I haven't tried to reinstall a radio.. I woudn't know which one.
- I can access odin just fine by clicking the 3 keys.
- I Can't access TWRP Recovery. I held the 3 keys, and it shows the message on the left corner like it's going to go, but then just reboots and gets stuck on samsung screen.
Tried to reinstall it, but didn't seem to work I guess.. since it still shows the left corner message, but doesnt go to twrp.


Details about my phone:
SGS4 Rooted.
Rom, Custom Stock Rom.. Jedi S4X http://forum.xda-developers.com/show....php?t=2331942 (url of ROM)

What Can I do?
I dont care what I have to install/remove, but I have very important things on the phone that I CANT have deleted!

HELP ME ??
SAMSUNG GALAXY S4! - FEEL THE POWERR!!


Cheats for all Android Games!
AndroidCheats.org


iPhone Cheats - iOS Cheats!
iOS Cheaters.org


Short URL


---------------------------