5,599,478 Members 38,339 Now Online
XDA Developers Android and Mobile Development Forum

[ROOT TOOL] rootkitXperia - Root Many Xperia! [bug 9950697][CVE-2013-6282]

Tip us?
 
kingvortex
Old
#31  
kingvortex's Avatar
Senior Member
Thanks Meter 1445
Posts: 2,234
Join Date: Mar 2010
Location: Nottingham
Quote:
Originally Posted by rameshkotibani View Post
is it worked on my Xperia ZL C6502 4.3 10.4.B.0.569?pls help me
No.

Sent from my C6603 using Tapatalk
 
anancr
Old
#32  
Senior Member
Thanks Meter 27
Posts: 247
Join Date: Mar 2011
Location: Cali
Quote:
Originally Posted by RyokoN View Post
A Japanese developer, キューブキューブ @ cubeundcube created root tool for a lot of Xperia devices.

 
His root tools uses two exploit - one is master key exploit (bug 9950697), another one is CVE-2013-6282.
No internet connection is required.

Here is the confirmed list:
(If you find other devices/firmware can be rooted with this root tool, please let me know.)

bug 9950697 (rootkitZ)
Xperia Z C6603/C6602 10.3.1.A.2.67 / 10.3.1.A.2.74 / 10.3.1.A.0.244
・Xperia ZL C6502
・Xperia ZR C5503 10.31.A.2.67
・Xperia Tablet Z SGP311JP / SGP312 10.3.1.C.0.136
・Xperia V LT25i 9.1.A.1.140
・Xperia AX SO-01E 9.1.C.1.103
・Xperia Z SO-02E 10.3.1.B.0.256
・Xperia Tablet Z SO-03E 10.1.E.0.305
・Xpeira A/MIKU SO-04E 10.3.1.B.0.224 / 10.3.1.B.0.256
・Xpeira UL SOL22 10.2.F.3.81
・Xperia GX SO-04D 9.1.C.1.103

CVE-2013-6282 (rootkitXperia)
・Above devices/firmwares
Xperia Z C6603 10.3.1.E.0.191
Xperia Z1 C6903 14.1.G.1.534
Xperia Z Ultra 14.1.B.1.532
・Xperia UL SOL22 10.3.1.D.0.220
・Xperia SX SO-05D 9.1.C.1.103
・Xperia VL SOL21 9.1.D.0.401
・Xperia miro ST23i 11.0.A.5.5
・Xperia J ST26i 11.2.A.0.33
・Xperia L C2105 15.3.A.0.26
・Xperia E C1505 11.3.A.2.23
・Xperia E Dual C1605

Z 10.4.B.0.569 couldn't be rooted with both exploit, so these root tools cannot be used with newer devices/firmwares than Z1 .257.
You can root those firmwares with prerooted zip.

--- bug 9950697 ---
You can download root tool from his Japanese website,
http://cubeundcube.blogspot.jp/2013/...2e-so-04e.html
find "rootkitZ_20131112.zip" and download.

--- CVE-2013-6282 ---
You can download from this tweet.
https://twitter.com/cubeundcube/stat...91968795680770

*** Setup adb and enable USB debugging and Unknown Sources ***

Extract zip and run install.bat and follow the instructions.
If your device reboot and cmd says "完了しました" or "--- all finished ---", rooting is done.

If this roo tool helps you, please consider donating to him via Paypal.
please add xperia ZR C5502 with 10.3.1.A.0.244 with bug 9950697 (rootkitZ)

thanks
- read first before comenting anything about the devs work
-it isn't really tigo, is uff but it works in the tigo network.
- don't do something to get a "thanks" do it, because, you want, you can, and you like to do it.



device: u20a rom: ????
device: c5502 rom: stock 4.2.2 bl: locked root: yes build: 10.3.1.A.0.244
The Following User Says Thank You to anancr For This Useful Post: [ Click to Expand ]
 
opieum
Old
(Last edited by opieum; 29th January 2014 at 09:46 PM.) Reason: updating status
#33  
opieum's Avatar
Member
Thanks Meter 27
Posts: 52
Join Date: May 2010
Location: Valley Stream NY

 
DONATE TO ME
Will this tool work with the Xperia Z1S (C6916)? There have been questions about this. Im using the firmware 14.2.C.0.159

EDIT: answered my own question. Its a big no

Neither tool works.

I attempted a manual push of the files to see where the errors were:

C:\Users\Q05965\Downloads\rootkitZ_20131112\rootki tZ_20131112\files>adb install
-r mod_ShutDownAnimation.apk
2048 KB/s (29378 bytes in 0.014s)
pkg: /data/local/tmp/mod_ShutDownAnimation.apk
Failure [INSTALL_PARSE_FAILED_UNEXPECTED_EXCEPTION]

it doesn't work. After this point it looks like all the commands are just to exploit the root at shutdown. Oh well
 
ujangns
Old
#34  
Junior Member
Thanks Meter 1
Posts: 19
Join Date: Apr 2009
work great on my xperia zr 10.3.1.a.2.67 after several attempt.
 
kiawin
Old
#35  
Junior Member
Thanks Meter 4
Posts: 12
Join Date: Mar 2008
Location: Klang, Selangor

 
DONATE TO ME
Hi all, I'm unsure why I tried several times with the twitter/20131207 version with Windows but not successful.

So I check the .bat file and noticed it makes adb calls, and I boot up my linux and done the same and it works.

If anyone need the instructions I can post it here.

Thanks
Tags
exploit, root, xperia
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes