Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,742 Members 37,698 Now Online
XDA Developers Android and Mobile Development Forum

Massive packet loss on non-stock roms

Tip us?
 
sdfgsteve
Old
#1  
Member - OP
Thanks Meter 7
Posts: 41
Join Date: Dec 2013
Default Massive packet loss on non-stock roms

I hope someone can help me, this is driving me up the wall.

I've got a t0lte. I've been using the H3G image for it for a few months, with no problems with the network apart from not going onto LTE, and massive problems with Bluetooth (it seems Samsung suck at it). So I installed OmniROM 4.4.2. After a few days, I started getting up to 50% packet loss. I switched to CM11, same thing. Then on to SlimKat, as someone on #omnirom suggested it might be the RIL, but it wasn't that. I tried two other modems, didn't help. I then tried OmniROM 4.3.1, same thing, and CM10.2, same thing. Tried the latest modem I could find, XXUENA1, same thing.

People have suggested it might be a carrier issue (I'm on H3G), but I can't fathom how. I don't experience any packet loss on the stock H3G image I downloaded. But now they are rolling out LTE, I need something that can get on it.

I've hunted through the interwebs and can't find anything matching this.

Can anyone help?

Steve
 
sdfgsteve
Old
#2  
Member - OP
Thanks Meter 7
Posts: 41
Join Date: Dec 2013
I've been doing some further investigation, and it seems as if what's happening, which might be the cause, or a symptom, is that it's switching between HSDPA and DC-HSDPA constantly. I'm not sure if that switch is a function of the firmware, or something on the mast side, can anyone offer any advice/experience on that?

Ta

Steve
 
sdfgsteve
Old
#3  
Member - OP
Thanks Meter 7
Posts: 41
Join Date: Dec 2013
Ok, I tried the MB2 modem from http://forum.xda-developers.com/show....php?t=2031575 , but that didn't make any difference. I also tried changing one of the build.prop settings for the downswitching, and that didn't work either.

Anyone got any ideas? I really don't want to be stuck on the crappy Samsung software
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes