Smile [Q] Seem to have root but superuser doesn't work [SOLVED]

[SOLVED]

Have checked i don't know how many forum/posts but can't seem to find an answer to this perplexing problem...

Have a Tab p6210 with Omni version 4.4.2-20140209-p6210-HOMEMADE and although i can't seem to find the info, i remember that we have CWM 6.2.xx something.

Using Root Checker Advanced it shows that we have root. We are using Superuser v3.1.3 and su is in /xbin. The superuser app seems to work, i.e. it doesn't report any errors, but when i run Titanium Backup or Nandroid Manager, they both report that the superuser app is not installed. ???

Tit. Backup reports that the attempt was made using the /system/bin/su command. Root Checker Advanced reports that we have root access but that we need to install superuser app - SU path - /system/xbin/su

Any help would be greatly appreciated. Have a great evening!
"The earth is one country and mankind its citizens."
Bahá'u'lláh
"La tierra es un sólo país y la humanidad sus ciudadanos."