Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,222 Members 44,798 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Stuck while "fixing" my SGH-I337

Tip us?
 
AmpGuitarChase
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Apr 2014
Question [Q] Stuck while "fixing" my SGH-I337

Hello everyone,
I'm a new poster here at XDA , and I've gotten myself into a bit of a predicament. If there are any rules that I happened to skim over that are broken, please let me know! I have performed a search of my issue, but no solution has been procured from what I can tell.

For three days now, I've been trying to fix my phone. Stats below:

Model: SGH-I337 (AT&T Galaxy S4)
Build Number: JSS15J.I337UCUEMK2
OS: 4.3 (JB)

I believe that's all that needs to be listed, I'll be able to provide more information upon request if necessary.
I'll try to shorten my story to the key elements: Less than a week ago I tried to root, unlock, and flash a custom ROM to my S4 to no avail. I completed the rooting successfully and I believe I may have bypassed unlocking it via LOKI, but the ROM did not install. Since that failed, I've been trying for three days to completely restore my phone to stock and just deal with Samsung's TouchWiz UI. I can flash (through ODIN) my phone to stock 4.3 and everything is fine except for a lack of WiFi and Data. This is where my conundrum comes in to play.

Knox seems to display a message stating "The device has detected an application attempting to perform actions that are not permitted. These actions have been blocked. It is recommended that you restart your device." anytime that I attempt to turn WiFi on. The widget and the setting in options will attempt to turn on for a split second and turn off prior to displaying this security message. It's as if Knox believes my WiFi is attempting to access parts of my phone that are restricted. My data is able to be turned on in the settings, but no 3g/4g is ever utilized. I figured an update off of 4.3 would help remedy this issue, but I can't seem to update my phone through any other means (ODIN, Kies, no OTA due to no WiFi/Data, etc.).

I've run out of different combinations of the keywords about my problem to search for in Google and any question about my problem was asked approximately April-October 2013, not answered, and not many more similar questions have risen since then.. which leads me to believe that this fix should be relatively easy.

On an S3 forum thread (I know, different device) I read that there could be corruption of my Nandroid system, but I'm not even sure what that entails. The user answering implied that the phone was done for. Again, though, this was a separate thread for another user about a Galaxy S3.

Well, apologies for the wall of text, folks. If you are willing to assist me, I would very much appreciate it. Thank you very much for reading my issue and I hope assistance can be organized.
 
seedeh
Old
#2  
seedeh's Avatar
Member
Thanks Meter 16
Posts: 89
Join Date: Jan 2014
Location: Austin, TX
What did you use to get back to stock

Sent from my SAMSUNG-SGH-I337 using Tapatalk
If all else fails for you AT&T GS4 (i337) users check this out from ted77usa:

http://forum.xda-developers.com/show....php?t=2621279
posts 1 and 2
odin back to stock
The Following User Says Thank You to seedeh For This Useful Post: [ Click to Expand ]
 
AmpGuitarChase
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Apr 2014
Quote:
Originally Posted by seedeh View Post
What did you use to get back to stock

Sent from my SAMSUNG-SGH-I337 using Tapatalk
I used ODIN to flash (What I'm very confident is) 4.3 Stock in the same manner I flashed the custom ROM.

I feel like that isn't specific enough for you though. I used Odin3 v3.09 first and then after several failures switched to Odin3 v1.85 as demonstrated in a few tutorials I've seen.
 
seedeh
Old
#4  
seedeh's Avatar
Member
Thanks Meter 16
Posts: 89
Join Date: Jan 2014
Location: Austin, TX
Did you use this tutorial?: http://forum.xda-developers.com/show....php?t=2621279 cause if you didn't, do.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
If all else fails for you AT&T GS4 (i337) users check this out from ted77usa:

http://forum.xda-developers.com/show....php?t=2621279
posts 1 and 2
odin back to stock
The Following User Says Thank You to seedeh For This Useful Post: [ Click to Expand ]
 
AmpGuitarChase
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Apr 2014
Quote:
Originally Posted by seedeh View Post
Did you use this tutorial?: http://forum.xda-developers.com/show....php?t=2621279 cause if you didn't, do.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
Let me attempt this thread's instructions before I make more of a fool of myself. Thank you for the assistance so far. I really appreciate it.
 
seedeh
Old
#6  
seedeh's Avatar
Member
Thanks Meter 16
Posts: 89
Join Date: Jan 2014
Location: Austin, TX
No problem


Sent from my SAMSUNG-SGH-I337 using Tapatalk
If all else fails for you AT&T GS4 (i337) users check this out from ted77usa:

http://forum.xda-developers.com/show....php?t=2621279
posts 1 and 2
odin back to stock
The Following User Says Thank You to seedeh For This Useful Post: [ Click to Expand ]
 
AmpGuitarChase
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Apr 2014
Quote:
Originally Posted by seedeh View Post
No problem


Sent from my SAMSUNG-SGH-I337 using Tapatalk
Seedeh,

The errors still continued as usual even with the explicit following of the linked directions. It appears that during the process:

<ID:0/007> Odin v.3 engine (ID:7)..
<ID:0/007> File analysis..
<ID:0/007> SetupConnection..
<ID:0/007> Initialzation..
<ID:0/007> Set PIT file..
<ID:0/007> DO NOT TURN OFF TARGET!!
<ID:0/007> Get PIT for mapping..
<ID:0/007> Firmware update start..
<ID:0/007> SingleDownload.
<ID:0/007> sbl1.mbn
<ID:0/007> NAND Write Start!!
<ID:0/007> sbl2.mbn
<ID:0/007> sbl3.mbn
<ID:0/007> rpm.mbn
<ID:0/007> aboot.mbn
<ID:0/007> FAIL! (Auth)
<ID:0/007>
<ID:0/007> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)

that the "NAND Write Start" step isn't really even trying to write before it fails.

Kies "Emergency Firmware Recovery" also yields no success due to "Firmware emergency recovery stopped due to GALAXY S4(SGH-I337) error. If the problem persists, please contact the Samsung service centre.", which does persist each time I attempt to do so.

If you have any more suggestions, I'd be more than happy to attempt them.

Thank you.
 
John The Rhino
Old
(Last edited by John The Rhino; 2nd April 2014 at 09:01 AM.) Reason: added content for clarity
#8  
John The Rhino's Avatar
Senior Member
Thanks Meter 117
Posts: 175
Join Date: Dec 2013
Quote:
Originally Posted by AmpGuitarChase View Post
Hello everyone,
I'm a new poster here at XDA , and I've gotten myself into a bit of a predicament. If there are any rules that I happened to skim over that are broken, please let me know! I have performed a search of my issue, but no solution has been procured from what I can tell.

For three days now, I've been trying to fix my phone. Stats below:

Model: SGH-I337 (AT&T Galaxy S4)
Build Number: JSS15J.I337UCUEMK2
OS: 4.3 (JB)

I believe that's all that needs to be listed, I'll be able to provide more information upon request if necessary.
I'll try to shorten my story to the key elements: Less than a week ago I tried to root, unlock, and flash a custom ROM to my S4 to no avail. I completed the rooting successfully and I believe I may have bypassed unlocking it via LOKI, but the ROM did not install. Since that failed, I've been trying for three days to completely restore my phone to stock and just deal with Samsung's TouchWiz UI. I can flash (through ODIN) my phone to stock 4.3 and everything is fine except for a lack of WiFi and Data. This is where my conundrum comes in to play.

Knox seems to display a message stating "The device has detected an application attempting to perform actions that are not permitted. These actions have been blocked. It is recommended that you restart your device." anytime that I attempt to turn WiFi on. The widget and the setting in options will attempt to turn on for a split second and turn off prior to displaying this security message. It's as if Knox believes my WiFi is attempting to access parts of my phone that are restricted. My data is able to be turned on in the settings, but no 3g/4g is ever utilized. I figured an update off of 4.3 would help remedy this issue, but I can't seem to update my phone through any other means (ODIN, Kies, no OTA due to no WiFi/Data, etc.).

I've run out of different combinations of the keywords about my problem to search for in Google and any question about my problem was asked approximately April-October 2013, not answered, and not many more similar questions have risen since then.. which leads me to believe that this fix should be relatively easy.

On an S3 forum thread (I know, different device) I read that there could be corruption of my Nandroid system, but I'm not even sure what that entails. The user answering implied that the phone was done for. Again, though, this was a separate thread for another user about a Galaxy S3.

Well, apologies for the wall of text, folks. If you are willing to assist me, I would very much appreciate it. Thank you very much for reading my issue and I hope assistance can be organized.

Loki is for MF3 not for MK2. So you should just Odin back to stock. Here are the tar files.

http://forum.xda-developers.com/show....php?t=2621279.

If that didn't work, then follow ted77USA's guide.

Once you are back on Stock MK2 firmware, here are your options. Have a good read of this guide.

http://forum.xda-developers.com/show....php?t=2616221

Be sure to thank the op in the threads that help you & of the developers of the roms you flash. Good luck & remember, reading saves phones.
The Following User Says Thank You to John The Rhino For This Useful Post: [ Click to Expand ]
 
AmpGuitarChase
Old
#9  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Apr 2014
Quote:
Originally Posted by John The Rhino View Post
Loki is for MF3 not for MK2. So you should just Odin back to stock. Here are the tar files.

http://forum.xda-developers.com/show....php?t=2621279.

If that didn't work, then follow ted77USA's guide.

Once you are back on Stock MK2 firmware, here are your options. Have a good read of this guide.

http://forum.xda-developers.com/show....php?t=2616221

Be sure to thank the op in the threads that help you & of the developers of the roms you flash. Good luck & remember, reading saves phones.
John The Rhino,

Thank you for you assistance. I will surely give credit where credit is due (:

I've attempted the XDA Full Odin Tar MK2 link's instructions three times on two separate computers (one w8 and one w7) to no avail. I've triple-checked the instructions, but my Odin always fails when attempting to Complete(Write).

NAND Write Start!
sbl2.mbn
sbl3.mbn
rpm.mbn
aboot.mbn

Complete(Write) Operation Failed
All threads completed. (succeed 0 / failed 1)

Odin settings: Auto Reboot checked, F. Reset Time checked, PDA = I337MK2_Full_Odin_Tar.tar file, nothing else is checked.
Device: Dev mode activated, USB debugging active, this is all verified after a recovery-initiated factory reset, device is in download mode.
Computer(s): Samsung Android ADB Interface drivers are installed, Odin does show a yellow bar upon device connection. MicroUSB cable is the default one that came with the device, all USB ports have been tried with the same results.

I tried to be as thorough as possible with my setup. I'll see if my process is correct now just in case that will help.
  • [Fixing Device to Working Status w/o wifi/data permissions] Flashed AP_I337UCUEMK2_1921628_REV06_user_low_ship_MULTI_C ERT.tar.md5 via Odin
  • Automatic Reboot via Odin
  • [Device is back to working status w/o data/wifi permissions (No reset has been done)]
  • Power off
  • Reboot in Recovery Mode (Volume up + Home + Power)
  • Wipe data/factory reset command
  • Wipe cache (just in case)
  • Reboot
  • [Phone is now factory reset 4.3 MK2 (WiFi/Data permissions denied still]
  • Enable developer options
  • Enable USB debugging and Screen Stay Awake during charging
  • Power off
  • Boot into download mode (Volume down + Home + Power)
  • Open Odin3 v1.85
  • Bar in Odin for COM Port is yellow
  • Auto reboot & F. Reset Time are both checked
  • Load I337MK2_Combined_Odin_Tar\I337MK2_Full_Odin_Tar.ta r.md5 in PDA slot
  • Screenshot of Odin before "START" http://i.imgur.com/oXufVNQ.png
  • Odin START
  • Wait for Odin to check .md5 compatibility
  • <ID:0/005> Added!!
    <OSM> Enter CS for MD5..
    <OSM> Check MD5.. Do not unplug the cable..
    <OSM> Please wait..
    <OSM> I337MK2_Full_Odin_Tar.tar.md5 is valid.
    <OSM> Checking MD5 finished Sucessfully..
    <OSM> Leave CS..
    <ID:0/005> Odin v.3 engine (ID:5)..
    <ID:0/005> File analysis..
    <ID:0/005> SetupConnection..
    <ID:0/005> Initialzation..
    <ID:0/005> Set PIT file..
    <ID:0/005> DO NOT TURN OFF TARGET!!
    <ID:0/005> Get PIT for mapping..
    <ID:0/005> Firmware update start..
    <ID:0/005> sbl1.mbn
    <ID:0/005> NAND Write Start!!
    <ID:0/005> sbl2.mbn
    <ID:0/005> sbl3.mbn
    <ID:0/005> rpm.mbn
    <ID:0/005> aboot.mbn
    <ID:0/005>
    <ID:0/005> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
  • Back to where these points began

Apologies for the length, but again I wanted to be as thorough as possible. My WiFi still won't turn on due to permissions issues and Data is on, but no 3g/4g/LTE comes through.

Surely I'm just missing an essential step or two.
Can you offer any further advice on this matter?
 
jd1639
Old
#10  
jd1639's Avatar
Recognized Contributor
Thanks Meter 3055
Posts: 9,085
Join Date: Sep 2012
Location: Minnetonka, MN
Odin can be finicky, try different usb ports, 2.0 not 3.0, and make sure you're using the cable that came with your device. I don't see that your doing anything wrong, keep trying.

Sent from my Nexus 5

The Following User Says Thank You to jd1639 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes