Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,266 Members 41,774 Now Online
XDA Developers Android and Mobile Development Forum

[Q] [AOSP] Broken telephone feature

Tip us?
 
420rootit
Old
#1  
420rootit's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Oct 2013
Exclamation [Q] [AOSP] Broken telephone feature

Guys, everytime I flashed an AOSP based Rom like Carbon on my hltexx, nobody can call me and I also can't call someone else. If I dial a number, the connection seems to break instantly but my mom told me, she got my calls but didn't hear anything. I'm also unable to change or view the access points.
Stock based Roms like Omega work correctly.

WTF am I doing wrong?

Additional Infos:
>SMS and Internet work.
>3G because my provider (Drei, Austria) is retarded.
>Android 4.4.2
>restoring an old EFS backup didn't solve the problem
>APN seems to be correct
 
Sammath
Old
#2  
Senior Member
Thanks Meter 92
Posts: 520
Join Date: Dec 2008
Location: Nijmegen
Have you tried a custom kernel like temaseks kernel?

Sent from my SM-N9005 beast of a phone.
 
420rootit
Old
#3  
420rootit's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Oct 2013
Quote:
Originally Posted by Sammath View Post
Have you tried a custom kernel like temaseks kernel?
Not yet. I'll flash CM now and try a few kernels and will post the results later.
Btw here is one with the same problem.
 
420rootit
Old
#4  
420rootit's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Oct 2013
I tried some kernels for hltexx, but everything I got was bootloops or a starting system with the same problem ;_;
 
Sammath
Old
#5  
Senior Member
Thanks Meter 92
Posts: 520
Join Date: Dec 2008
Location: Nijmegen
Have you ever Flashed a newer rom(Sammy official) or updated your modem firmware?

Sent from my SM-N9005 beast of a phone.
 
420rootit
Old
#6  
420rootit's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Oct 2013
Quote:
Originally Posted by Sammath View Post
Have you ever Flashed a newer rom(Sammy official) or updated your modem firmware?

Sent from my SM-N9005 beast of a phone.
Yes, I updated from 4.3 to 4.4.2 via odin and used the stock images for my provider. Everything worked as it should, only aosp roms had problems.
A few days ago I installed PAC again after flashing the newest stock .tar.md5 and tried the whole evening many different configurations in apn and other connection related settings. Nothing worked and i restored them all. On the next day I got a call. I couldn't explain it, but i was able to start phone calls too. With just one problem: When I call someone I lose the control over the whole Touchscreen and the buttons, so the only way to end a conversation is a hard reset via holding the power button.

I'm not sure, but I have the theory that the RIL file isn't compatible to the modem. Where can I find some RILs?

Another strange fact is, that everytime I flashed an AOSP, i formated the device via TWRP to erase all the bloatware and then made a full wipe. But last week I forgot to format the storage. Guys, was I really everytime this stupid and simply wiped the RIL partition away?
 
radicalisto
Old
#7  
radicalisto's Avatar
Senior Member
Thanks Meter 1385
Posts: 3,412
Join Date: Nov 2013
Location: York

 
DONATE TO ME
Model number?
Firmware you have upgraded to (4.4.2)?
Tried changing recovery, Wipe System, wipe cache, data, then flash the ROM fresh. boot into it, head to Settings > about and check if you have lost Baseband and/or Serial Number/IMEI - then we'll figure it out for you
// LG G3 (D855) // Stock // Stock //

// HTC One (M8) // GPE Stock // Stock GPE//

// Nexus 7 (flo) // Android L // Stock//

S3(White) > M7(Red) > Note 3(Black) > Nexus 5(Black) > M8(Gunmetal)/LG G3 (Titan Grey)
 
420rootit
Old
#8  
420rootit's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Oct 2013
Quote:
Originally Posted by radicalisto View Post
Model number?
Firmware you have upgraded to (4.4.2)?
Tried changing recovery, Wipe System, wipe cache, data, then flash the ROM fresh. boot into it, head to Settings > about and check if you have lost Baseband and/or Serial Number/IMEI - then we'll figure it out for you
Sorry for answering so late. Changing every password after heartbleed took much time.
My model number is SM-9005
Even with a CWM based recovery and after a wipe with a complete reinstall I get the same problem.
IMEI and Baseband (N9005XXUENB1) are still here.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...