FORUMS

device not available, only in adb shell

23 posts
Thanks Meter: 16
 
By mdelaney1986, Junior Member on 4th April 2014, 07:51 AM
Post Reply Subscribe to Thread Email Thread
C:\ADBTOOLS>adb devices
List of devices attached
da4d4717 device


C:\ADBTOOLS>adb shell
shell@android:/ $ su
su
root@android:/ # adb devices
adb devices
* daemon not running. starting it now on port 5038 *
* daemon started successfully *
List of devices attached

root@android:/ #


my device connects to adb,

however as soon as I go into adb shell, the device is no longer found.

What is going on here?
 
 
4th April 2014, 09:35 AM |#2  
neutrondev's Avatar
Recognized Contributor
Flag Bucharest
Thanks Meter: 1,504
 
Donate to Me
More
Quote:
Originally Posted by mdelaney1986

C:\ADBTOOLS>adb devices
List of devices attached
da4d4717 device


C:\ADBTOOLS>adb shell
shell@android:/ $ su
su
root@android:/ # adb devices
adb devices
* daemon not running. starting it now on port 5038 *
* daemon started successfully *
List of devices attached

root@android:/ #


my device connects to adb,

however as soon as I go into adb shell, the device is no longer found.

What is going on here?

Of course that happens when you run adb shell you are entering in your phone using the debbuging shell. You are in your phone. This happens to me also when i am using adb shell no devices will be shown. If you can run any command from adb shell then your device is there. Nothing to worry about. It is normal.
If you disconnect your device when in adb shell you will see it will automatically exit the shell!

Hit Thanks if i helped you!
Last edited by neutrondev; 4th April 2014 at 09:41 AM. Reason: Some more info
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes