Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

device not available, only in adb shell

OP mdelaney1986

4th April 2014, 08:51 AM   |  #1  
OP Junior Member
Flag Calgary
Thanks Meter: 16
 
23 posts
Join Date:Joined: Feb 2014
Donate to Me
More
C:\ADBTOOLS>adb devices
List of devices attached
da4d4717 device


C:\ADBTOOLS>adb shell
shell@android:/ $ su
su
root@android:/ # adb devices
adb devices
* daemon not running. starting it now on port 5038 *
* daemon started successfully *
List of devices attached

root@android:/ #


my device connects to adb,

however as soon as I go into adb shell, the device is no longer found.

What is going on here?
4th April 2014, 10:35 AM   |  #2  
christi9503's Avatar
Senior Member
Flag Bucharest
Thanks Meter: 169
 
314 posts
Join Date:Joined: Aug 2013
Donate to Me
More
Quote:
Originally Posted by mdelaney1986

C:\ADBTOOLS>adb devices
List of devices attached
da4d4717 device


C:\ADBTOOLS>adb shell
shell@android:/ $ su
su
root@android:/ # adb devices
adb devices
* daemon not running. starting it now on port 5038 *
* daemon started successfully *
List of devices attached

root@android:/ #


my device connects to adb,

however as soon as I go into adb shell, the device is no longer found.

What is going on here?

Of course that happens when you run adb shell you are entering in your phone using the debbuging shell. You are in your phone. This happens to me also when i am using adb shell no devices will be shown. If you can run any command from adb shell then your device is there. Nothing to worry about. It is normal.
If you disconnect your device when in adb shell you will see it will automatically exit the shell!

Hit Thanks if i helped you!
Last edited by christi9503; 4th April 2014 at 10:41 AM. Reason: Some more info
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes