Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,782 Members 38,376 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Compiled OmniRom not booting

Tip us?
 
MrMarques01
Old
#1  
Senior Member - OP
Thanks Meter 97
Posts: 177
Join Date: Jun 2011
Default [Q] Compiled OmniRom not booting

Hi everyone,

I've successfully built OmniRom from source for my Nexus 5 using this guide: http://forum.xda-developers.com/goog...-aokp-t2617919

The ROM builds fine and the omni-4.4.2-xxx-hammerhead-homemade.zip is created in /out/target/product/hammerhead.

However, when I flash that zip file, my phone is stuck on the Google logo and it won't boot into the system.
Is there anything I am missing?
A Google search didn't reveal anything.

Thanks in advance!
 
jeffsf
Old
#2  
jeffsf's Avatar
Recognized Contributor
Thanks Meter 975
Posts: 1,081
Join Date: Mar 2011
Location: San Francisco

 
DONATE TO ME
I'm assuming you've already downloaded and extracted the proprietary blobs, yes?


---
Posted from whatever phone booted today
Nexus 5, custom OmniROM builds (don't panic, it means I can brick my SGS4G without fear)
Samsung Galaxy S 4G -- Development version of OmniROM
Fromerly: Development version of Team Acid's CM9 source, Hefe Kernel of Darkness, KG4 modem.
Working on: Cleaning up the build tree for OmniROM and Samsung kernel sources


WiFi Performance, GB vs. ICS, and how to measure it yourself.

FreeBSD, Ubuntu, MacOS X, OpenWRT
Motorola Micro-TAC ("Micro" ) Nokia 2160, 8260, 6681, E70, N900, then had to move on
The Following User Says Thank You to jeffsf For This Useful Post: [ Click to Expand ]
 
MrMarques01
Old
(Last edited by MrMarques01; 6th April 2014 at 11:38 AM.)
#3  
Senior Member - OP
Thanks Meter 97
Posts: 177
Join Date: Jun 2011
I knew I was missing something. Can you point me to the right direction how to do it?

edit:// Nevermind, found it and building as we speak! Thanks!

edit2:// The missing proprietary blobs were the issue indeed. My phone just booted into my first self-built ROM. Cheers!
For anyone having the same issue: Here's a good guide for getting and extracting the missing files.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes