Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,660 Members 54,209 Now Online
XDA Developers Android and Mobile Development Forum

WiFi connection is stable, but Internet isn't

Tip us?
 
Cullinan
Old
#1  
Cullinan's Avatar
Junior Member - OP
Thanks Meter 9
Posts: 8
Join Date: Dec 2012
Default WiFi connection is stable, but Internet isn't

Somebody please delete my previous thread (wrong forum), thank you: http://forum.xda-developers.com/show....php?t=2707468

------------------------------------

WiFi connects to my router and stays connected at excellent signal strength without any trouble. Internet connection however, always disappears after a minute or so. Then my Dolphin Browser either keeps loading a website forever or gives me some error like "Webpage not available". Same story with stock or any other browser. I'm not sure since how long I have had this issue. It surely existed already when my phone came back from warranty service (and I had sent it there because of very short range of WiFi commonly known problem which they fixed by giving the phone new hardware). I think that upgrade to Android 4.2.2 might have caused my problem, but it was such a long time ago that I don't remember now (I don't use/need WiFi that much, mobile data internet is enough for me).

What I've tried so far:
-rebooting phone and router obviously
-factory formatting the phone
-WiFi analyzer app
-changing all the network parameters and re-setting it up
-WPS connecting
-playing with all the WiFi settings on my phone (proxy settings, ip settings, wifi optimization and other)
-finally, today I unlocked bootloader, rooted and installed custom ROM hoping it'd help (but it didn't and now I lost my warranty lol)

What I have:
HTC One X Endeavor
Android 4.2.2 HTC Sense 5.0
Android Revolution HD 33.1
3.1.10-g7f360be Kernel version
TP-LINK
N750 Wireless Dual Band Gigabit Router
Model No. TL-WDR4300

I'm thinking about installing other ROM, some that works on Android 4.0 or KitKat, could it help?
Oh, and I should add that two different notebooks, Galaxy S4, S3 mini, Xperia X10 and a tablet all work fine with this network :>
I can provide any screenshots, photos, names of devices etc., just tell me what is needed.
HELP!
 
|>/\nte
Old
#2  
|>/\nte's Avatar
Senior Member
Thanks Meter 19
Posts: 149
Join Date: Jun 2013
Location: Utopia
I have a similar problem with my device, but I just reset my router and it's fine. Maybe your problem is that your phone doesn't receive an ip address. You can check out if you have received an address via settings->wi-fi-> advanced, and check the 'ip address'. If it says ' not available, reset your router and your phone's wi-fi until you get one.
Phone: Sony xperia sp (c5303)
Android version: 4.1.2
Kernel version: 3.4.0-perf-g1285c6c-01149-g40c437a BuildUser@BuildHost) ) #1 SMP PREEMPT Wed Aug 14 17:10:55 2013
Baseband version: 8960A-AAAAATAZQ-40031007-13
Build number: 12.0.A.2.254

 
Cullinan
Old
#3  
Cullinan's Avatar
Junior Member - OP
Thanks Meter 9
Posts: 8
Join Date: Dec 2012
Quote:
Originally Posted by |>/\nte View Post
I have a similar problem with my device, but I just reset my router and it's fine. Maybe your problem is that your phone doesn't receive an ip address. You can check out if you have received an address via settings->wi-fi-> advanced, and check the 'ip address'. If it says ' not available, reset your router and your phone's wi-fi until you get one.
Nopes, IP reception is fine. Here are all my settings:
Status: Connected
Signal strength: Excellent
Link speed: 26Mbps
Security: WPA/WPA2 PSK
IP address: 192.168.0.101
Proxy settings: None
IP settings: DHCP

As I said earlier, I have been playing with all the network settings above as well as with the phone WiFi advanced settings and it didn't change anything.
 
|>/\nte
Old
#4  
|>/\nte's Avatar
Senior Member
Thanks Meter 19
Posts: 149
Join Date: Jun 2013
Location: Utopia
Hm…it may be a hardware problem.
Phone: Sony xperia sp (c5303)
Android version: 4.1.2
Kernel version: 3.4.0-perf-g1285c6c-01149-g40c437a BuildUser@BuildHost) ) #1 SMP PREEMPT Wed Aug 14 17:10:55 2013
Baseband version: 8960A-AAAAATAZQ-40031007-13
Build number: 12.0.A.2.254

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes