Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,054 Members 40,159 Now Online
XDA Developers Android and Mobile Development Forum

[Q] *Strange* Error when recompiling -none system apk-

Tip us?
 
MPooZD
Old
(Last edited by MPooZD; 2nd April 2014 at 10:30 PM.)
#1  
Senior Member - OP
Thanks Meter 17
Posts: 164
Join Date: Feb 2012
Unhappy [Q] *Strange* Error when recompiling -none system apk-

Hi Guys ,

I've a Strange problem when i recompile

I'm getting this error when i recompile -without modification- :
http://pastebin.com/S8Td4QxV


Then i've searched about the error and found some answer that said delete public.xml , i do that then i've got this error :
http://pastebin.com/tRechubZ

Then i've searched about the error and found some answer that said add @+ before drawable in xml in drawable , i do that then the error message has gone and i recompiled and signed apk without errors but after install apk in device i got force close , so what's problem exactly

BTW i've tired recompiling other apks without any problems

apk in Attach
Attached Files
File Type: apk com.catfiz-2.apk - [Click for QR Code] (2.20 MB, 6 views)
 
MPooZD
Old
#2  
Senior Member - OP
Thanks Meter 17
Posts: 164
Join Date: Feb 2012
How i do fix that please
 
lacoursiere18
Old
#3  
lacoursiere18's Avatar
Recognized Themer
Thanks Meter 3663
Posts: 2,691
Join Date: Jan 2013
Location: Boca Raton

 
DONATE TO ME
Quote:
Originally Posted by MPooZD View Post
How i do fix that please
Hmm seems weird.. It's like it needs certain framework to pull the correct public ids.. is this a system app? Or what rom did you get it from? If you pulled it from a rom..try installing that roms frameworks in apk tool. .then decompile it..
If not..pull a log and see what errors it's throwing at you when it fcs. .If you want post it here..and I'll see if I can help you at all

Sent from my SCH-I605 using xda app-developers app
The Following User Says Thank You to lacoursiere18 For This Useful Post: [ Click to Expand ]
 
MPooZD
Old
(Last edited by MPooZD; 4th April 2014 at 11:53 AM.)
#4  
Senior Member - OP
Thanks Meter 17
Posts: 164
Join Date: Feb 2012
Quote:
Originally Posted by lacoursiere18 View Post
Hmm seems weird.. It's like it needs certain framework to pull the correct public ids.. is this a system app? Or what rom did you get it from? If you pulled it from a rom..try installing that roms frameworks in apk tool. .then decompile it..
If not..pull a log and see what errors it's throwing at you when it fcs. .If you want post it here..and I'll see if I can help you at all

Sent from my SCH-I605 using xda app-developers app
Thanks for respond
it's none system app
Attached Files
File Type: txt 2014-04-04-13-48-06.txt - [Click for QR Code] (8.5 KB, 3 views)
 
lacoursiere18
Old
(Last edited by lacoursiere18; 4th April 2014 at 12:36 PM.)
#5  
lacoursiere18's Avatar
Recognized Themer
Thanks Meter 3663
Posts: 2,691
Join Date: Jan 2013
Location: Boca Raton

 
DONATE TO ME
Quote:
[quote name="lacoursiere18" post=51624609]Hmm seems weird.. It's like it needs certain framework to pull the correct public ids.. is this a system app? Or what rom did you get it from? If you pulled it from a rom..try installing that roms frameworks in apk tool. .then decompile it..
If not..pull a log and see what errors it's throwing at you when it fcs. .If you want post it here..and I'll see if I can help you at all

Sent from my SCH-I605 using xda app-developers app
Thanks for respond
it's none system app[/QUOTE]

Looks like it is not installing correctly.. Also what Android version are you on? Does this app support it?
It is also requesting to write to internal storage which I know something in 4.4 have changed with that.
? Why are you decompiling it?
Sent from my SCH-I605 using xda app-developers app
 
MPooZD
Old
#6  
Senior Member - OP
Thanks Meter 17
Posts: 164
Join Date: Feb 2012
Quote:
Originally Posted by lacoursiere18 View Post
Looks like it is not installing correctly.. Also what Android version are you on? Does this app support it?
It is also requesting to write to internal storage which I know something in 4.4 have changed with that.
? Why are you decompiling it?
Sent from my SCH-I605 using xda app-developers app

i'm on 4.4.2 , yes support and works fine
But I got lots of error when i tried to decompile it without modified or changes !!
I'd change colors in xml


BTW all apps i had decompiled working fine , but had an error in this one
 
MPooZD
Old
#7  
Senior Member - OP
Thanks Meter 17
Posts: 164
Join Date: Feb 2012
UP UP
 
MPooZD
Old
#8  
Senior Member - OP
Thanks Meter 17
Posts: 164
Join Date: Feb 2012
BumpUp!
 
MPooZD
Old
#9  
Senior Member - OP
Thanks Meter 17
Posts: 164
Join Date: Feb 2012
Is there any solutions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Remove Unnecessary WhatsApp Elements with Xposed

In modern life, you can’t underestimate the power ofthe dark sidemessaging … more

MaR-V-iN to Talk Google and Android APIs at XDA:DevCon 2014

Our international xda:devcon 14in Manchester, UK on the weekend of September … more

But First, Let Me Take a #Selfie

“Today while browsing XDA,I’m going tocheck to seeif my favorite ROM has been updated–but … more