Make Your Own Heat Sink for the LG Optimus 4X HD

Its not a rare occurrence that performing a resource heavy task on your Android device (e.g. … more

Learn How to Create an Old School Dialer

XDA is not only a great source for custom ROMs, kernels, and various modifications for numerous … more

USB Desktop Charger Roundup – XDA TV

Sometimes you learn one way to do something, and that’s the way you do it forever. You never … more

Samsung Galaxy Grand Duos Receives Early CM12 Port

Samsung Galaxy Grand is a dual-SIM phone with a 5 screen that was announced two years ago. … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] *Strange* Error when recompiling -none system apk-

OP MPooZD

2nd April 2014, 11:27 PM   |  #1  
OP Senior Member
Thanks Meter: 17
 
166 posts
Join Date:Joined: Feb 2012
Hi Guys ,

I've a Strange problem when i recompile

I'm getting this error when i recompile -without modification- :
http://pastebin.com/S8Td4QxV


Then i've searched about the error and found some answer that said delete public.xml , i do that then i've got this error :
http://pastebin.com/tRechubZ

Then i've searched about the error and found some answer that said add @+ before drawable in xml in drawable , i do that then the error message has gone and i recompiled and signed apk without errors but after install apk in device i got force close , so what's problem exactly

BTW i've tired recompiling other apks without any problems

apk in Attach
Attached Files
File Type: apk com.catfiz-2.apk - [Click for QR Code] (2.20 MB, 6 views)
Last edited by MPooZD; 2nd April 2014 at 11:30 PM.
3rd April 2014, 08:04 PM   |  #2  
OP Senior Member
Thanks Meter: 17
 
166 posts
Join Date:Joined: Feb 2012
How i do fix that please
4th April 2014, 02:15 AM   |  #3  
lacoursiere18's Avatar
Recognized Themer
Flag LbTs
Thanks Meter: 5,190
 
3,587 posts
Join Date:Joined: Jan 2013
Donate to Me
More
Quote:
Originally Posted by MPooZD

How i do fix that please

Hmm seems weird.. It's like it needs certain framework to pull the correct public ids.. is this a system app? Or what rom did you get it from? If you pulled it from a rom..try installing that roms frameworks in apk tool. .then decompile it..
If not..pull a log and see what errors it's throwing at you when it fcs. .If you want post it here..and I'll see if I can help you at all

Sent from my SCH-I605 using xda app-developers app
The Following User Says Thank You to lacoursiere18 For This Useful Post: [ View ]
4th April 2014, 12:33 PM   |  #4  
OP Senior Member
Thanks Meter: 17
 
166 posts
Join Date:Joined: Feb 2012
Quote:
Originally Posted by lacoursiere18

Hmm seems weird.. It's like it needs certain framework to pull the correct public ids.. is this a system app? Or what rom did you get it from? If you pulled it from a rom..try installing that roms frameworks in apk tool. .then decompile it..
If not..pull a log and see what errors it's throwing at you when it fcs. .If you want post it here..and I'll see if I can help you at all

Sent from my SCH-I605 using xda app-developers app

Thanks for respond
it's none system app
Attached Files
File Type: txt 2014-04-04-13-48-06.txt - [Click for QR Code] (8.5 KB, 3 views)
Last edited by MPooZD; 4th April 2014 at 12:53 PM.
4th April 2014, 01:34 PM   |  #5  
lacoursiere18's Avatar
Recognized Themer
Flag LbTs
Thanks Meter: 5,190
 
3,587 posts
Join Date:Joined: Jan 2013
Donate to Me
More
Quote:

[quote name="lacoursiere18" post=51624609]Hmm seems weird.. It's like it needs certain framework to pull the correct public ids.. is this a system app? Or what rom did you get it from? If you pulled it from a rom..try installing that roms frameworks in apk tool. .then decompile it..
If not..pull a log and see what errors it's throwing at you when it fcs. .If you want post it here..and I'll see if I can help you at all

Sent from my SCH-I605 using xda app-developers app

Thanks for respond
it's none system app[/QUOTE]

Looks like it is not installing correctly.. Also what Android version are you on? Does this app support it?
It is also requesting to write to internal storage which I know something in 4.4 have changed with that.
? Why are you decompiling it?
Sent from my SCH-I605 using xda app-developers app
Last edited by lacoursiere18; 4th April 2014 at 01:36 PM.
4th April 2014, 02:28 PM   |  #6  
OP Senior Member
Thanks Meter: 17
 
166 posts
Join Date:Joined: Feb 2012
Quote:
Originally Posted by lacoursiere18

Looks like it is not installing correctly.. Also what Android version are you on? Does this app support it?
It is also requesting to write to internal storage which I know something in 4.4 have changed with that.
? Why are you decompiling it?
Sent from my SCH-I605 using xda app-developers app


i'm on 4.4.2 , yes support and works fine
But I got lots of error when i tried to decompile it without modified or changes !!
I'd change colors in xml


BTW all apps i had decompiled working fine , but had an error in this one
5th April 2014, 01:05 PM   |  #7  
OP Senior Member
Thanks Meter: 17
 
166 posts
Join Date:Joined: Feb 2012
UP UP
6th April 2014, 10:44 PM   |  #8  
OP Senior Member
Thanks Meter: 17
 
166 posts
Join Date:Joined: Feb 2012
BumpUp!
8th April 2014, 11:40 AM   |  #9  
OP Senior Member
Thanks Meter: 17
 
166 posts
Join Date:Joined: Feb 2012
Is there any solutions

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes