Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Proximity sensor issue??

OP Inane65

3rd April 2014, 09:03 PM   |  #1  
OP Member
Thanks Meter: 7
 
61 posts
Join Date:Joined: Nov 2012
Wondering if someone (hopefully more than one) can check something to see if this is an issue with my particular phone or something related to the software/hardware. It seems that when a call is placed or received, the proximity sensor goes to "far" and won't reset until it is uncovered and then re-covered. I have searched through the Verizon HTC One forums and have not found anything related to this issue.

If the proximity sensor is covered, and I make a call (via bluetooth headset (double click for last dialed)) or receive a call, the proximity sensor goes to the uncovered state. It then stays in that state until I uncover and then re-cover it. How I checked this was using Elixir 2 and checking the sensor data. I also set up variables in Tasker and Automagic.

So, this was my test procedure:
I start the sensor data in Elixir 2 for the proximity sensor. I cover the sensor with my finger (it now shows "near"). I use my bluetooth headset to place a call. The screen comes on with the current call. I back out of the current screen (the phone screen) and get back to Elixir 2 sensor data. The sensor now shows "far". From that point on, until I uncover the proximity sensor and then cover it, it shows far. I set up variables in Tasker and Automagic that show the same results.

I am running the stock debloated ROM. Rooted and S-Off.
Last edited by Inane65; 3rd April 2014 at 09:06 PM. Reason: Changed to question
3rd April 2014, 10:34 PM   |  #2  
cmlusco's Avatar
Senior Member
Flag Michigan City, IN
Thanks Meter: 932
 
3,146 posts
Join Date:Joined: Nov 2010
Donate to Me
More
Dont know about the bluetooth thing because i dont have one, but i do have issues sometimes with the proximity sensor when on calls. For example i will dial a number and put the phone to my ear talk awhile and then need to switch to speaker or look at something on the phone while still talking. But when i take the phone away from my ear, the screen stays off, and i have to swipe my finger over the sensor to get it to come back on.
4th April 2014, 12:19 AM   |  #3  
OP Member
Thanks Meter: 7
 
61 posts
Join Date:Joined: Nov 2012
I don't seem to have an issue with that. What seems to happen is that, IF the proximity sensor is covered, and you place a call or answer a call with your headset, when the device "wakes up" to the call screen the proximity sensor defaults to uncovered ( "far" ). Then the sensor does not start responding again until it is actually uncovered.

Sent from my HTC6500LVW using XDA Premium 4 mobile app
Last edited by Inane65; 4th April 2014 at 12:35 AM.
8th April 2014, 09:15 PM   |  #4  
OP Member
Thanks Meter: 7
 
61 posts
Join Date:Joined: Nov 2012
Anyone?
Hmmm... So, this is the latest for my issue. I went from stock ROM to ViperOne 5.8.0. I am still getting the same results. So, I think I have eliminated the software side of it. Would that be right? So, it could be the firmware or the hardware? I'm still wondering if it's my phone only or if it is an issue with the HTC One in general. Is there anyone that can check this? Or give me another route to take?

I'm on ViperOne 5.8.0
Android 4.4.2
Senses 5.5

Any other info you might need, please just ask.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes