Default How Do I Root MY Evo 3D :'( PLEASE HELP

I have Sprint CDMA Evo 3D NOT ROOTED
SHOOTER XC SHIP S-ON RL
HBOOT-1.58.0000
eMMC-boot
Software Version: 2.95.651.6 710RD

I have been stressing for hours trying to figure this out!
I tried following a tutorial to root the phone and I get stuck trying to unlock the bootloader following htcdev.
After I enter the commands I do not get a dialog on my phone screen asking to unlock bootloader. After googling the issue i found that many people have this problem and running the RUU will fix the problem. I ran the 2.89.651.2 RUU and it failed saying that I have the wrong RUU. The problem is There is no RUU for my current version. I googled this problem as well and barley found answers, the answers I did find said I had to downgrade to 2.89.651.2 I had no idea how to do this and when i looked up how to do it I found an answer that said running the RUU while in temproot state will work (which i tried and got the same outcome as before) I found another answer that said I have to install a recovery and then flash a file that would lower my version and allow me to RUU. I got the img file for the recovery and put it in PG86IMG.zip and put that on my sd card and when i went into hboot it says checking PG86IMG.zip but then it just goes back to the regular hboot screen. Then i looked up an ADB method to flash recovery, I put the img with my fastboot and ran the commands and ended with


C:\Users\Yianni\Desktop\adt-bundle-windows-x86_64-20140321\sdk\platf
stboot flash recovery recovery.img
sending 'recovery' (6914 KB)...
OKAY [ 1.787s]
writing 'recovery'...
(bootloader) signature checking...
FAILED (remote: signature verify fail)
finished. total time: 3.759s

Now im lost
Breakdown:
Im trying to root
I need to unlock bootloader first
I need to RUU before I unlock bootloader but i cant without downgrading
I cant successfully downgrade
****
Any help is greatly appreciated!!