Default [Q] HELP! Boot loop and Mythtools freezing when flashing stock firmware

Okay, I have an Atrix HD that I have rooted and unlocked the bootloader and I have been running the SlimKat ROM with little to no problems and Philz Touch recovery for about a week until yesterday when my phone reset itself and started to boot loop. They only other thing I had flashed was a new logo to get rid of that stupid unlocked bootloader warning. I am fairly savvy when it comes to rooting and flashing roms because I have done this for years with various Samsung devices but the Motorola is a little new to me with having Fastboot.

Let me tell you what I have tried...

I first did a factory data reset in Philz and that did nothing.... then I tried to recover it back to my stock rom that I was running before using a nandroid backup that I had made with Philz Touch and same thing happened, it just sticks in boot loop. I then try to flash the PAC rom after I do a factory data reset and all the wipes I need to flash a new rom in Philz Touch to see if I can get a different rom to load and nothing happens but boot loop again.

Next I go to the forums to find answers and I start to set up my ADB on my computer... After I get ADB setup I first do fastboot -w to do a factory data reset through fastboot, download the stock Mexican rom and tried to flash all the components individually with ADB in fastboot the way skeevydude mentioned in one of his threads (sorry I can't remember which one) and I got a failed error "FAILED (remote failure)" when I tried to flash the system.img.

I then went to Mythtools v1.3 because I thought that I was doing something wrong with the ADB and fastboot... I put the stock Mexico retail rom into the firmware folder in Mythtools and tried to flash the stock firmware through Mythtools. Mythtoold froze when it rebooted the fastboot at 50 of 100%

Now I am at a loss, I have done everything that I know to try to fix this and I have searched everywhere for help and I need help. This is they only phone that I have because I just switched over to to a new carrier and just purchased this phone.

Any help would be appreciated!

UPDATE
I went into Philz Touch and formatted the /system so I could try and flash it again and now the phone boots straight to fastboot and Philz touch if I hold volume+ and power. I am going to download the stock mex retail rom and try and flash it through Philz touch.

UPDATE
I got an Error mounting /data when I tried to format the /data and when I tried to intall the Mexico retail rom I got a "set_perm: some changes failed E:Error in /storage/sdcard1/Atrix HD Mexico Retail 4.1.2.zip (Status 7) Installation aborted."

UPDATE
I formatted /data and /data media in Philz Touch and then it started mounting /data so I wiped and install PAC rom and it booted up just fine.