Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,290 Members 53,165 Now Online
XDA Developers Android and Mobile Development Forum

Help installing TWRP 2.7 on new G2 with 12B

Tip us?
 
ECrispy
Old
#1  
Senior Member - OP
Thanks Meter 202
Posts: 1,228
Join Date: Jun 2010
Default Help installing TWRP 2.7 on new G2 with 12B

I have downloaded a TWRP 2.7 flashable zip. The official instructions on the TWRP site talk about using a .img file, but they don't have a 2.7 img for vs980.

Many threads mention some images are Lokified, others are not, I'm not sure how to install.

This is a new G2 with 12B that I'm going to root with IORoot 25, how can I get TWRP installed on it as well, preferably in same adb session?

Thanks
 
ECrispy
Old
#2  
Senior Member - OP
Thanks Meter 202
Posts: 1,228
Join Date: Jun 2010
Is this the right way?

flash older 2.6.3.2 img using Flashify
reboot into recovery
flash 2.7 zip

Is there a faster way to do this?
 
ECrispy
Old
#3  
Senior Member - OP
Thanks Meter 202
Posts: 1,228
Join Date: Jun 2010
Can someone please help?
 
twolasrnames
Old
#4  
Member
Thanks Meter 22
Posts: 88
Join Date: Jan 2012
Location: Omaha
Quote:
Originally Posted by ECrispy View Post
Can someone please help?
Root with ioroot
Flashify has its own download section, I would download the .IMG file in the app, just to make sure you have the correct one.
Follow directions in flashify.

I just did this with cwm and it worked, it might have the latest twrp to flash in the app.
 
xemnas18
Old
#5  
xemnas18's Avatar
Senior Member
Thanks Meter 32
Posts: 160
Join Date: Jan 2014
Quote:
Originally Posted by ECrispy View Post
Can someone please help?
If you just want the easiest method, do this:

Extract twrp.lok from this thread. (first download twrp.zip...the .lok file is in there) Rename the extension to img. Flash that with flashify. Then flash this in recovery. You should now be on twrp 2.7 loki'd for 12b.

Credit for that procedure goes to JRJ442...i just explained his steps from here.
The Following 2 Users Say Thank You to xemnas18 For This Useful Post: [ Click to Expand ]
 
gbeardmore
Old
#6  
Senior Member
Thanks Meter 47
Posts: 243
Join Date: Mar 2011
Location: Green Bay

 
DONATE TO ME
Quote:
Originally Posted by xemnas18 View Post
If you just want the easiest method, do this:

Extract twrp.lok from this thread. (first download twrp.zip...the .lok file is in there) Rename the extension to img. Flash that with flashify. Then flash this in recovery. You should now be on twrp 2.7 loki'd for 12b.

Credit for that procedure goes to JRJ442...i just explained his steps from here.
+1 This works perfectly.
Phone: LG G2
Tab: Nexus 10
Neglected: Nook Color
Retired: HTC Inspire 4G
 
glhelinski
Old
#7  
Junior Member
Thanks Meter 5
Posts: 17
Join Date: Oct 2010
Quote:
Originally Posted by xemnas18 View Post
If you just want the easiest method, do this:

Extract twrp.lok from this thread. (first download twrp.zip...the .lok file is in there) Rename the extension to img. Flash that with flashify. Then flash this in recovery. You should now be on twrp 2.7 loki'd for 12b.

Credit for that procedure goes to JRJ442...i just explained his steps from here.
Will this method work if I already have TWRP 2.6.3.3? My goal is: get to TWRP 2.7 but tried to go into TWRP and flash the "openrecovery-twrp-2.7.0.0-vs980.zip", it tells me I can't because it can't find "/tmp/loki.sh" (couldn't capture exact message). Currently I'm on 12B.
thanks
 
JRJ442
Old
(Last edited by JRJ442; 28th April 2014 at 05:59 AM.)
#8  
JRJ442's Avatar
Senior Member
Thanks Meter 1,247
Posts: 2,200
Join Date: Jan 2011
Location: Salisbury, Md

 
DONATE TO ME
Quote:
Originally Posted by glhelinski View Post
Will this method work if I already have TWRP 2.6.3.3? My goal is: get to TWRP 2.7 but tried to go into TWRP and flash the "openrecovery-twrp-2.7.0.0-vs980.zip", it tells me I can't because it can't find "/tmp/loki.sh" (couldn't capture exact message). Currently I'm on 12B.
thanks
Yeah the official that you tried doesn't have the correct Loki patch for 12B. Thats why it throws that message. All the ones I made for VS980 are patched to work on 11A or 12B. Just click on "This" a few posts up. That goes to my Dropbox. The zip is Stock-TWRP2.7-VS980. Just flash in recovery, then reboot recovery and it'll be 2.7
Or if you have Flashify you can download and install 2.7 through that.
The Following User Says Thank You to JRJ442 For This Useful Post: [ Click to Expand ]
 
Cydiggitydog
Old
#9  
Cydiggitydog's Avatar
Junior Member
Thanks Meter 0
Posts: 7
Join Date: May 2013
Location: Fort Collins
These one click tools worked for me. I went from 12b + stock recovery to twrp 2.7 with just a few clicks. I used it yesterday. Thread http://forum.xda-developers.com/show....php?t=2713954

Sent from my VS980 4G using XDA Premium 4 mobile app
 
glhelinski
Old
#10  
Junior Member
Thanks Meter 5
Posts: 17
Join Date: Oct 2010
Quote:
Originally Posted by JRJ442 View Post
Yeah the official that you tried doesn't have the correct Loki patch for 12B. Thats why it throws that message. All the ones I made for VS980 are patched to work on 11A or 12B. Just click on "This" a few posts up. That goes to my Dropbox. The zip is Stock-TWRP2.7-VS980. Just flash in recovery, then reboot recovery and it'll be 2.7
Or if you have Flashify you can download and install 2.7 through that.
thanks. worked as expected.

The Following User Says Thank You to glhelinski For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes