Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Trouble updating to 4.4 (Rooted / CWM)

OP OChrisJones

9th April 2014, 09:29 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Apr 2014
Hi xda,

Can anybody help me in updating my shield to the latest update 72? I have a rooted NVIDIA Shield on (I believe) update 68, Android 4.3 Jelly Bean. I have clockworkmod recovery installed as the bootloader. Upon downloading the update and hitting restart, it brings up CWM and asks if I want to flash the update zip it downloaded, click yes, says root may have been lost - fix? click yes/no, doesn't matter I've tried both and then it boots right back up and says the system update is still available. SO it's obviously not installing correctly.

Can anybody help me out? Is it possible to install the OTA update with CWM, or do I have to restore the default android bootloader? And if so, do I also have to unroot? Factory reset? What would be the easiest way of updating?

Thanks in advance, I'm loving my Shield!
10th April 2014, 07:34 AM   |  #2  
Gnurou's Avatar
Member
Flag Tokyo
Thanks Meter: 55
 
85 posts
Join Date:Joined: Aug 2010
You will need to revert to the stock recovery before you perform the update, as CWM cannot do it for some reason.

If you are not using CWM features outside of rooting, you might prefer this rooting method which does not require installing it so you can just do OTA upgrades without worrying:

https://github.com/linux-shield/shield-root
10th April 2014, 03:53 PM   |  #3  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2010
Failed OTA with a twist...
I also tried the OTA with a rooted/CWM Shield and failed. However, I found this thread and reverted to stock recovery as instructed. But now, it says there are no updates available, and still reports I'm running 4.3. So how do I get it to update?
10th April 2014, 08:39 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Apr 2014
Quote:
Originally Posted by rpalmer919

I also tried the OTA with a rooted/CWM Shield and failed. However, I found this thread and reverted to stock recovery as instructed. But now, it says there are no updates available, and still reports I'm running 4.3. So how do I get it to update?

I actually had the same problem as you after reverting back to stock recovery. The only solution I could find was to 1) Backup everything on my Shield and 2) Factory reset. After factory resetting, the OTA update was detected, and installed flawlessly. I'm now on 4.4 Kit Kat, stock recovery, and am in the process of restoring all my apps and then re-rooting.
10th April 2014, 11:28 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Apr 2014
525 45863523
Quote:
Originally Posted by Gnurou

You will need to revert to the stock recovery before you perform the update, as CWM cannot do it for some reason.

If you are not using CWM features outside of rooting, you might prefer this rooting method which does not require installing it so you can just do OTA upgrades without worrying:

Just an update:

After going back to stock recovery, factory resetting for the OTA update to detect, installing it, restoring all my apps, and re-rooting using the method above, everything is running great. Future OTA updates with ease as well as being able to have root access!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes