Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,201 Members 51,936 Now Online
XDA Developers Android and Mobile Development Forum

SR Tool flashing system.img hangs for hours on end - any solution?

Tip us?
 
34158245
Old
(Last edited by 34158245; 10th April 2014 at 06:00 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Apr 2014
Default SR Tool flashing system.img hangs for hours on end - any solution?

Bricked KFHD 8.9in

Can get device into fastboot if I type "fastboot -i 0x1949 getvar product" but only if I enter the command immediately when connecting the device.

I tried doing the process manually by getting it into fastboot and then immediately entering "fastboot flash recovery /Users/USER/Downloads/KFHD_SRT_v2.1/images/system2.img" but it says <waiting for device> as if it weren't connected.


Any ideas?
 
stunts513
Old
#2  
stunts513's Avatar
Recognized Contributor
Thanks Meter 603
Posts: 2,182
Join Date: Feb 2013
Location: New Braunfels, TX

 
DONATE TO ME
Well that is the wrong command... In that command you tried to flash the system image to the recovery partition... Replace "recovery" with "system". Also every command has to have the -i 0x1949 or it won't work.

Sent from my Amazon Kindle Fire HD using Tapatalk
My Wallpaper Fix for KF2, KFHD 7", and KFHD 8.9" is HERE
Please Read the instructions and use the debugger if you run into errors.
My own modified adb drivers for just about all kindles (includes old twrp and cm versions) HERE
Tablet UI Patch for latest CM10.1 build HERE!

Please send complaints to /dev/null
 
34158245
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Apr 2014
Default :(

Quote:
Originally Posted by stunts513 View Post
Well that is the wrong command... In that command you tried to flash the system image to the recovery partition... Replace "recovery" with "system". Also every command has to have the -i 0x1949 or it won't work.

Sent from my Amazon Kindle Fire HD using Tapatalk
So I tried it using the correct syntax and the device went into fast boot mode, and it indicated that the file was being transferred and written successfully. However, when it rebooted, a red screen appeared and went away and the fast boot mode screen appeared... now what?
 
34158245
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Apr 2014
Quote:
Originally Posted by 34158245 View Post
So I tried it using the correct syntax and the device went into fast boot mode, and it indicated that the file was being transferred and written successfully. However, when it rebooted, a red screen appeared and went away and the fast boot mode screen appeared... now what?
I was able to flash stock system via SRT, and stock boot and stock recovery, and erased user data and cache, but my kindle fire hd89 still will not boot properly.

Error message: Your kindle doesn't seem to be able to boot

Option to factory default or reboot, have tried both options, but neither resolve issue.

Any ideas?
 
stunts513
Old
#5  
stunts513's Avatar
Recognized Contributor
Thanks Meter 603
Posts: 2,182
Join Date: Feb 2013
Location: New Braunfels, TX

 
DONATE TO ME
Quote:
Originally Posted by 34158245 View Post
I was able to flash stock system via SRT, and stock boot and stock recovery, and erased user data and cache, but my kindle fire hd89 still will not boot properly.

Error message: Your kindle doesn't seem to be able to boot

Option to factory default or reboot, have tried both options, but neither resolve issue.

Any ideas?
try reflashing it one more time, this is weird, try using kffa and see if you get any better results if the next attempt fails.
My Wallpaper Fix for KF2, KFHD 7", and KFHD 8.9" is HERE
Please Read the instructions and use the debugger if you run into errors.
My own modified adb drivers for just about all kindles (includes old twrp and cm versions) HERE
Tablet UI Patch for latest CM10.1 build HERE!

Please send complaints to /dev/null
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes