Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,719 Members 38,567 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Phone Won't Charge

Tip us?
 
mc_becker56
Old
#1  
mc_becker56's Avatar
Member - OP
Thanks Meter 4
Posts: 53
Join Date: Apr 2013
Default [Q] Phone Won't Charge

My GN2 just randomly started an issue with charging. Sometimes it will charge for about 10 minutes then it will stop. Other times it won't even recognize that I have plugged it in. Other times I will plug it in, the charging LED light will turn on, but the phone won't actually state that it is charging and won't charge regardless. It will not charge while it is turned off either. I have tried 4 different cables and blocks, tried using my computer to charge it but it doesn't recognize it anymore either. I have wiggled it into different positions, cleaned out the port, wiped cache and dalvik, flashed my ROM again, ect. The problem still persists. Do you think it is a faulty/damaged charging port? I have purchased a new one and a going to replace it when it arrives in about a week. Any other ideas in the meantime as to what it might be and how to solve it? Any help would be greatly appreciated. Thanks!


In case it matters: I am using Beanstalk 4.4 from Will03. Been running it for months with zero issues.
AT&T/Straight Talk Samsung Galaxy Note 2
KitKat 4.4 CM 11
 
Coug76
Old
#2  
Coug76's Avatar
Senior Member
Thanks Meter 664
Posts: 1,840
Join Date: Feb 2011
Location: East of Seattle
Quote:
Originally Posted by mc_becker56 View Post
My GN2 just randomly started an issue with charging. Sometimes it will charge for about 10 minutes then it will stop. Other times it won't even recognize that I have plugged it in. Other times I will plug it in, the charging LED light will turn on, but the phone won't actually state that it is charging and won't charge regardless. It will not charge while it is turned off either. I have tried 4 different cables and blocks, tried using my computer to charge it but it doesn't recognize it anymore either. I have wiggled it into different positions, cleaned out the port, wiped cache and dalvik, flashed my ROM again, ect. The problem still persists. Do you think it is a faulty/damaged charging port? I have purchased a new one and a going to replace it when it arrives in about a week. Any other ideas in the meantime as to what it might be and how to solve it? Any help would be greatly appreciated. Thanks!


In case it matters: I am using Beanstalk 4.4 from Will03. Been running it for months with zero issues.
Sounds like you have a bad port. The ports on these seem to get loose fairly easily. The replacement process is super easy. I did mine in about 10 minutes. If it hadn't been the first time it would have been faster.

Hastily spouted for your befuddlement
 
pvaldeben
Old
#3  
pvaldeben's Avatar
Senior Member
Thanks Meter 46
Posts: 257
Join Date: Feb 2011
Location: E. Rockaway
Quote:
Originally Posted by mc_becker56 View Post
My GN2 just randomly started an issue with charging. Sometimes it will charge for about 10 minutes then it will stop. Other times it won't even recognize that I have plugged it in. Other times I will plug it in, the charging LED light will turn on, but the phone won't actually state that it is charging and won't charge regardless. It will not charge while it is turned off either. I have tried 4 different cables and blocks, tried using my computer to charge it but it doesn't recognize it anymore either. I have wiggled it into different positions, cleaned out the port, wiped cache and dalvik, flashed my ROM again, ect. The problem still persists. Do you think it is a faulty/damaged charging port? I have purchased a new one and a going to replace it when it arrives in about a week. Any other ideas in the meantime as to what it might be and how to solve it? Any help would be greatly appreciated. Thanks!


In case it matters: I am using Beanstalk 4.4 from Will03. Been running it for months with zero issues.
Try another charger first. I had similar issue charging up to 20% then found out the charger was bad
 
Coug76
Old
#4  
Coug76's Avatar
Senior Member
Thanks Meter 664
Posts: 1,840
Join Date: Feb 2011
Location: East of Seattle
Quote:
Originally Posted by pvaldeben View Post
Try another charger first. I had similar issue charging up to 20% then found out the charger was bad
In the sentence where op mentions "cables and blocks", "blocks" means charger. OP has gone through pretty much all the reasonable troubleshooting steps. Only thing else is wipe, then Odin the UVALK1 ROM and see if that works.

Doubt it will at this point and with a suspected bad port I wouldn't risk dropping the USB connection in middle of a flash.

Hastily spouted for your befuddlement
 
guider
Old
#5  
Member
Thanks Meter 3
Posts: 30
Join Date: Feb 2014
you may go to shop and rectify your problem
Tags
battery, won't charge
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes