Question [Q] Trying to reflash with stock firmware using JODIN3

After fooling around with CyanogenMod, I decided that I want to put the stock firmware back on my P3113. So I acquired the firmware from here: hxxp://samsung-updates.com/device/?id=GT-P3113 (which I then unpacked) and JODIN3 (Linux64) release 1035. I've already installed Heimdall with the packages pointed to from hxxp://glassechidna.com.au/heimdall/.

I started JODIN3, pressed the PDA button, and gave it the file "HOME_XAR_P3113UEUCMK3_1978026_REV04_user_low_ship .tar.md5". It wants to get a pit file from the device. I let it do that and put the tablet back into download mode. Then I pressed "start". JODIN3 then complained that the firmware file was corrupt. I tried a few more times. The unzip program on my computer seemed satisfied that the zipfile was not corrupt. Tar seemed satisfied that the tar file within was not corrupt.

I then tried feeding JODIN3 the zipfile itself. That caused JODIN3 to ask to download a pit, which I allowed. I pressed "start" and then it complained that the pit file was corrupt.

After repeating the above several times, I tried again with the .tar.md5 file. That seemed to do something. The spew in the xterm in which I
started JODIN3 flashed the names of the six file contained within. The spew then kept printing stuff about "heimdall detect" confirming that a
device was attached. Nothing new was printed to the JODIN3 GUI. I let it sit there for 30 minutes. Nothing -- not even a complaint of
something being corrupt. Scrolling back in the xterm, I saw this:

Exception in thread "Thread-103" java.lang.OutOfMemoryError: Java heap space
at CASUAL.communicationstools.heimdall.odin.OdinFile. extractOdinContents(OdinFile.java:145)
at CASUAL.communicationstools.heimdall.odin.Odin.getH eimdallFileParametersFromOdinFile(Odin.java:50)
at com.casual_dev.jodin.JOdinController.getHeimdallCo mmandFromOdinPackageList(JOdinController.java:619)
at com.casual_dev.jodin.JOdinController.access$3300(J OdinController.java:53)
at com.casual_dev.jodin.JOdinController$13.run(JOdinC ontroller.java:570)
at java.lang.Thread.run(Thread.java:744)
[DEBUG]Run Heimdall from
DeviceCommunicationProtocol:/usr/local/bin/heimdall detect

Now, the questions: Am I doing anything wrong here? Can somone suggest a known-good version of JODIN3? I quick check of my system gives me to reason to suspect I'm legitimately out of memory.

Using regular Odin isn't an option because I don't use Windows and I can't make it work with Virtualbox. I hear there are problems inherent to emulation that prevent Odin from working correctly there. Trying to run the plain jar file doesn't work because it complains that it needs a newer version of Java. I'm running OpenJDK7 and that seems to be what the Linux64 package uses. Someone, please help me out here.