Watch This Now!

[SOLVED] Koush's (clockworkmod) Superuser not working on Stock 4.2.2

421 posts
Thanks Meter: 142
By kaizokan, Senior Member on 12th April 2014, 05:35 PM
Post Reply Subscribe to Thread Email Thread
Koush's (clockworkmod) Superuser ( installs with no problems, the problem is: root is not recognized by apps.
AFWall+ states something like: Could not acquire root access... and "error purging iptables"
SuperSU app works fine though. Is superuser disabling root when installed...??

I have tried:
- Rootkit zip with busybox and SuperSU, then switched to superuser (by cleaning superSU in app)
- Direct superuser install after rooting with busybox.
- Installing superuser after removing knox with SuperSU.
- factory reset, clearing data and cache
- Reflash rom and recovery

I have tried both methods: from recovery and superuser.apk

on: Stock 4.2.2 (I9195XXUBML4)
with: recovery-clockwork-


Caused by:
Originally Posted by AndreiLux

...a new "feature" / CONFIG_SEC_RESTRICT_SETUID in the kernel.

This means no more rooting is possible, at least not anymore in the usual methods. Your SuperUser will tell you it will have granted access, but it's neutered on the kernel level.

Solved by:
More info about this root prevention / security measure here:
Github koush/Superuser: android 4.2+ seteuid (root) failed with 13:
Last edited by kaizokan; 16th April 2014 at 08:38 PM. Reason: solved
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes