[Q] Tasker and WIFI question

211 posts
Thanks Meter: 33
By joelstitch, Senior Member on 11th April 2014, 01:57 AM
Post Reply Subscribe to Thread Email Thread
I am trying to get Tasker to turn Airplane mode when the wifi is disconnected IF theres no cell signal and then turn airplane mode off again agter 2 seconds. At the momnt this is what I got:

Airplane mode ON using Secure Settings.
Not Wifi Connected >
Airplane mode OFF usinf Secure Settings

Airplane Mode ON:
1. Configuration: Airplane Mode Enabled
If: %CELLSRV ~ noservice

2. Wait 3 seconds

Airplane Mode OFF
Configuration: Airplane Mode Disabled
IF: %AIR ~ On

When I press the PLAY button on the task it does turns on Airplane mode but when I test it by turning off my wifi it shows that the Task is active but Airplane mode is not turned on.

what can I do?
Last edited by joelstitch; 12th April 2014 at 07:12 PM.
12th April 2014, 07:06 PM |#2  
OP Senior Member
Flag Minneapolis
Thanks Meter: 33
So I think I got it working. I removed the Wifi Off part since I found it kinda useless for this profile. So now whenever I dont have any service for more than 10 seconds Tasker will turn on Airplane Mode on and 10 seconds after that it will turn it off.

State - Variable Value

%CELLSRV ~ noservice


1. Wait - Seconds - 10s
2. Secure Settings - Airplane Mode Enabled 
                              If: %CELLSRV ~ noservice
3. Wait - Seconds - 10s
4. Secure Settings- Airplane Mode Disabled 
                             If: %AIR ~ On
If anyone could test it and let me know if it works that would be great.
Last edited by joelstitch; 12th April 2014 at 07:13 PM.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes