Post Reply Subscribe to Thread Email Thread

[Q] Tasker and WIFI question

11th April 2014, 12:57 AM   |  #1  
OP Senior Member
Flag Minneapolis
Thanks Meter: 33
 
196 posts
Join Date:Joined: Jan 2012
More
I am trying to get Tasker to turn Airplane mode when the wifi is disconnected IF theres no cell signal and then turn airplane mode off again agter 2 seconds. At the momnt this is what I got:


Airplane mode ON using Secure Settings.
Not Wifi Connected >
Airplane mode OFF usinf Secure Settings

Airplane Mode ON:
1. Configuration: Airplane Mode Enabled
If: %CELLSRV ~ noservice

2. Wait 3 seconds

Airplane Mode OFF
Configuration: Airplane Mode Disabled
IF: %AIR ~ On

When I press the PLAY button on the task it does turns on Airplane mode but when I test it by turning off my wifi it shows that the Task is active but Airplane mode is not turned on.

what can I do?
Last edited by joelstitch; 12th April 2014 at 06:12 PM.
12th April 2014, 06:06 PM   |  #2  
OP Senior Member
Flag Minneapolis
Thanks Meter: 33
 
196 posts
Join Date:Joined: Jan 2012
More
So I think I got it working. I removed the Wifi Off part since I found it kinda useless for this profile. So now whenever I dont have any service for more than 10 seconds Tasker will turn on Airplane Mode on and 10 seconds after that it will turn it off.

Code:
State - Variable Value

%CELLSRV ~ noservice

TASK

1. Wait - Seconds - 10s
2. Secure Settings - Airplane Mode Enabled 
                              If: %CELLSRV ~ noservice
3. Wait - Seconds - 10s
4. Secure Settings- Airplane Mode Disabled 
                             If: %AIR ~ On
If anyone could test it and let me know if it works that would be great.
Last edited by joelstitch; 12th April 2014 at 06:13 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes