Post Reply

Xperia mic and proximity problem

OP chikuera

5th April 2014, 04:33 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
18 posts
Join Date:Joined: Jul 2012
First it was a speaker automatically turns on during call,
Then the mic doesnt works during call but surprising working well in recording apps and in service test(both mic working)
Now the proximity sensor isnt working.. help me
[IMG][/IMG]
9th April 2014, 06:29 PM   |  #2  
Junior Member
Flag Calgary
Thanks Meter: 2
 
8 posts
Join Date:Joined: Jul 2013
More
Quote:
Originally Posted by chikuera

First it was a speaker automatically turns on during call,
Then the mic doesnt works during call but surprising working well in recording apps and in service test(both mic working)
Now the proximity sensor isnt working.. help me
[IMG][/IMG]

I have the same problem with the calls!! my mic works fine in recording apps, but it doesn't work with the phone. However it works making calls via Skype, I'm so frustated with this. I think it started happening since we updated to 4.3
9th April 2014, 11:32 PM   |  #3  
Bassheadzero's Avatar
Member
Flag São Paulo
Thanks Meter: 2
 
76 posts
Join Date:Joined: Nov 2008
More
Please verify the kernel you're using.. I'm was with that problems and the problem is a kernel from an previous ROM version
13th April 2014, 01:39 AM   |  #4  
Senior Member
Thanks Meter: 14
 
100 posts
Join Date:Joined: Aug 2012
i have same problem too....in test(service test, xperia diagnostic, recorder) both microphone is ok no problem....but during call....other people can't hear my voice(too low)...and the weird problem...during call i can hear my own voice in ear speaker....i 'm already disable microphone noise suspression and reflash stock rom with clean install too...unlucky the problem was appeared after my warranty ended ...please help me...sorry for bad english
Last edited by Kylez; 13th April 2014 at 01:44 AM. Reason: lol
13th April 2014, 05:58 AM   |  #5  
Senior Member
Flag Bangalore
Thanks Meter: 98
 
454 posts
Join Date:Joined: Jun 2012
More
Quote:
Originally Posted by chikuera

First it was a speaker automatically turns on during call,
Then the mic doesnt works during call but surprising working well in recording apps and in service test(both mic working)
Now the proximity sensor isnt working.. help me
[IMG][/IMG]

For proximity calibration you need to do a factory reset. every sony phones will give same error without factory reset. you can test it by keeping auto brightness on. if it changes according to the background lighting well you can say its working. however mic problem two reason. either water or dust might have entered in the part of mic or there will be a coating on the top of mic which might have been moved a bit which makes it difficult to make calls only.

take it to service or use to manuals the open it yourself to check it out.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes