Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,012 Members 53,750 Now Online
XDA Developers Android and Mobile Development Forum

DevShaft's Backup TA stuck on integrity check

Tip us?
 
gwhite5
Old
(Last edited by gwhite5; 14th April 2014 at 06:43 AM.) Reason: Mistake, which may lead to some thinking my phone is boot loader unlocked.
#1  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Mar 2014
Prompt DevShaft's Backup TA stuck on integrity check

SOLVED I just had to restart the script.

Today I decided to unlock my boot loader after still experiencing lag and force closes in .201.

I wanted to backup my TA though, so after reading threads I chose DevShaft's Backup TA batch scripts, which got stuck on "INTEGRITY CHECK".

I quickly searched it up after half an hour of it stuck on this screen and found a post where it got stuck on "BACKING UP TA..." only to find that this could kill an Xperia device. I panicked, re read it and found that I was not experiencing the same problem. I checked the batch scripts for where it could get stuck at and if it could kill my phone.

I'm not sure whether it's fine, and my phone will not be bricked and I can try again or unlock the boot loader. I am on the .257 firmware.

Any ideas? The only thing I am worried about is that the command it is stuck at is running under su.

EDIT: My phone is an SIM-free, locked boot loader C5303, and am running the tool on Windows 8.1 64-bit. Reading the batch source, I have identified the place where it has got stuck on - the command to check the MD5 of the .img file on the phone. This doesn't seem to be harmful to my phone but it is plugged in the back of the PC and charging in case.
 
noahvt
Old
#2  
noahvt's Avatar
Senior Member
Thanks Meter 293
Posts: 1,074
Join Date: Jan 2013
Did you try to backup after the unlock? Because a unlock of bootloader will wipe the TA partition, you need to back it up before bootloader unlock

Sent from my C5303 using xda app-developers app
MY DEVICES:

XPERIA SP (C5303)
-CPU: 1.7ghz(DUAL) QUALCOMM SNAPDRAGON S4 PRO
-RAM: 1GB
-BOARD: MSM8960T
-GPU: Adreno 320
-ROM: [KK 4.4.3] OFFICIAL CM11 Nightly
-KERNEL: [CM11]Williams kernel V2


Asus Transformer tf300t (CARDHU)
-CPU: 1.8GHz( QUAD, OC ) TEGRA3 T30L
-RAM: 1GB
-BOARD: Cardhu
-GPU: TEGRA3
-ROM: MULTIBOOT: Xubuntu, ubuntu touch, cm11, Cromi-X, omni, Dirty Unicorns
 
gwhite5
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Mar 2014
Default Thanks for replying quickly

Quote:
Originally Posted by noahvt View Post
Did you try to backup after the unlock? Because a unlock of bootloader will wipe the TA partition, you need to back it up before bootloader unlock

Sent from my C5303 using xda app-developers app
Thank you for replying quickly. No, I have not unlocked the boot loader yet. My phone is a C5303, and I am using my brother's gaming rig to do it, as I have a Mac and two computers running Linux.
 
gwhite5
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Mar 2014
Smile Solved!

Just restarted it and it worked fine after exiting Sony PC companion.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes