FORUMS

Please help me with this

170 posts
Thanks Meter: 10
 
By kumar8904, Senior Member on 13th April 2014, 03:59 PM
Post Reply Subscribe to Thread Email Thread
Xperia u display problem
Will anyone help me? my little xperia u display dead due to sweat.The phone connecting in flashboot and fastboot and i also used ics official firmware via flashtool but again displaying only black.phone vibrates when i start my phone but sony logo doesn't come.there is only black screen.i kept in sun due to this white form made up on half of the screen.
 
 
13th April 2014, 04:03 PM |#2  
XperienceD's Avatar
Senior Member
Flag Here =)
Thanks Meter: 2,508
 
More
Quote:
Originally Posted by kumar8904

Xperia u display problem
Will anyone help me? my little xperia u display dead due to sweat.The phone connecting in flashboot and fastboot and i also used ics official firmware via flashtool but again displaying only black.phone vibrates when i start my phone but sony logo doesn't come.there is only black screen.i kept in sun due to this white form made up on half of the screen.

If there is water in the display which has damaged something then no amount of flashing is going to help. Leave it a bowl of rice over night and if still doesn't power on then you'll need a service centre.
14th April 2014, 04:13 AM |#3  
OP Senior Member
Flag chennai
Thanks Meter: 10
 
More
Quote:
Originally Posted by XperienceD

If there is water in the display which has damaged something then no amount of flashing is going to help. Leave it a bowl of rice over night and if still doesn't power on then you'll need a service centre.

The phone is power on and everything fine even i can connect it to my pc led light also working illumination strip also very fine only display is showing nothing just black when touch the screen the sounds are hearable i dono wat happened since touch screen and everything working fine and i dont have warranty also bootloader unlocked
14th April 2014, 04:58 AM |#4  
Senior Member
Thanks Meter: 636
 
Donate to Me
More
The LCD / LCD flex cable has been damaged or the part of the motherboard that controls the LCD. You would need to take it apart and look for corrosion on the motherboard and flex cable. It's possible leaving it open and letting it dry out might help. Liquid damage is unpredictable. If you don't see any signs of corrosion then you could buy a new LCD and give it a shot.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes