Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Phone unable to charge

OP Chilidog

15th April 2014, 05:55 AM   |  #1  
Chilidog's Avatar
OP Senior Member
Thanks Meter: 112
 
653 posts
Join Date:Joined: Oct 2013
OK so this just started happening yesterday and it's really annoying... I will plug my phone in while using like chrome or something and it will tell me I'm using too much power and it can't charge... This doesn't make sense when I am only using one app. It has never happened until yesterday and now it always does it... I am using Google the original cable and charger. Has anyone else had this happen? Idk what to do
15th April 2014, 07:48 AM   |  #2  
cmlusco's Avatar
Senior Member
Flag Michigan City, IN
Thanks Meter: 931
 
3,146 posts
Join Date:Joined: Nov 2010
Donate to Me
More
I have had it happen once when i guess my charger went bad. Switched to the charger from my old phone and have never seen the message since. Could be a charger, a cord, or a battery issue. I would try a different cord and charger.
15th April 2014, 08:14 AM   |  #3  
Chilidog's Avatar
OP Senior Member
Thanks Meter: 112
 
653 posts
Join Date:Joined: Oct 2013
Quote:
Originally Posted by cmlusco

I have had it happen once when i guess my charger went bad. Switched to the charger from my old phone and have never seen the message since. Could be a charger, a cord, or a battery issue. I would try a different cord and charger.

Sounds good thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes