5,599,677 Members 45,492 Now Online
XDA Developers Android and Mobile Development Forum

[ROMS]Mass CM Thread

Tip us?
 
atscntsc
Old
#161  
Member
Thanks Meter 24
Posts: 39
Join Date: Dec 2012
Location: Bangkok
Quote:
Originally Posted by cars1189 View Post
If you can provide app name logs and what not maybe i can help? It seems like its a app issues though.
Below is a portion of logcat output produced from an attempt to play an MP3 (Cloud Nothings - Stay Useless.mp3) through Google Play Music.

Code:
D/LocalAsyncMediaPlayer( 1654): Event logging MUSIC_START_PLAYBACK_REQUESTED: 291/: local playback

I/ExtendedUtils(  152): AV Sync late margin : Intended=40ms Using=0ms

D/AwesomePlayer(  152): Before reset_l

D/AwesomePlayer(  152): printFileName fd(30) -> /storage/sdcard0/Music/Cloud Nothings - Stay Useless.mp3

D/ExtendedUtils(  152): extended extractor not needed, return default

E/AwesomePlayer(  152): LPAPlayer::Clip duration setting of less than 30sec not supported, defaulting to 60sec

D/AwesomePlayer(  152): matchComponentName is set to MP3Decoder 166844081, mime audio/mpeg

E/MediaPlayer( 1654): error (1, -2147483648)

E/LocalAsyncMediaPlayer( 1654): Track: [291, DEFAULT] : Prepare failed.: status=0x1

E/LocalAsyncMediaPlayer( 1654): java.io.IOException: Prepare failed.: status=0x1

E/LocalAsyncMediaPlayer( 1654): 	at android.media.MediaPlayer.prepare(Native Method)

E/LocalAsyncMediaPlayer( 1654): 	at com.google.android.music.playback.LocalAsyncMediaPlayer.setDataSourceImpl(LocalAsyncMediaPlayer.java:500)

E/LocalAsyncMediaPlayer( 1654): 	at com.google.android.music.playback.LocalAsyncMediaPlayer.handleMessageImp(LocalAsyncMediaPlayer.java:207)

E/LocalAsyncMediaPlayer( 1654): 	at com.google.android.music.playback.LocalAsyncMediaPlayer.handleMessage(LocalAsyncMediaPlayer.java:187)

E/LocalAsyncMediaPlayer( 1654): 	at android.os.Handler.dispatchMessage(Handler.java:102)

E/LocalAsyncMediaPlayer( 1654): 	at com.google.android.music.utils.LoggableHandler.dispatchMessage(LoggableHandler.java:72)

E/LocalAsyncMediaPlayer( 1654): 	at android.os.Looper.loop(Looper.java:136)

E/LocalAsyncMediaPlayer( 1654): 	at android.os.HandlerThread.run(HandlerThread.java:61)

W/LocalDevicePlayback( 1654): Failed to open MusicId ([291, DEFAULT]) for playback

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.playbackfailed

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.playbackfailed

I/LocalAsyncMediaPlayer( 1654): Requesting import of media store

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

V/ArtResolver( 1920): getArt containerDescriptor=[19, 291, usele, <null>, <null>], mixDescriptor=null type=QUEUE_HEADER

V/QueueHeaderView( 1920): Enabling click handling

V/ArtResolver( 1920): startSingleSongLookup: ArtRequest{mArtType=QUEUE_HEADER, mImages=[], mContainerDescriptor=[19, 291, usele, <null>, <null>], mMixDescriptor=null, mNeededItems=[]}

I/Icing   ( 1091): Indexing CB8C41A4416319F7D280BA10ECDE61F47B56F98A from com.google.android.music

V/ArtResolver( 1920): extractAlbumIdsFromUri: uri: content://com.google.android.music.MusicContent/audio/291, cursor mined: 1 album covers found

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.metachanged

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.metachanged

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

V/ArtResolver( 1920): notifyIfDone: ArtRequest{mArtType=QUEUE_HEADER, mImages=[], mContainerDescriptor=[19, 291, usele, <null>, <null>], mMixDescriptor=null, mNeededItems=[]}

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

V/ArtResolver( 1920): onLoadFinished ArtRequest{mArtType=QUEUE_HEADER, mImages=[], mContainerDescriptor=[19, 291, usele, <null>, <null>], mMixDescriptor=null, mNeededItems=[]}

V/QueueHeaderView( 1920): updateHeaderViews request=ArtRequest{mArtType=QUEUE_HEADER, mImages=[], mContainerDescriptor=[19, 291, usele, <null>, <null>], mMixDescriptor=null, mNeededItems=[]}, removeListener=true

V/QueueHeaderView( 1920): setArtImageOrDefault request=ArtRequest{mArtType=QUEUE_HEADER, mImages=[], mContainerDescriptor=[19, 291, usele, <null>, <null>], mMixDescriptor=null, mNeededItems=[]}

V/QueueArtRenderer( 1920): makeArtForBitmaps artCount=0, slotWidth=480, w=480, h=90

V/QueueArtRenderer( 1920): width: 480, height=90, scale=1.0, scaledBmpWidth=540

V/QueueHeaderView( 1920): updateBackground: isLandscape=false, drawable=android.graphics.drawable.ColorDrawable@41db96b8, width=480

I/MediaStoreImporter( 1654): Update: incremental Added music: 0 Updated music: 0 Deleted music: 0 Created playlists: 0 Updated playlists: 0 Deleted playlists: 0 Inserted playlist items: 0 Deleted playlist items: 0 Removed orphaned playlist items: 0

I/Icing   ( 1091): Indexing done CB8C41A4416319F7D280BA10ECDE61F47B56F98A

W/AudioTrack(  514): AUDIO_OUTPUT_FLAG_FAST denied by client due to mismatching sample rate (48000 vs 44100)

D/AudioFlinger(  152): start(4098), calling pid 514 session 43

D/AudioFlinger(  152): ? => ACTIVE (4098) on thread 0x1047148

W/InputMethodManagerService(  514): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@4195c4e8 attribute=null, token = android.os.BinderProxy@41e8c9c8

W/AudioTrack(  514): AUDIO_OUTPUT_FLAG_FAST denied by client due to mismatching sample rate (48000 vs 44100)

D/AudioFlinger(  152): start(4100), calling pid 514 session 44

D/AudioFlinger(  152): ? => ACTIVE (4100) on thread 0x105a380

W/AudioTrack(  514): AUDIO_OUTPUT_FLAG_FAST denied by client due to mismatching sample rate (48000 vs 44100)

D/AudioFlinger(  152): start(4098), calling pid 514 session 45

D/AudioFlinger(  152): ? => ACTIVE (4098) on thread 0x1047148

I/MediaFocusControl(  514):   Remote Control   registerMediaButtonIntent() for PendingIntent{41e15c70: PendingIntentRecord{41e84ec8 com.google.android.music broadcastIntent}}

V/MediaFocusControl(  514): updating focussed RCC change to RCD: CallingPackageName:com.google.android.music isFocussed:false isAvailable:true

I/MusicStore( 1654): caqPlay: descriptor=[19, 291, usele, <null>, <null>]

D/MusicStore( 1654): caqPlay: descriptor=[19, 291, usele, <null>, <null>] tracksCursor.size=1 shuffleContainer=false containerPlayPosition=0 sprinkle=false

D/MusicStore( 1654): caqPlay: queueSize=0 requestedSize=1 sizeToAdd=1

D/MusicStore( 1654): caqGetItemOrderExtreme: order=0

D/NowPlayingFragment( 1920): onLoadFinished: Cursor updated: count=1

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.metachanged

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.metachanged

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

I/LocalDevicePlayback( 1654): open: id=[291, DEFAULT], pos=0, playPos=0, fromUser=true, track=Stay Useless

D/MusicStore( 1654): caqGetItemIdAndOrder: id=1063 order=-1

D/LocalAsyncMediaPlayer( 1654): Event logging MUSIC_START_PLAYBACK_REQUESTED: 291/: local playback

I/ExtendedUtils(  152): AV Sync late margin : Intended=40ms Using=0ms

D/AwesomePlayer(  152): Before reset_l

D/AwesomePlayer(  152): printFileName fd(30) -> /storage/sdcard0/Music/Cloud Nothings - Stay Useless.mp3

D/ExtendedUtils(  152): extended extractor not needed, return default

E/AwesomePlayer(  152): LPAPlayer::Clip duration setting of less than 30sec not supported, defaulting to 60sec

D/AwesomePlayer(  152): matchComponentName is set to MP3Decoder 166844081, mime audio/mpeg

E/MediaPlayer( 1654): error (1, -2147483648)

E/LocalAsyncMediaPlayer( 1654): Track: [291, DEFAULT] : Prepare failed.: status=0x1

E/LocalAsyncMediaPlayer( 1654): java.io.IOException: Prepare failed.: status=0x1

E/LocalAsyncMediaPlayer( 1654): 	at android.media.MediaPlayer.prepare(Native Method)

E/LocalAsyncMediaPlayer( 1654): 	at com.google.android.music.playback.LocalAsyncMediaPlayer.setDataSourceImpl(LocalAsyncMediaPlayer.java:500)

E/LocalAsyncMediaPlayer( 1654): 	at com.google.android.music.playback.LocalAsyncMediaPlayer.handleMessageImp(LocalAsyncMediaPlayer.java:207)

E/LocalAsyncMediaPlayer( 1654): 	at com.google.android.music.playback.LocalAsyncMediaPlayer.handleMessage(LocalAsyncMediaPlayer.java:187)

E/LocalAsyncMediaPlayer( 1654): 	at android.os.Handler.dispatchMessage(Handler.java:102)

E/LocalAsyncMediaPlayer( 1654): 	at com.google.android.music.utils.LoggableHandler.dispatchMessage(LoggableHandler.java:72)

E/LocalAsyncMediaPlayer( 1654): 	at android.os.Looper.loop(Looper.java:136)

E/LocalAsyncMediaPlayer( 1654): 	at android.os.HandlerThread.run(HandlerThread.java:61)

W/LocalDevicePlayback( 1654): Failed to open MusicId ([291, DEFAULT]) for playback

I/LocalAsyncMediaPlayer( 1654): Requesting import of media store

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.playbackfailed

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.playbackfailed

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.metachanged

D/NowPlayingFragment( 1920): onReceive: action=com.android.music.metachanged

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

D/BufferProgressListener( 1920): updateCurrentSong: [291, DEFAULT]

V/QueueHeaderView( 1920): update mix=null, container=[19, 291, usele, <null>, <null>]

I/MediaStoreImporter( 1654): Update: incremental Added music: 0 Updated music: 0 Deleted music: 0 Created playlists: 0 Updated playlists: 0 Deleted playlists: 0 Inserted playlist items: 0 Deleted playlist items: 0 Removed orphaned playlist items: 0

W/AudioTrack(  514): AUDIO_OUTPUT_FLAG_FAST denied by client due to mismatching sample rate (48000 vs 44100)

D/AudioFlinger(  152): start(4099), calling pid 514 session 47

D/AudioFlinger(  152): ? => ACTIVE (4099) on thread 0x1045180

W/InputMethodManagerService(  514): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@42018c60 attribute=null, token = android.os.BinderProxy@41e8c9c8
 
cars1189
Old
(Last edited by cars1189; 21st March 2014 at 02:27 AM.)
#162  
Senior Member - OP
Thanks Meter 347
Posts: 387
Join Date: Jun 2009
Location: Atlanta
Quote:
Originally Posted by atscntsc View Post
Below is a portion of logcat output produced from an attempt to play an MP3 (Cloud Nothings - Stay Useless.mp3) through Google Play Music.
so i did a bit of reasearch and it seems like its a common problem with the google play music app. I coulda swore it was working last night and it might have something to do with lpa as i switch that on at some point and now its not working. So you can try that but also some poeple said

Quote:
Originally Posted by dellenrules View Post
Had this same issue.
Went to settings/app and cleared data for the music app.
Re-loaded the app. Selected my google account. Then everything worked perfectly.
Other than that theres nothing i can do as it seems to be a google play music error. You could maybe try loading an old version of the app if you use something like titanium backup and have a copy or something....but other than those two things theres nothing i can do.

@atscntsc @ otherstoo
Edit: ok so i can confirm it is infact a problem with lpa and some apps. you can disable it in the /system/build.prop just set both lpa options to false.

Code:
lpa.decode=false
lpa.use-stagefright=false
It is only in some apps though and happens with stock roms too in some cases so im not sure it can be fixed. In the chance that it is fixable rom or kernel side i have told the AriesVE-DevCon-TEAM and arco since they are the ones who have gotten lpa to where it is now about the issue and well see if they have any ideas.
The Following User Says Thank You to cars1189 For This Useful Post: [ Click to Expand ]
 
cars1189
Old
(Last edited by cars1189; 21st March 2014 at 02:36 AM.)
#163  
Senior Member - OP
Thanks Meter 347
Posts: 387
Join Date: Jun 2009
Location: Atlanta
Quote:
Originally Posted by jfbs View Post
LPA isn't routing to headphones and is still disabled in their system.prop.
@jfbs If you use their kernel and audio-caf it works now idk if they changed something recently or what but there are some fairly new commits and i can confirm it does work. I plug/unpluged speakers in multiple times over and over and it switched every time.

Edit: Also the error with it selecting the wrong song seems to have just been a glitch when i was just testing now for the lpa issue it was selecting fine.
 
jfbs
Old
#164  
Senior Member
Thanks Meter 387
Posts: 229
Join Date: May 2012
This log is suspect and was recently added to fw/av: W/AudioTrack( 514): AUDIO_OUTPUT_FLAG_FAST denied by client due to mismatching sample rate (48000 vs 44100).

I'm testing a build from Monday and mp3's play without an issue using play music and Apollo.

If anyone is up to it, try editing the build.prop and either remove af.resampler.quality=255, or change 255 to 4. Otherwise, the device may be missing some libs.
 
atscntsc
Old
(Last edited by atscntsc; 21st March 2014 at 03:55 AM.)
#165  
Member
Thanks Meter 24
Posts: 39
Join Date: Dec 2012
Location: Bangkok
Quote:
Originally Posted by cars1189 View Post
Edit: ok so i can confirm it is infact a problem with lpa and some apps. you can disable it in the /system/build.prop just set both lpa options to false.

Code:
lpa.decode=false
lpa.use-stagefright=false
Setting the props to false solved the problem with mp3 playback.
The Following User Says Thank You to atscntsc For This Useful Post: [ Click to Expand ]
 
wrusry
Old
#166  
Senior Member
Thanks Meter 43
Posts: 159
Join Date: Jan 2011
Location: Austin
Quote:
Originally Posted by atscntsc View Post
Setting the props to false solved the problem with mp3 playback.
This also corrected my problem. Thanks, Cars! I had flashed the kernel as well prior to chaning the props to false. I assume that both were necessary or is it only changing lpa options necessary?

I'm giving the ROM a good try now.
 
cars1189
Old
(Last edited by cars1189; 24th March 2014 at 05:25 AM.)
#167  
Senior Member - OP
Thanks Meter 347
Posts: 387
Join Date: Jun 2009
Location: Atlanta
Quote:
Originally Posted by wrusry View Post
This also corrected my problem. Thanks, Cars! I had flashed the kernel as well prior to chaning the props to false. I assume that both were necessary or is it only changing lpa options necessary?

I'm giving the ROM a good try now.
Both are needed. with just rom you get no audio with rom+kernel you get some audio. With both you get audio all the time normal.

Edit: Also for those that wana try imo gps is already improved in this last build over the others however i have a new config that i think has improved it. I havent tried it much but it seems to be more consistantly better.
New Config : http://d-h.st/jXe
Original Config : http://d-h.st/WFQ

Both flashable cwm zips. IF you want give it a try and if it overall seems better maybe ill include it in next update. I do believe though that it will work best on tmobile so if you are not on that carrier you can try but it may have a bad effect instead of better. Which is why im not sure if i should include it. Let me know!
The Following User Says Thank You to cars1189 For This Useful Post: [ Click to Expand ]
 
atscntsc
Old
(Last edited by atscntsc; 24th March 2014 at 09:36 PM.)
#168  
Member
Thanks Meter 24
Posts: 39
Join Date: Dec 2012
Location: Bangkok
Quote:
Originally Posted by cars1189 View Post
Also for those that wana try imo gps is already improved in this last build over the others however i have a new config that i think has improved it. I havent tried it much but it seems to be more consistantly better.
Flashed the GPS update to test. Seems fine, although GPS was working well with last build also. I use GPS for navigation and both versions of config seem to lock quickly and track accurately.
I am running on T-Moble network.
 
cars1189
Old
(Last edited by cars1189; 16th April 2014 at 04:35 AM.)
#169  
Senior Member - OP
Thanks Meter 347
Posts: 387
Join Date: Jun 2009
Location: Atlanta
Quote:
Originally Posted by atscntsc View Post
Flashed the GPS update to test. Seems fine, although GPS was working well with last build also. I use GPS for navigation and both versions of config seem to lock quickly and track accurately.
I am running on T-Moble network.
Yea both are pretty much the same but with the new config it stores your location between sessions. So sometimes when you first start it itll have a accuracy of like 1000ft+ but then once it updates it goes down really fast as it updates the stored location from where you last used it. It also adds a ntp server setting that was pressent in stock rom that for w.e. reason cyanogenmod didnt include thats non carrier specific. Also i did add a setting that is carrier specific. Idk well see i guess how it turns out overall. Sometimes it seems like the time of day can affect if so ill keep trying at different times and what not and maybe i can get an idea of how and what works best.
The Following User Says Thank You to cars1189 For This Useful Post: [ Click to Expand ]
 
cars1189
Old
#170  
Senior Member - OP
Thanks Meter 347
Posts: 387
Join Date: Jun 2009
Location: Atlanta
New CM11 up. Might be doing less 10.2 builds...not alot is changeing.

The Following 2 Users Say Thank You to cars1189 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes