Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,619 Members 46,469 Now Online
XDA Developers Android and Mobile Development Forum

[Q] How to get my HTC One up and running again?

Tip us?
 
damithark
Old
#31  
damithark's Avatar
Senior Member - OP
Thanks Meter 26
Posts: 165
Join Date: Jul 2010
Location: Colombo
Exclamation Passed the early barrier

Thanks for all the help you gave before. I manage to install SlimKat Rom 3.8 it passes the barrier that I had earlier. Setup wizard goes just fine. But my Sim card is not recognized. I even installed CM11 rom and it has the same issue.

Baseband: Unknown.
IMEI: empty.

My guess is that there's a hardware issue. What do you think I should do?. Any ideas?.

On the other hand, My device is still under warranty. So do you think may be I can get it prepared (With Bootloader locked and with a Original RUU)?.

Thanks.
Dam.
HTC One (International)


 
nkk71
Old
#32  
nkk71's Avatar
Recognized Contributor
Thanks Meter 2696
Posts: 5,456
Join Date: May 2010
Location: Beirut
Quote:
Originally Posted by damithark View Post
Thanks for all the help you gave before. I manage to install SlimKat Rom 3.8 it passes the barrier that I had earlier. Setup wizard goes just fine. But my Sim card is not recognized. I even installed CM11 rom and it has the same issue.

Baseband: Unknown.
IMEI: empty.

My guess is that there's a hardware issue. What do you think I should do?. Any ideas?.

On the other hand, My device is still under warranty. So do you think may be I can get it prepared (With Bootloader locked and with a Original RUU)?.

Thanks.
Dam.
Sorry didnt get back to you earlier, a couple of busy days. But unfortunately, if

Quote:
In any booted ROM, if you go to "Settings -> About -> Software information -> More" does baseband show up correctly?
and "Settings -> About -> Phone identity" shows correct IMEI, IMSI?

Is it giving you:
Baseband version - unknown
IMEI - Unknown
IMEI SV - Unknown
IMSI - unavailable
and you are not on a Sprint device with a GSM flashed frimware/ROM, and the "fastboot getvar all" shows baseband correctly, then unfortunately it's off to repair. there are a couple of other threads like yours... don't have any links around, but you can search for them. 99% were unsolvable even with a complete RUU.

unless there have been any updates (?)
The Following User Says Thank You to nkk71 For This Useful Post: [ Click to Expand ]
Tags
htc one, stock sense
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes