Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Samsung Galaxy S III - No Sound When Calling or Recieving (Please Help)

OP niestar

15th April 2014, 09:28 AM   |  #1  
OP Junior Member
Flag Manzini
Thanks Meter: 0
 
1 posts
Join Date:Joined: Apr 2014
Hi Guys

I have a major issue, im not sure what to do.
a have a GT-I9300, all of a sudden my speaker like muted some how when i try make a call or receive a call.
the dialer makes the beep that the call is being made, but theres just no sound, even if i try put on the loudspeaker, no sound comes through.
however, i can make calls with viber, line and skype, they all work properly, the mic is also working well.
ive rooted the phone, installed a custom rom, reflashed it to stock with odin, and nothing happens.
its just the same, i dont know what to , i need some help. ive also tried connecting headphones, its all the same.. no difference.
i dont understand why its only when i try call out and receive. everything else works properly.

Please help
16th April 2014, 10:44 AM   |  #2  
Member
Thanks Meter: 2
 
44 posts
Join Date:Joined: Mar 2012
This is very unusual..

Try to flash a stock rom and than do the Return To New command ##RTN# ##786#.. this should format the phone and ofcourse deletes everything on it so be sure to save your data.

That's all I could think of to do.

Good luck.
16th April 2014, 12:04 PM   |  #3  
droidshan's Avatar
Member
Thanks Meter: 4
 
54 posts
Join Date:Joined: Oct 2013
More
Quote:
Originally Posted by niestar

Hi Guys

I have a major issue, im not sure what to do.
a have a GT-I9300, all of a sudden my speaker like muted some how when i try make a call or receive a call.
the dialer makes the beep that the call is being made, but theres just no sound, even if i try put on the loudspeaker, no sound comes through.
however, i can make calls with viber, line and skype, they all work properly, the mic is also working well.
ive rooted the phone, installed a custom rom, reflashed it to stock with odin, and nothing happens.
its just the same, i dont know what to , i need some help. ive also tried connecting headphones, its all the same.. no difference.
i dont understand why its only when i try call out and receive. everything else works properly.

Please help

I had seen the same issue on s3 once before. there will be no sound for calling( including earpiece), music , notification etc..
what I found was a culprit sound recording app which was causing the problem. I dont know what will be urs problem but first of all check for any audio related app.
all the best
16th April 2014, 09:38 PM   |  #4  
Junior Member
Flag Ermelo
Thanks Meter: 5
 
22 posts
Join Date:Joined: Apr 2014
More
This seems like a common Samsung problem but I have not yet seen a fix! It happened once on my mums GS3 (GT-i9300) and also on my friend's GS4s (He has 2)

Sent from my Galaxy Pocket running CM 7.2
The Following User Says Thank You to ToXiFi3d For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes