Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] T-Mobile 4G (not LTE) speeds issue

OP elesbb

16th April 2014, 10:39 PM   |  #1  
elesbb's Avatar
OP Senior Member
Thanks Meter: 4,468
 
6,922 posts
Join Date:Joined: Jun 2010
Donate to Me
More
Hey guys. I love T-Mobile. But lately I have gotten horrible data speeds on 4G (not LTE). The average for the past three days has been 50 - 70 KB/s

Thats horrible. I remember I used to get 270 KB/s.

I am running my own ROM with the NB4 baseband installed.

My brother has the S3 and his speeds are pretty much the same as mine.

Are there any ROM tweaks to boost my speed or is T-Mobile throttling me? Or does their speeds literally just suck?

When I am in LTE I get AMAZING speeds no issues nothing. Just RAW FAST sweet speeds.

Its just 4G that sucks. And sadly thats all i get at my house (where i use most of my data)

If i were to call T-Mobile, what do you think could be done about it?

What are your 4G (not LTE) data speeds like??

I'm not sure if its my area or their network.
Kinda getting irritated by it. I feel like im back on Sprint.
16th April 2014, 10:54 PM   |  #2  
Android_Monsters's Avatar
Senior Member
Flag Los Angeles
Thanks Meter: 965
 
3,248 posts
Join Date:Joined: Feb 2012
More
If you call ask for a free cellular repeater.

Sent from my SGH-M919 using XDA Premium 4 mobile app
16th April 2014, 11:04 PM   |  #3  
elesbb's Avatar
OP Senior Member
Thanks Meter: 4,468
 
6,922 posts
Join Date:Joined: Jun 2010
Donate to Me
More
Quote:
Originally Posted by Android_Monsters

If you call ask for a free cellular repeater.

Sent from my SGH-M919 using XDA Premium 4 mobile app

Already have the cel fi rs1. Thought that was the problem but even outside it's still the same.

Sent from my SGH-M919 using Tapatalk
16th April 2014, 11:09 PM   |  #4  
brian117's Avatar
Senior Member
Flag Cleveland, OH
Thanks Meter: 200
 
452 posts
Join Date:Joined: Feb 2011
Donate to Me
More
It's possible you're being throttled. What plan do you have with T-Mobile? If you're like me on the $30 text and data plan, they throttle your 4G speeds after 5GB. If you're not past the 5GB limit, then it could just be the tower you're connecting to. Contact T-Mobile and give them your address so they can search for any possible errors. They have a Live Chat option you can use to get a faster response. Let them know of the problem so they can investigate it further.
16th April 2014, 11:32 PM   |  #5  
elesbb's Avatar
OP Senior Member
Thanks Meter: 4,468
 
6,922 posts
Join Date:Joined: Jun 2010
Donate to Me
More
Quote:
Originally Posted by brian117

It's possible you're being throttled. What plan do you have with T-Mobile? If you're like me on the $30 text and data plan, they throttle your 4G speeds after 5GB. If you're not past the 5GB limit, then it could just be the tower you're connecting to. Contact T-Mobile and give them your address so they can search for any possible errors. They have a Live Chat option you can use to get a faster response. Let them know of the problem so they can investigate it further.

I have the truly unlimited data plan so thats why i was a little weary about me being throttled. They better not be or i'll flip. Its weird, when i do a speed test, the speed jumps up to the normal 170 - 270 KB/s then goes way down to 50. And my LTE speed is 1 MB/s which is good but i remember getting about 2.3 - 3 MB/s.

I guess i'll just give em a call. May Odin back to MDL stock and check just to make sure its not a ROM issue.

I am still wondering what you guys are getting on 4G speeds. I really do feel like im back on Sprint.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes