Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,791 Members 47,377 Now Online
XDA Developers Android and Mobile Development Forum

Bluetooth controller pairing fine, but not actually connecting!

Tip us?
 
marvin_rock
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jun 2010
Default Bluetooth controller pairing fine, but not actually connecting!

I just recently got a PhoneJoy Play controller, and I know that it works as it connects to my roommates phones/tablets (Motorola Droid 4{running Eclipse ROM}, Nexus 5 & Nexus 7 {both stock}), but it refuses to connect to my Droid Razr MAXX (XT912).

I can see the device, I can pair with it, but when I click to connect, nothing changes and it doesn't connect. Other bluetooth headsets work just fine, I don't have any other bluetooth input devices to test on this phone, but is this something I can fix?

Here are the ROM's I've all had the same issue with -
AOKP
PACman ROM
Eclipse (current, which I really quite like!)

I'm starting to hear about issues with it being a Bluetooth HID device, but I'm confused if the droid 4 with the Eclipse ROM can run it perfectly, why can't the droid RAZR run it?

The only strange variable I have is that I'm using ROM slot 2, not sure if that matter at all, any help would be much appreciated!
 
marvin_rock
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jun 2010
Default An Update

Okay, so I've had a few hours to play with the phone, and here are my updates, but I'm still stumped.

Okay, so here's the short and skinny.

Bought a PhoneJoy Play on Kickstarter, it just got here, works on my Droid 4 running an Eclipse ROM, works on a stock Nexus 5 and stock Nexus 7 with no issues, pairs, connects, plays.

My Droid RAZR (my personal phone, the others listed belonged to roommates), it will pair, but not connect on any ROM I throw at it. Here's what I've tried so far.

Cyanogenmod KitKat variant
Cyanogenmod JB Variant
SlimKat
AOKP
PACman ROM
Eclipse
Aviator Blur

They all experience the exact same issue. Sees the controller, pairs, won't connect. Just doesn't connect. Drives me bonkers.

I load up the stock ROM via safestrap, works right away and breaks my heart because I can't STAND the stock Ice Cream Sandwich ROM, it's old, bloated with Verizon BS, half my other apps don't work, etc etc.

Why doesn't this thing work on a Custom ROM and how can I get it to work!? Note, bluetooth headsets work fine, just appears to be an issue with the HID support.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes