Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] broken inhouse charging

OP ranjib

13th April 2014, 10:25 AM   |  #1  
OP Senior Member
Thanks Meter: 28
 
246 posts
Join Date:Joined: Nov 2010
Charging my SGS becomes impossible now after 4 years. Although ist shows the charging symbol, my device doesn't charge the battery. Can anybody explain the following screenshot? I run nightly cm11 from pawtip in the most recent nightly...

17th April 2014, 07:39 PM   |  #2  
Gokulbalram's Avatar
Senior Member
Flag Pune
Thanks Meter: 110
 
541 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by ranjib

Charging my SGS becomes impossible now after 4 years. Although ist shows the charging symbol, my device doesn't charge the battery. Can anybody explain the following screenshot? I run nightly cm11 from pawtip in the most recent nightly...

Most probably a hardware issue. You might want to get it to the nearest Samsung Service Center and get the USB Port (or whatever you call it) replaced
17th April 2014, 11:12 PM   |  #3  
OP Senior Member
Thanks Meter: 28
 
246 posts
Join Date:Joined: Nov 2010
I tried to fix the USB port. I teared down my mobile until I got the USB port in my hands and put the pcb under my microscope. I saw a corroded connection from the port to the motherboard. But I don't have a proper solder unit to repair that. So I tried with my big fat soldering iron....and killed one connection. I managed to repair that, so I have the same faulty mobile as before. My next try will be a wireless charging mod (with parts from a palm mobile).
But I bought a spare I9000 already for 50 Euros......
Last edited by ranjib; 18th April 2014 at 10:55 AM.
The Following User Says Thank You to ranjib For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
battery charging cm11
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes