Default [Q] PPTP VPN Routing Issue

I am having some problems with connecting my devices to my server through PPTP VPN. My setup is a DD-WRT router running PPTPd. I can connect to it with my Android over LTE just fine, can surf the internet and can ping devices within my LAN. My subnet is 192.168.0.x, with 192.168.0.1 being the router, 192.168.0.2-99 reserved for static internal IPs, 192.168.0.100-150 reserved for dynamic internal IPs (the DHCP range), and 192.168.0.201-253 reserved for PPTP VPN. My PPTP VPN server is set up as 192.168.0.200, which is the same physical device as 192.168.0.1.

The problem is that devices physically connected my router cannot ping Android nodes connected over VPN. This seems to be an Android issue. When I took my windows 7 laptop to a cafe, connected it to the cafe's network and connected to my home network over VPN, the ping worked both ways. Devices that were physically in my house could ping my windows laptop and my windows laptop could ping them.

I tried the same thing with my Nexus 5 and Nexus 10, both could not be pinged from inside the house (although my Nexus devices could ping devices inside the house).

I am using 4.4.2 KitKat on both my nexus devices and connecting using the built-in PPTP settings menus. Can anyone throw a suggestion my way?

Thanks!
Phone:
History: Motorola V220 -> Motorola RAZR -> HTC Wizard (Hello XDA!) -> HTC Touch -> Blackberry Curve 8330 -> Samsung Galaxy S III SGH-I747M
Current: Google Nexus 5 (stock: used in a corporate environment)

Tablet:
History: Viewsonic G-Tablet -> Asus EEE Pad Transformer (it's making a thief in Antwerp, Belgium very happy right now)
Current: Google Nexus 10 (stock: used in a corporate environment)

Other people's devices I look after:
HTC One X (stock)
Google Nexus 7 (stock)