FORUMS
Post Reply Subscribe to Thread Email Thread

Lots of lag

18th April 2014, 09:42 PM |#1  
OP Senior Member
Flag Southport
Thanks Meter: 24
 
More
Recently got this and i am shocked it lags so much everywhere. Laggy in the homescreen and apps takes 10 secs to open apps such as xda. I expected a snapdragon 600 with 2gb ram was top notch.... please why does this lag is it beacuse of kitkat?

Sent from my LG-V500 using XDA Premium 4 mobile app
 
 
18th April 2014, 10:01 PM |#2  
Senior Member
Flag Rio de Janeiro
Thanks Meter: 49
 
More
Quote:
Originally Posted by dec1153

Recently got this and i am shocked it lags so much everywhere. Laggy in the homescreen and apps takes 10 secs to open apps such as xda. I expected a snapdragon 600 with 2gb ram was top notch.... please why does this lag is it beacuse of kitkat?

Sent from my LG-V500 using XDA Premium 4 mobile app

I doubt it. I just opened the XDA app in roughly 2 seconds, plus a few to load the list of course, but that is not the tablet. Most apps take 1-2 seconds, except deliberately slow ones such as Kindle.
18th April 2014, 10:10 PM |#3  
OP Senior Member
Flag Southport
Thanks Meter: 24
 
More
I am not joking. My tab just froze and went on a black screen and would.not respond for 5 mins, i have rebooted and so far it seems a tad faster

Sent from my LG-V500 using XDA Premium 4 mobile app
19th April 2014, 12:05 AM |#4  
sleekmason's Avatar
Senior Member
Flag Fayetteville
Thanks Meter: 358
 
More
Quote:
Originally Posted by dec1153

I am not joking. My tab just froze and went on a black screen and would.not respond for 5 mins, i have rebooted and so far it seems a tad faster

Sent from my LG-V500 using XDA Premium 4 mobile app

No, that's not right. You have something going on wrong with the tablet. I would look to see what apps are running. Maybe something doing something it shouldn't? That would be my guess.
A custom ROM may serve you better if you feel up to the change.
19th April 2014, 12:17 AM |#5  
OP Senior Member
Flag Southport
Thanks Meter: 24
 
More
Quote:
Originally Posted by sleekmason

No, that's not right. You have something going on wrong with the tablet. I would look to see what apps are running. Maybe something doing something it shouldn't? That would be my guess.
A custom ROM may serve you better if you feel up to the change.

Thank god!! Now since i rebooted a few times it no longer lags... how strange.

Sent from my LG-V500 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes