Default Metasploit framework

Currently I'm running xposed framework and the pen testing application i'm running asked me to update my metasploit framework. Will metasploit interfere with xposed?
Everyone needs some love, so if I helped don't forget to click thanks.

Device list:
Evo 4G - Lost
Galaxy S2 - Retired
Galaxy S3 - Sold
Galaxy Note 3 - Rooted stock 4.4.2
Galaxy Gear 2 Neo - Root has been achieved!