Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Google Invites Selected Devs to Buy Project Tango Development Kit

Just about a month ago, the curious Project Tango development kit was … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] LG Optimus L3 usb not connecting but charging

OP Bosskardo

21st March 2014, 10:59 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Mar 2014
More
Hello
My phone: LG E400
rom: SDmerge+ miniCM (not sure if the problem is connected with that as everything was fine at the beginning)

All of a sudden my phone didn't show usb connection any more. No connection is shown in the phone or PC, but the phone is charging.
I tried all usb connection options, usb debugging on/off, no result.
Uninstalled all phone drivers in my PC and reinstalled LG driver, nothing.
Tried another usb cable and another PC, the same problem.
Also tried turning off my phone while connected, no help.

Please help me.

Don't know if it helps but I once saw a strange message in Titanium backup while usb was connected (this was after the problem started, so no usb connection was shown, usb debugging was on). It only happened once, so I'm not 100% sure what it said but it was sth about that I should turn on usb debugging.
22nd March 2014, 06:17 AM   |  #2  
IGGYVIP's Avatar
Senior Member
Flag Emerald
Thanks Meter: 296
 
759 posts
Join Date:Joined: Feb 2014
Donate to Me
More
Thumbs up
Quote:
Originally Posted by Bosskardo

Hello
My phone: LG E400
rom: SDmerge+ miniCM (not sure if the problem is connected with that as everything was fine at the beginning)

All of a sudden my phone didn't show usb connection any more. No connection is shown in the phone or PC, but the phone is charging.
I tried all usb connection options, usb debugging on/off, no result.
Uninstalled all phone drivers in my PC and reinstalled LG driver, nothing.
Tried another usb cable and another PC, the same problem.
Also tried turning off my phone while connected, no help.

Please help me.

Don't know if it helps but I once saw a strange message in Titanium backup while usb was connected (this was after the problem started, so no usb connection was shown, usb debugging was on). It only happened once, so I'm not 100% sure what it said but it was sth about that I should turn on usb debugging.

message is fine thats mode for special apps to control phone from pc or when using adb

there is a program to see if phone fully not detected "Advanced USB Port Monitor" it will show all the requests to usb

seems like you need a flash because usbmanager is part of system and i'm not sure if possible to reinstall
wait a little if not in rush maybe someone else can help @slipsystem @AwesomeSMS
24th March 2014, 06:17 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by IGGYVIP

message is fine thats mode for special apps to control phone from pc or when using adb

there is a program to see if phone fully not detected "Advanced USB Port Monitor" it will show all the requests to usb

seems like you need a flash because usbmanager is part of system and i'm not sure if possible to reinstall
wait a little if not in rush maybe someone else can help @slipsystem @AwesomeSMS

I did format and flashed rom again but it didn't solve it. Does this mean its a hardware issue for sure?
24th March 2014, 06:40 PM   |  #4  
IGGYVIP's Avatar
Senior Member
Flag Emerald
Thanks Meter: 296
 
759 posts
Join Date:Joined: Feb 2014
Donate to Me
More
Question
Quote:
Originally Posted by Bosskardo

I did format and flashed rom again but it didn't solve it. Does this mean its a hardware issue for sure?

can you access phone using adb ?
how did you flash ?
25th March 2014, 12:35 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by IGGYVIP

can you access phone using adb ?
how did you flash ?

No, phone doesn't show up as adb device
I copied rom files to sd card and flashed from recovery.
25th March 2014, 04:27 PM   |  #6  
IGGYVIP's Avatar
Senior Member
Flag Emerald
Thanks Meter: 296
 
759 posts
Join Date:Joined: Feb 2014
Donate to Me
More
Thumbs up
Quote:
Originally Posted by Bosskardo

No, phone doesn't show up as adb device
I copied rom files to sd card and flashed from recovery.

TRY THIS http://forum.xda-developers.com/show....php?t=2660144

did you try to access phone using adb in recovery mode ? (not cwm !) does it recognise phone in lgmobile support tool whire in recovery mode?
if you can then try to recovery mode flash new stock firmware
if not leave it because if anything happens to your cwm you will be stuck until you get usb port/controller (i think controller) repaired (yes its most likely hardware damage)


you could also ask if anyone will provide you with .img partition dumps and then adb wifi sideload them (HARD AND DANGEROUS)
13th April 2014, 09:20 AM   |  #7  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by IGGYVIP

TRY THIS http://forum.xda-developers.com/show....php?t=2660144

did you try to access phone using adb in recovery mode ? (not cwm !) does it recognise phone in lgmobile support tool whire in recovery mode?
if you can then try to recovery mode flash new stock firmware
if not leave it because if anything happens to your cwm you will be stuck until you get usb port/controller (i think controller) repaired (yes its most likely hardware damage)


you could also ask if anyone will provide you with .img partition dumps and then adb wifi sideload them (HARD AND DANGEROUS)

No, LG support tool doesn't recognize it. I gave up on usb, just been using bt and wifi transfer (not the best solutions but at least I can transfer data).

But sth happened a few days ago. I plugged it in to my laptop for charging and suddenly it connected. It showed as device in the computer. But then I looked at my phone, it was connected as media device. I don't know why but I changed the connection to usb storage straigth away and lost the connection. Changing back to media device and replugging doesn't connect any more, it still charges.
What could that be about?
14th April 2014, 04:20 AM   |  #8  
george brown's Avatar
Senior Member
Thanks Meter: 26
 
177 posts
Join Date:Joined: Sep 2011
Quote:
Originally Posted by Bosskardo

No, LG support tool doesn't recognize it. I gave up on usb, just been using bt and wifi transfer (not the best solutions but at least I can transfer data).

But sth happened a few days ago. I plugged it in to my laptop for charging and suddenly it connected. It showed as device in the computer. But then I looked at my phone, it was connected as media device. I don't know why but I changed the connection to usb storage straigth away and lost the connection. Changing back to media device and replugging doesn't connect any more, it still charges.
What could that be about?

Actually the problem is on your windows not on your phone.
Last edited by george brown; 19th April 2014 at 05:09 PM.
14th April 2014, 05:34 PM   |  #9  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by george brown

Actally the problem is on your windows not on your phone.

I've tried it on another computer (Vista, mine is win7).
20th April 2014, 05:57 AM   |  #10  
george brown's Avatar
Senior Member
Thanks Meter: 26
 
177 posts
Join Date:Joined: Sep 2011
Quote:
Originally Posted by Bosskardo

I've tried it on another computer (Vista, mine is win7).

If the problem is not from your windows then try to reinstall your cusrom. Or try another cusrom.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes