Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,985 Members 41,092 Now Online
XDA Developers Android and Mobile Development Forum

[Q] LG Optimus L3 usb not connecting but charging

Tip us?
 
Bosskardo
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Mar 2014
Question [Q] LG Optimus L3 usb not connecting but charging

Hello
My phone: LG E400
rom: SDmerge+ miniCM (not sure if the problem is connected with that as everything was fine at the beginning)

All of a sudden my phone didn't show usb connection any more. No connection is shown in the phone or PC, but the phone is charging.
I tried all usb connection options, usb debugging on/off, no result.
Uninstalled all phone drivers in my PC and reinstalled LG driver, nothing.
Tried another usb cable and another PC, the same problem.
Also tried turning off my phone while connected, no help.

Please help me.

Don't know if it helps but I once saw a strange message in Titanium backup while usb was connected (this was after the problem started, so no usb connection was shown, usb debugging was on). It only happened once, so I'm not 100% sure what it said but it was sth about that I should turn on usb debugging.
 
IGGYVIP
Old
#2  
IGGYVIP's Avatar
Senior Member
Thanks Meter 156
Posts: 557
Join Date: Feb 2014
Location: Emerald
Quote:
Originally Posted by Bosskardo View Post
Hello
My phone: LG E400
rom: SDmerge+ miniCM (not sure if the problem is connected with that as everything was fine at the beginning)

All of a sudden my phone didn't show usb connection any more. No connection is shown in the phone or PC, but the phone is charging.
I tried all usb connection options, usb debugging on/off, no result.
Uninstalled all phone drivers in my PC and reinstalled LG driver, nothing.
Tried another usb cable and another PC, the same problem.
Also tried turning off my phone while connected, no help.

Please help me.

Don't know if it helps but I once saw a strange message in Titanium backup while usb was connected (this was after the problem started, so no usb connection was shown, usb debugging was on). It only happened once, so I'm not 100% sure what it said but it was sth about that I should turn on usb debugging.
message is fine thats mode for special apps to control phone from pc or when using adb

there is a program to see if phone fully not detected "Advanced USB Port Monitor" it will show all the requests to usb

seems like you need a flash because usbmanager is part of system and i'm not sure if possible to reinstall
wait a little if not in rush maybe someone else can help @slipsystem @AwesomeSMS
I NEED HELP WITH THIS THREAD LG E430

 
ALL TIME FAVOURITE DAILY OG MILESTONE GSM
Kernel OR 2ndboot 2.6.32.60-cust-gcc9164c
Rom CM9
Custom OC 1100Mhz 75Vsel

Dual Boot UBUNTU 14 / WINDOWS 7


NEED ROOT ? TRY VROOT YOUTUBE GUIDE

MY GUIDE ON HOW TO ASK QUESTIONS

DETAILS !!! *i need detailed details to help you
THERE IS A REASON THANKS BUTTON IS HERE
 
 
Bosskardo
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Mar 2014
Quote:
Originally Posted by IGGYVIP View Post
message is fine thats mode for special apps to control phone from pc or when using adb

there is a program to see if phone fully not detected "Advanced USB Port Monitor" it will show all the requests to usb

seems like you need a flash because usbmanager is part of system and i'm not sure if possible to reinstall
wait a little if not in rush maybe someone else can help @slipsystem @AwesomeSMS
I did format and flashed rom again but it didn't solve it. Does this mean its a hardware issue for sure?
 
IGGYVIP
Old
#4  
IGGYVIP's Avatar
Senior Member
Thanks Meter 156
Posts: 557
Join Date: Feb 2014
Location: Emerald
Quote:
Originally Posted by Bosskardo View Post
I did format and flashed rom again but it didn't solve it. Does this mean its a hardware issue for sure?
can you access phone using adb ?
how did you flash ?
I NEED HELP WITH THIS THREAD LG E430

 
ALL TIME FAVOURITE DAILY OG MILESTONE GSM
Kernel OR 2ndboot 2.6.32.60-cust-gcc9164c
Rom CM9
Custom OC 1100Mhz 75Vsel

Dual Boot UBUNTU 14 / WINDOWS 7


NEED ROOT ? TRY VROOT YOUTUBE GUIDE

MY GUIDE ON HOW TO ASK QUESTIONS

DETAILS !!! *i need detailed details to help you
THERE IS A REASON THANKS BUTTON IS HERE
 
 
Bosskardo
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Mar 2014
Quote:
Originally Posted by IGGYVIP View Post
can you access phone using adb ?
how did you flash ?
No, phone doesn't show up as adb device
I copied rom files to sd card and flashed from recovery.
 
IGGYVIP
Old
#6  
IGGYVIP's Avatar
Senior Member
Thanks Meter 156
Posts: 557
Join Date: Feb 2014
Location: Emerald
Quote:
Originally Posted by Bosskardo View Post
No, phone doesn't show up as adb device
I copied rom files to sd card and flashed from recovery.
TRY THIS http://forum.xda-developers.com/show....php?t=2660144

did you try to access phone using adb in recovery mode ? (not cwm !) does it recognise phone in lgmobile support tool whire in recovery mode?
if you can then try to recovery mode flash new stock firmware
if not leave it because if anything happens to your cwm you will be stuck until you get usb port/controller (i think controller) repaired (yes its most likely hardware damage)


you could also ask if anyone will provide you with .img partition dumps and then adb wifi sideload them (HARD AND DANGEROUS)
I NEED HELP WITH THIS THREAD LG E430

 
ALL TIME FAVOURITE DAILY OG MILESTONE GSM
Kernel OR 2ndboot 2.6.32.60-cust-gcc9164c
Rom CM9
Custom OC 1100Mhz 75Vsel

Dual Boot UBUNTU 14 / WINDOWS 7


NEED ROOT ? TRY VROOT YOUTUBE GUIDE

MY GUIDE ON HOW TO ASK QUESTIONS

DETAILS !!! *i need detailed details to help you
THERE IS A REASON THANKS BUTTON IS HERE
 
 
Bosskardo
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Mar 2014
Quote:
Originally Posted by IGGYVIP View Post
TRY THIS http://forum.xda-developers.com/show....php?t=2660144

did you try to access phone using adb in recovery mode ? (not cwm !) does it recognise phone in lgmobile support tool whire in recovery mode?
if you can then try to recovery mode flash new stock firmware
if not leave it because if anything happens to your cwm you will be stuck until you get usb port/controller (i think controller) repaired (yes its most likely hardware damage)


you could also ask if anyone will provide you with .img partition dumps and then adb wifi sideload them (HARD AND DANGEROUS)
No, LG support tool doesn't recognize it. I gave up on usb, just been using bt and wifi transfer (not the best solutions but at least I can transfer data).

But sth happened a few days ago. I plugged it in to my laptop for charging and suddenly it connected. It showed as device in the computer. But then I looked at my phone, it was connected as media device. I don't know why but I changed the connection to usb storage straigth away and lost the connection. Changing back to media device and replugging doesn't connect any more, it still charges.
What could that be about?
 
george brown
Old
(Last edited by george brown; 19th April 2014 at 04:09 PM.)
#8  
george brown's Avatar
Senior Member
Thanks Meter 21
Posts: 162
Join Date: Sep 2011
Quote:
Originally Posted by Bosskardo View Post
No, LG support tool doesn't recognize it. I gave up on usb, just been using bt and wifi transfer (not the best solutions but at least I can transfer data).

But sth happened a few days ago. I plugged it in to my laptop for charging and suddenly it connected. It showed as device in the computer. But then I looked at my phone, it was connected as media device. I don't know why but I changed the connection to usb storage straigth away and lost the connection. Changing back to media device and replugging doesn't connect any more, it still charges.
What could that be about?
Actually the problem is on your windows not on your phone.
 
Bosskardo
Old
#9  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Mar 2014
Quote:
Originally Posted by george brown View Post
Actally the problem is on your windows not on your phone.
I've tried it on another computer (Vista, mine is win7).
 
george brown
Old
#10  
george brown's Avatar
Senior Member
Thanks Meter 21
Posts: 162
Join Date: Sep 2011
Quote:
Originally Posted by Bosskardo View Post
I've tried it on another computer (Vista, mine is win7).
If the problem is not from your windows then try to reinstall your cusrom. Or try another cusrom.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Samsung Gear Live Stock Firmware Image Pulled, Temp Root

Just yesterday,XDA Recognized Developer and TV ProducerAdamOutlertore apart … more

Draw a Line and Let Your Device Do the Rest with LineitApp

Over the years, since evenbefore Android entered the scene, we have striven to … more

[APK] Chrome Beta 37 Brings First Traces of Material Design

With Android L on the horizon, it’s no surprise that Google’s … more

Immersive Mode on Unrooted Devices with GMD Full Screen Immersive Mode

Everyone likes screen real estate–no question about that. The … more