Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Need help installing a ROM on a Samsung Galaxy S4 (Verizon)

OP Snake2k

20th April 2014, 09:53 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2014
Soooo.... I rooted my Samsung Galaxy S4 (SCH-I545), then I decided to install a custom ROM since the default TouchWiz rom is slower than a turtle stuck in a pile of wax. I installed Safestrap 3.71 (TWRP v2.6.3.1) and by mistake flashed my stock rom. Now my phone won't boot into any ROM since that is corrupt, but it still boots into recovery (that's a good thing I suppose). I have tried a number of Safestrap compatible roms (omni, cm, beanstalk) but they either end up giving me a black screen or a very weird looking pixelated blue/cyan screen. I have to remove the battery to reboot my phone. I tried using adb to wipe the data aswell but nothing works beyond recovery.
I have to rely on adb to push and pull data to and from the phone.
I was hoping if anyone had any idea what I should try to do next?
20th April 2014, 10:40 AM   |  #2  
Senior Member
Thanks Meter: 591
 
3,106 posts
Join Date:Joined: May 2010
Donate to Me
More
Probably best just to restart by flashing the stock firmware back to it with Odin.

Make sure you don't try to downgrade the firmware vs what you have now, as that can create a lot more issues than you want to deal with.
20th April 2014, 10:44 AM   |  #3  
Member
Flag Vienna
Thanks Meter: 19
 
57 posts
Join Date:Joined: Dec 2013
More
Quote:
Originally Posted by Snake2k

Soooo.... I rooted my Samsung Galaxy S4 (SCH-I545), then I decided to install a custom ROM since the default TouchWiz rom is slower than a turtle stuck in a pile of wax. I installed Safestrap 3.71 (TWRP v2.6.3.1) and by mistake flashed my stock rom. Now my phone won't boot into any ROM since that is corrupt, but it still boots into recovery (that's a good thing I suppose). I have tried a number of Safestrap compatible roms (omni, cm, beanstalk) but they either end up giving me a black screen or a very weird looking pixelated blue/cyan screen. I have to remove the battery to reboot my phone. I tried using adb to wipe the data aswell but nothing works beyond recovery.
I have to rely on adb to push and pull data to and from the phone.
I was hoping if anyone had any idea what I should try to do next?

Have you cleared cache?
If you are not able to flash a custom rom, I would recommend you to flash a stock rom and begin from new. Also if you are on Android 4.4 you cannot use any recovery.

Sent from my GT-I9505 using XDA Premium 4 mobile app
20th April 2014, 10:47 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2014
Quote:
Originally Posted by es0tericcha0s

Probably best just to restart by flashing the stock firmware back to it with Odin.

Make sure you don't try to downgrade the firmware vs what you have now, as that can create a lot more issues than you want to deal with.

I'm just gonna give the Hyperdrive ROM a go, if that doesn't work, I'll definitely just go back to Stock I suppose and see what happens next. Thanks!

Quote:
Originally Posted by ikuni123

Have you cleared cache?
If you are not able to flash a custom rom, I would recommend you to flash a stock rom and begin from new. Also if you are on Android 4.4 you cannot use any recovery.

Sent from my GT-I9505 using XDA Premium 4 mobile app

Yep I cleared everything, weird problem lol. Its not 4.4 cus Verizon never released any for their S4s, but I'll definitely just head back to stock after I give Hyperdrive a chance Thanks!
20th April 2014, 10:52 AM   |  #5  
Senior Member
Thanks Meter: 591
 
3,106 posts
Join Date:Joined: May 2010
Donate to Me
More
Quote:
Originally Posted by Snake2k

I'm just gonna give the Hyperdrive ROM a go, if that doesn't work, I'll definitely just go back to Stock I suppose and see what happens next. Thanks!



Yep I cleared everything, weird problem lol. Its not 4.4 cus Verizon never released any for their S4s, but I'll definitely just head back to stock after I give Hyperdrive a chance Thanks!


http://forum.xda-developers.com/show....php?t=2634408

According to that, only 13 is supported. I dunno if the that thread hasn't been updated or whatever, but something to consider.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes