Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,360 Members 54,100 Now Online
XDA Developers Android and Mobile Development Forum

Camera stops working often after cwm 6.0.4.8 on aosp roms

Tip us?
 
RealiableCandy4
Old
#1  
RealiableCandy4's Avatar
Senior Member - OP
Thanks Meter 37
Posts: 151
Join Date: Dec 2013
Default Camera stops working often after cwm 6.0.4.8 on aosp roms

I'm not sure if I'm the only one experiencing this but every time I try to flash a custom kernel on CM11 and PA4 with cwm 6...4.8 camera app freezes like usual but then freezes again after 5 secs which is not usual.

Not only does this happen on custom kernals but stock CM11 and PA as well e.g. when I was in the science museum using PA taking pics everything was working well, then phone froze so I did a reboot in fact 5 reboots and camera displayed same symptoms as explained above. Also on CM11 stock kernal I did a regular reboot to apply full theme and bam camera stopped working all AF a sudden.

To fix I had to reflash ROM. I even did a full wipe( including format system) and still had same symptoms.

Pimped kernal just breaks camera straight from reboot no matter how many times I reboot it doesn't fix the problem. Only fix seems to reflash ROM (no need to wipe). Restoring stock/original ROM kernel fixes it but WiFi does not work.

Any way to get custom kernels to work without breaking camera?
 
eclyptos
Old
#2  
eclyptos's Avatar
Senior Member
Thanks Meter 612
Posts: 2,990
Join Date: Jun 2008
Location: Planet Earth
..just an advice, do not use CWM, is recommended to flash with TWRP because is more efficient. I had many problems with CWM.
IF I HELPED DO NOT SAY THANKS, CLICK IT.
My Evolution: Sony Xperia Z1 - UB + 4.3 Rooted + Deodexed, HTC HD2, HTC Diamond 2, HTC HD Blackstone, Nokia 7070 Prism, Qtek 9100, Nokia 3100, Motorola T720i, Nokia 3310, Sony Ericson PF 768 (Blue)

How Get Root on Sony Xperia Z1 with Locked Bootloader and the Latest Android 4.4
 
RealiableCandy4
Old
#3  
RealiableCandy4's Avatar
Senior Member - OP
Thanks Meter 37
Posts: 151
Join Date: Dec 2013
Quote:
Originally Posted by eclyptos View Post
..just an advice, do not use CWM, is recommended to flash with TWRP because is more efficient. I had many problems with CWM.
Thanks for the reply. I have no option but to use cwm cause all my back ups where done on cwm.

As for the problem I found the solution in this thread:

http://forum.xda-developers.com/show....php?t=2505973

yup owns Z1 and stuff.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes